Bug 5082 - Boot into Xterm after shrinking of partitions
: Boot into Xterm after shrinking of partitions
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-20 13:53 MSK by Shalok Shalom
Modified: 2015-02-21 16:20 MSK (History)
1 user (show)

See Also:
RPM Package: dont know
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-02-20 13:53:40 MSK
Description of problem:

After GRUB, ROSA boot directly into a Xterm instance, sometimes with the default (root) wallpaper, sometimes with a black screen. startkde fix this.

Version-Release number of selected component (if applicable):

2014.1

How reproducible:

Always

Steps to Reproduce:

1. I shrink  the /home and / partition of ROSA and guess, this creates the error.
2. I think, its not (really) reproduce able.
3. Just send me a fix for this please. This device is for an old man, which get confused, when he have to input a command each time on startup. :)

When this happens the very first time, it happens on a already booted ROSA session and results in KDM. As we log in there, the issue happens the first time.

Please let me know, if i can send you any details, here is a hw-probe:

http://hw.rosalinux.ru/index.php?probe=a9d9c445dc
Comment 1 Andrey Ponomarenko 2015-02-20 19:05:52 MSK
Try to remove nvidia drivers: sudo urpme dkms-nvidia340 x11-driver-video-nvidia340

And reconfigure nouveau graphics: XFdrake

And then reboot.
Comment 2 Shalok Shalom 2015-02-20 20:23:29 MSK
I do that with both, free and non free drivers and it takes no effect.
Comment 3 Shalok Shalom 2015-02-21 16:16:21 MSK
Boot into Xterm means boot into recovery mode: it t would have been nice if you make me aware about that ;)

I was not aware about it, because i choose automatic login:

Recovery mode was set as the default login option, that was the issue.
Comment 4 Shalok Shalom 2015-02-21 16:20:47 MSK
For other users: 

Change in your login manager (where you type in your password) the boot option from recovery mode to KDE/LXDE/what ever. 

In the default log in manager (KDM) is that available in the settings menu on the lower left: http://www.rosalab.com/system/images/13/medium/KDM.png?1345203603

I hope, that helps