Bug 5073 - [UPDATE REQUEST] draklive-install-1.49-1
: [UPDATE REQUEST] draklive-install-1.49-1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-18 21:59 MSK by Konstantin Vlasov
Modified: 2015-02-21 15:00 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
konstantin.vlasov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2015-02-18 21:59:49 MSK
Installer update.
Comment 1 Konstantin Vlasov 2015-02-18 22:09:11 MSK
https://abf.rosalinux.ru/build_lists/2430187
https://abf.rosalinux.ru/build_lists/2430188

Advisory: Added bootloader option for linking os-probed systems instead of embedding them.

(Requires updates from bug #5061.)

Test iso image is on its way...
Comment 2 Konstantin Vlasov 2015-02-19 00:48:39 MSK
ISO image:
https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/9437

How to test:
When installation reaches the "Setup Bootloader" stage, click "Advanced" and turn on the last checkbox ("Add secondary systems as links to grub.cfg"). If you have other systems installed, they will be added to the boot menu as links to respective grub.cfg files instead of direct boot entries.
Comment 3 Vladimir Potapov 2015-02-20 17:22:24 MSK
The ISO-image don't load in EFI mode (blue box after menu select)
Comment 4 Konstantin Vlasov 2015-02-20 18:50:07 MSK
Cannot confirm, here in VirtualBox with UEFI mode it boots successfully.
Maybe, download was corrupted? Check please the SHA sum of the image file, it should be 5c2a099fb6bc20f5c83c6747a445e74374adec06.
Comment 5 Vladimir Potapov 2015-02-20 20:06:57 MSK
(In reply to comment #4)
> Cannot confirm, here in VirtualBox with UEFI mode it boots successfully.
> Maybe, download was corrupted? Check please the SHA sum of the image file,
> it should be 5c2a099fb6bc20f5c83c6747a445e74374adec06.
Checksum ok. Non-efi install OK. The parameter work correct (with non-EFI).
Comment 6 Konstantin Vlasov 2015-02-20 20:33:32 MSK
1. What is "blue box"? Could you make a photo of the screen, please?

2. How long did you wait? If "blue box" is the Grub dark-blue console that appears in place of the boot menu, then it's normal to wait for some time until kernel and initrd are loaded (on my test machine it took ~12 seconds to booting).

I tested now also on the real machine, and still UEFI boots correctly in all 3 modes (Start, Install, Install in basic mode).

Anyway, this request was about draklive-install, and hanging just after Grub menu might be a problem somewhere else, it has nothing to do with the installer. The installer only starts after the timezone selection step (when partitioning dialog appears).
Comment 7 Vladimir Potapov 2015-02-21 05:04:05 MSK
Today I set up the iso correct (hardware problem?)
Comment 8 Vladimir Potapov 2015-02-21 05:05:32 MSK
draklive-install-1.49-1
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2430187/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2430188/x86_64/main/release/
************************* Advisory *********************
Added bootloader option for linking os-probed systems instead of embedding them.
********************************************************
QA Verified
Comment 9 Konstantin Vlasov 2015-02-21 15:00:00 MSK
(In reply to comment #7)
> hardware problem?

Might be... On one of the test notebooks we had strange problems: installing from USB flash disk hanged at random, arbitrary moments. The cause was discovered to be a USB port with loose connection, the contact was breaking now and then. After inserting the flash into a different USB port, everything worked without a glitch.