Bug 503 - 'module' object has no attribute '_RPMVSF_NODIGESTS
: 'module' object has no attribute '_RPMVSF_NODIGESTS
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 15:21 MSD by Alexander Khryukin
Modified: 2012-07-24 10:51 MSD (History)
2 users (show)

See Also:
RPM Package: mock-urpm
ISO-related:
Bad POT generating:
Upstream:
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Khryukin 2012-07-10 15:21:43 MSD
Description of problem:

mock-urpm-1.1.12-9




DEBUG: Clean SCM checkout directory
DEBUG: remove tree: /tmp/tmpTTp93e.mock-scm.zip
ERROR: 'module' object has no attribute '_RPMVSF_NODIGESTS'
Traceback (most recent call last):
  File "/usr/sbin/mock-urpm", line 494, in <module>
    def do_buildsrpm(config_opts, chroot, options, args):
  File "/usr/sbin/mock-urpm", line 806, in main
    do_rebuild(config_opts, chroot, args)
  File "<peak.util.decorators.rewrap wrapping __main__.do_rebuild at 0x0295E488>", line 3, in do_rebuild
    def do_rebuild(config_opts, chroot, srpms): return __decorated(config_opts, chroot, srpms)
  File "/usr/lib/python2.7/site-packages/mock_urpm/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/sbin/mock-urpm", line 454, in do_rebuild
    for hdr in mock_urpm.util.yieldSrpmHeaders(srpms):
  File "/usr/lib/python2.7/site-packages/mock_urpm/util.py", line 127, in yieldSrpmHeaders
    ts.setVSFlags(rpm.RPMVSF_NOHDRCHK|rpm.RPMVSF_NOSHA1HEADER|rpm.RPMVSF_NODSAHEADER|rpm.RPMVSF_NORSAHEADER|rpm.RPMVSF_NOMD5|rpm.RPMVSF_NODSA|rpm.RPMVSF_NORSA|rpm._RPMVSF_NODIGESTS|rpm._RPMVSF_NOSIGNATURES)
AttributeError: 'module' object has no attribute '_RPMVSF_NODIGESTS'
DEBUG: kill orphans





Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1.sudo urpmi mock-urpm
2.mock-urpm -vvvv --scm-enable --scm-option package=zip --scm-option branch=rosa2012lts
3.FAIL
Comment 1 Anton Kirilenko 2012-07-11 12:50:39 MSD
Please, provide the output of "rpm -q python-rpm".
Comment 2 Anton Kirilenko 2012-07-11 12:59:15 MSD
And one more: "pydoc rpm|grep _RPMVSF_NODIGESTS"
Comment 3 Alexander Khryukin 2012-07-11 16:47:05 MSD
rpm -q python-rpm
python-rpm-5.4.9-5-mdv2012.0.x86_64


pydoc rpm|grep _RPMVSF_NODIGESTS
nothing

Also i see
https://abf.rosalinux.ru/import/mock-urpm/commit/44f329e37a4c85a1db12f38828690d3767b14c0c
Comment 4 Anton Kirilenko 2012-07-11 17:46:28 MSD
It's about to be published :)
The flags causing the problem were needed for old rpm with segfaults during signature checking. I've removed those flags.
Comment 5 Anton Kirilenko 2012-07-11 19:25:34 MSD
The problem was fixed in release 11.

i586:    https://abf.rosalinux.ru/build_lists/622235
x86_64:  https://abf.rosalinux.ru/build_lists/622236

Advisory:
Some internal python-rpm flags were used by mock-urpm. It doesn't use these flags anymore. (We needed it as a workaround for bugged rpm version)


How to test: 
There are some minor changes. You can watch diff: https://abf.rosalinux.ru/import/mock-urpm/commit/0fb0defbe87658531ebe98c806047776f8364562
There are also some changes with symlinks creation (some kind of spec file refactoring).

You can also install the package on the system with rpm-5.4.9 and run mock-urpm.