Bug 5021 - HP 8510p: CPU get hot, sensors display eye-catching numbers
: HP 8510p: CPU get hot, sensors display eye-catching numbers
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Hardware
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Eugene Shatokhin
: Eugene Shatokhin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-07 21:08 MSK by Shalok Shalom
Modified: 2016-05-01 03:21 MSD (History)
0 users

See Also:
RPM Package: kernel-nrj-desktop-3.14.25-1rosa
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-02-07 21:08:16 MSK
Description of problem:

  https://paste.kde.org/p2m8cr9lc

  Be aware about temp 6: Always 100 degrees. Round Numbers in general.

  I run "sensors" 3 times for this pastebin, with 10 minutes interval) 


Version-Release number of selected component (if applicable):

  2014.1, same in the default Kernel of Open Mandriva 2015 Aplha LXQt


How reproducible:

  Always

Steps to Reproduce:

 1. Turn on the Computer (https://paste.kde.org/p7annnfh2)
 2. Check Sensors
 3. Check Fan Speed

Work fine with the nrj-notebook Kernel (3.14.25 as well)
Comment 1 Shalok Shalom 2015-02-07 22:30:31 MSK
Happens with the nrj-notebook Kernel now as well. 

I install another Distro, to check if the Hardware is the Reason.
Comment 2 Shalok Shalom 2015-02-08 03:27:59 MSK
PCLOS KDE 64, which use the BFS scheduler as well and Mint KDE 64 work fine and stay nice to my CPUs, even after some Hours.
Comment 3 Eugene Shatokhin 2015-02-09 11:37:06 MSK
There is a known bug in our cpupower package that might result in such things. 

Please try the following workaround: remove cpupower package and then install it again. Execute 

systemctl restart cpupower.service

just in case, or reboot.

Please check then what /etc/sysconfig/cpupower contains, there should be something like this now:

CPUPOWER_START_OPTS="frequency-set -g powersave"
CPUPOWER_STOP_OPTS="frequency-set -g powersave"

Note that "ondemand" may also be set there instead of "powersave" on some systems.

If the problem persists after that, please use hw-probe as I described in http://bugs.rosalinux.ru/show_bug.cgi?id=5006#c2 to upload the hardware info and the data to us.
Comment 4 Shalok Shalom 2015-02-10 02:19:04 MSK
http://hw.rosalinux.ru/index.php?probe=19e6d09af2
Comment 5 Shalok Shalom 2015-02-10 04:03:23 MSK
Believe it or not, the Issue seems (currently) to be gone.
The Temps are now cooler as in Mint :D

I do a second hw-probe: http://hw.rosalinux.ru/index.php?probe=7520936246

(The first one, in the Comment above was created, when i turn the device on, 2, 3 Hours ago. Since then was facebook,youtube and so on running, same as in the past times, i do all like before. Afaik.)
Comment 6 Shalok Shalom 2015-02-10 04:05:28 MSK
Ah, guess, it happens like that, because the manual restart of cpupower take no effect and my reboot does. Fine, thanks :)
Comment 7 Shalok Shalom 2015-02-10 17:38:12 MSK
The Issue appears again, after a Reboot and about two Hours of using the Device:

[matthias@matthias-laptop ~]$ sensors
radeon-pci-0100
Adapter: PCI adapter
temp1:        +64.0°C  

acpitz-virtual-0
Adapter: Virtual device
temp1:        +82.0°C  (crit = +105.0°C)
temp2:        +45.0°C  (crit = +256.0°C)
temp3:        +37.0°C  (crit = +105.0°C)
temp4:        +38.0°C  (crit = +105.0°C)
temp5:        +29.5°C  (crit = +105.0°C)
temp6:       +100.0°C  (crit = +110.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:       +39.0°C  (high = +100.0°C, crit = +100.0°C)

[matthias@matthias-laptop ~]$
Comment 8 Eugene Shatokhin 2015-02-10 19:23:07 MSK
(In reply to comment #7)
> The Issue appears again, after a Reboot and about two Hours of using the

Could you please do hw-probe again? We need the logs to see what is going on.
Comment 9 Shalok Shalom 2015-02-10 23:52:39 MSK
I reboot again and currently works all fine:

http://hw.rosalinux.ru/index.php?probe=fdbd4227cc

(I post the next hw-probe again, when the Issue reappears.)
Comment 10 Shalok Shalom 2015-02-11 02:09:38 MSK
http://hw.rosalinux.ru/index.php?probe=189c9c52d3

uptime
 23:07:54 up  2:19,  3 users,  load average: 1.24, 1.01, 0.74

(I keep the Notebook on a secondary sense full base for this time.)
Comment 11 Shalok Shalom 2015-02-11 03:46:05 MSK
I am now sure about it: 

The Sensor #6 always start with 50 degrees, goes after around 45 - 60 minutes up to 75 degrees and then up to 100. Every Time. 

hw-probe of 75 degrees: http://hw.rosalinux.ru/index.php?probe=ac2f02776c

uptime 00:44:11 up 47 min,  3 users,  load average: 0.46, 0.35, 0.36
Comment 12 Shalok Shalom 2015-02-11 03:51:41 MSK
Hnn, now is it (#6) down to 60° again... Why always such round Numbers ?
Comment 13 Shalok Shalom 2015-02-12 05:33:21 MSK
So, i change the underground and the notebook gets still up to 60 degrees, even with just some tiny tabs open. Always round numbers.
Comment 14 Shalok Shalom 2015-02-15 14:22:19 MSK
Any news ? :)
Comment 15 Shalok Shalom 2015-02-15 15:59:44 MSK
The same thing happens for me in mageia 5 beta 3: in this case even from the start ! What can this be ? cpupower ? Do OM/ROSA and Mageia use the same cpupower config ? At least the sensors output is very similar:

https://paste.kde.org/pusnt03zp

(Which looks different in each other distro, afaik.) :(
Comment 16 Shalok Shalom 2015-02-16 04:06:44 MSK
Ok, it happens in KaOS as well.. with the slight difference, that it shut down there already at about 70 degress. Same round numbers.
Comment 17 Eugene Shatokhin 2015-02-16 12:08:22 MSK
As for the always round numbers - no idea.

Concerning the temperatures - it might be that the CPU frequency is kept at maximum (or even higher if boost/turbo are enabled) for some reason.

You can run cpupower frequency-info (as root) from time to time to check the frequency. Example output from the data you sent us with hw-probe:

------------------------
analysiere CPU 0:
  Treiber: acpi-cpufreq
  Folgende CPUs laufen mit der gleichen Hardware-Taktfrequenz: 0
  Die Taktfrequenz folgender CPUs werden per Software koordiniert: 0
  Maximale Dauer eines Taktfrequenzwechsels: 10.0 us.
  Hardwarebedingte Grenzen der Taktfrequenz: 800 MHz - 2.20 GHz
  mögliche Taktfrequenzen: 2.20 GHz, 2.20 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
  mögliche Regler: userspace, ondemand, performance
  momentane Taktik: die Frequenz soll innerhalb 800 MHz und 2.20 GHz.
                    liegen. Der Regler "ondemand" kann frei entscheiden,
                    welche Taktfrequenz innerhalb dieser Grenze verwendet wird.
  momentane Taktfrequenz ist 2.20 GHz  (verifiziert durch Nachfrage bei der Hardware).
  boost state support:
    Supported: yes
    Active: yes 
------------------------

That is, the CPU is currently running at 2.20 GHz (maximum frequency) while cpupower may make it run at 1.60 GHz, 1.20 GHz or 800 MHz as well. 

You can try to set the upper limit for the CPU frequency to 1.60 GHz as follows (as root):
cpupower frequency-set -u 1.60GHz

Then you an use cpupower frequency-info again to see that the limit is set (there should be something like "momentane Taktik: die Frequenz soll innerhalb 800 MHz und 1.60 GHz liegen" there).

Then see if the temperatures go high as before when you launch some applications etc.

There was a possibly similar problem on another HP laptop we were testing, although the model was different from yours. CPU frequency was always kept at maximum there, even when the laptop was idle. It turned out, the problem was in the BIOS: the HP-specific "Deep Sleep" option did not allow to lower CPU frequency on idle for some reason. When it was turned off, frequency control started working and that problem was solved. 

Not sure if it is the case for your laptop, but it may be worth looking at. 

Updating the BIOS (with all the precautions necessary for it) might be helpful as well.
Comment 18 Shalok Shalom 2015-02-16 21:04:28 MSK
I set it up to 1.6 Ghz, that works. Overheat issue stay like before and there is no such BIOS option here, as far as i see: 

http://imgur.com/Csnaj40,aFZTeDD

http://imgur.com/Csnaj40,aFZTeDD#1

Thanks a lot again, great support :)
Comment 19 Shalok Shalom 2015-03-18 00:10:54 MSK
I make the BIOS update to the last version from 2011, the issue is still there.
Comment 20 Eugene Shatokhin 2015-03-18 10:52:25 MSK
We are now testing the update for lm_sensors, you can try it too and see if it improves anything.

Unlikely, but if you changed /etc/sysconfig/lm_sensors manually, it is recommended to make a backup of that file first. 

Then, please add the repository with that update and update the system:

urpmi.addmedia lm_sensors-new http://abf-downloads.rosalinux.ru/rosa2014.1/container/2473468/x86_64/main/release/

urpmi --auto-update

Then you can run 'sensors-detect --auto' (or just 'sensors-detect' if you want more control over what it scans). 

Reboot, just in case and see what 'sensors' will show now.
Comment 21 Shalok Shalom 2015-03-18 15:33:33 MSK
[matthias@matthias-laptop ~]$ urpmi.addmedia lm_sensors-new http://abf-downloads.rosalinux.ru/rosa2014.1/container/2473468/x86_64/main/release/
bash: urpmi.addmedia: Kommando nicht gefunden.

(Command not found)

I copy and paste your command into my yakuake.
Comment 22 Shalok Shalom 2015-03-18 15:46:26 MSK
I run the commands with sudo and they work.

Issue is still the same, temp4 shows 75.0 degrees, 60 degrees and so on.

https://paste.kde.org/pmatex9oo
Comment 23 Shalok Shalom 2015-03-22 13:48:04 MSK
Ok, i install PC-BSD: Exactly the same issue. 
(I guess because Linux and BSD share acpi ?)

When i run Windows (XP) on this device, show me the Open Hardware Monitor and CoreTemp around 50 degrees in idle and around 60, when i play a 1080p Youtube Movie (in Fullscreen, on 1024 x 786 Display Resolution) '

Windows runs in idle and with light browser usage without fan activity and turn them just slightly on, when i play the Full HD Video.

So i guess its acpi ?
Comment 24 Shalok Shalom 2015-03-29 23:14:51 MSD
Can this help, please ? 
http://eddietse.blogspot.co.at/2008/03/patching-dsdt-table-for-8510p-to-reduce.html

I find this interesting Post, about a similar model:

http://h30434.www3.hp.com/t5/Notebook-Hardware/My-HP-6910p-is-becoming-extremely-hot/td-p/2669345

The Battery is very weak already, 15-20 Minutes with standard Kernel.
Can this effect ACPI or the overheat issue in general.
Comment 25 Shalok Shalom 2015-03-31 13:46:49 MSD
I try without battery, issue consist.
Comment 26 Shalok Shalom 2015-03-31 13:47:08 MSD
I try without battery, issue consist.
Comment 27 Shalok Shalom 2016-04-28 17:14:53 MSD
Issue is fixed with lm_sensors 3.4.0:

https://issues.openmandriva.org/show_bug.cgi?id=1096#c10

When happens this update on ROSA?
Comment 29 Shalok Shalom 2016-04-29 16:00:48 MSD
I install them all 3, restart and the issue still exist:

http://hw.rosalinux.ru/index.php?probe=9a6b7aab93

Always round numbers: http://funkyimg.com/i/2bgUN.png
Comment 30 Eugene Shatokhin 2016-04-29 18:08:30 MSD
(In reply to comment #29)
> Always round numbers: http://funkyimg.com/i/2bgUN.png

Where? 61, 62, 56, 48, 58, 60, 65 - looks OK. No more round numbers than usual.
Comment 31 Shalok Shalom 2016-05-01 03:21:58 MSD
i mean, there isnt a single temp with another number as 0 next to the comma.
and these temp are checked directly from a cold boot and the fan drives crazy as always..