Bug 5009 - [UPDATE REQUEST] grub2-2.00-68
: [UPDATE REQUEST] grub2-2.00-68
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-04 17:29 MSK by Konstantin Vlasov
Modified: 2015-02-06 20:29 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
konstantin.vlasov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2015-02-04 17:29:07 MSK
UEFI-related updates for grub2.
Comment 1 Konstantin Vlasov 2015-02-04 17:31:01 MSK
https://abf.io/build_lists/2405332
https://abf.io/build_lists/2405333

Advisory: Various UEFI-related fixes:
1. When installing in UEFI mode on an MBR-partitioned hard disk, the MBR disk ID was changed. It caused boot failure of the existing Legacy-BIOS Windows installation.
2. Windows UEFI entry was not added, if grub config update was caused by kcm_grub2 running with non-root privileges.
3. BOOTx64.efi filename case fixed.
Comment 2 Vladimir Potapov 2015-02-06 20:17:25 MSK
grub2-2.00-68
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2405332/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2405333/x86_64/main/release/
****************************** Advisory *************************
Various UEFI-related fixes
****************************** Changelog ************************
1. When installing in UEFI mode on an MBR-partitioned hard disk, the MBR disk ID was changed. It caused boot failure of the existing Legacy-BIOS Windows installation.
2. Windows UEFI entry was not added, if grub config update was caused by kcm_grub2 running with non-root privileges.
3. BOOTx64.efi filename case fixed.
*****************************************************************
QA Verified