Bug 4993 - We need to synchronize rosa2014.1 and current initscripts package
: We need to synchronize rosa2014.1 and current initscripts package
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-02 16:20 MSK by a.lahin
Modified: 2015-05-19 18:12 MSD (History)
5 users (show)

See Also:
RPM Package: initscripts
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments
ss (67.09 KB, image/png)
2015-02-09 17:59 MSK, Vladimir Potapov
Details
ss (251.95 KB, image/png)
2015-02-09 18:01 MSK, Vladimir Potapov
Details
Screenshot - squares instead of the russian letters (22.46 KB, image/png)
2015-02-16 16:26 MSK, Eugene Shatokhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a.lahin 2015-02-02 16:20:30 MSK
We need to synchronize rosa2014.1 and current initscripts package.
New initscripts version is more systemd-oriented and has, for example, initscrips/legacy-actions (which is used in new audit package ( https://abf.io/current/audit/tree/current )).
Comment 1 a.lahin 2015-02-02 16:24:22 MSK
Advisory: "Upgrade initscripts"

Main:
https://abf.io/build_lists/2404773
https://abf.io/build_lists/2404774
Comment 2 FirstLevel 2015-02-04 14:25:08 MSK
I have such string while I have tried to update initscripts:
[root@r5-32 ~]# urpmi.addmedia tst http://abf-downloads.rosalinux.ru/rosa2014.1/container/2404773/i586/main/release/
добавляется источник «tst»
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2404773/i586/main/release/media_info/20150202-120440-synthesis.hdlist.cz
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2404773/i586/main/release/media_info/20150202-120440-info.xml.lzma                        
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2404773/i586/main/release/media_info/20150202-120440-files.xml.lzma                       
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2404773/i586/main/release/media_info/20150202-120440-changelog.xml.lzma                   
[root@r5-32 ~]# urpmi --auto-update 
источник «main» уже обновлён
источник «main updates» уже обновлён
источник «contrib» уже обновлён
источник «contrib updates» уже обновлён
источник «non-free» уже обновлён
источник «non-free updates» уже обновлён
источник «restricted» уже обновлён
источник «restricted updates» уже обновлён
источник «tst» уже обновлён
Следующие пакеты будут удалены для обновления остальных:
dmraid-1.0.0-0.rc16.8-rosa2014.1.i586
 (из-за неудовлетворённости dmraid-events == 1.0.0-0.rc16.8)
dmraid-events-1.0.0-0.rc16.8-rosa2014.1.i586
 (из-за неудовлетворённости dmraid == 1.0.0-0.rc16.8) (y/N) 


Is it normal?
Comment 3 FirstLevel 2015-02-04 14:27:01 MSK
And for 64bit I have same strings:

Следующие пакеты будут удалены для обновления остальных:
dmraid-1.0.0-0.rc16.8-rosa2014.1.x86_64
 (из-за неудовлетворённости dmraid-events == 1.0.0-0.rc16.8)
dmraid-events-1.0.0-0.rc16.8-rosa2014.1.x86_64
 (из-за неудовлетворённости dmraid == 1.0.0-0.rc16.8) (y/N) 

Is It normal?
Comment 4 a.lahin 2015-02-04 14:59:48 MSK
(In reply to comment #3)
> And for 64bit I have same strings:
> 
> Следующие пакеты будут удалены для обновления остальных:
> dmraid-1.0.0-0.rc16.8-rosa2014.1.x86_64
>  (из-за неудовлетворённости dmraid-events == 1.0.0-0.rc16.8)
> dmraid-events-1.0.0-0.rc16.8-rosa2014.1.x86_64
>  (из-за неудовлетворённости dmraid == 1.0.0-0.rc16.8) (y/N) 
> 
> Is It normal?

Not exactly, please wait for dmraid synchronization - I'll initiate it now.
Comment 5 a.lahin 2015-02-04 17:08:36 MSK
(In reply to comment #4)
> (In reply to comment #3)
> > And for 64bit I have same strings:
> > 
> > Следующие пакеты будут удалены для обновления остальных:
> > dmraid-1.0.0-0.rc16.8-rosa2014.1.x86_64
> >  (из-за неудовлетворённости dmraid-events == 1.0.0-0.rc16.8)
> > dmraid-events-1.0.0-0.rc16.8-rosa2014.1.x86_64
> >  (из-за неудовлетворённости dmraid == 1.0.0-0.rc16.8) (y/N) 
> > 
> > Is It normal?
> 
> Not exactly, please wait for dmraid synchronization - I'll initiate it now.

dmraid 1.0.0-0.rc16.18 is published at:
https://abf.io/build_lists/2405330
https://abf.io/build_lists/2405329

Please recheck with these updated versions.
Comment 6 FirstLevel 2015-02-05 11:10:57 MSK
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > And for 64bit I have same strings:
> > > 
> > > Следующие пакеты будут удалены для обновления остальных:
> > > dmraid-1.0.0-0.rc16.8-rosa2014.1.x86_64
> > >  (из-за неудовлетворённости dmraid-events == 1.0.0-0.rc16.8)
> > > dmraid-events-1.0.0-0.rc16.8-rosa2014.1.x86_64
> > >  (из-за неудовлетворённости dmraid == 1.0.0-0.rc16.8) (y/N) 
> > > 
> > > Is It normal?
> > 
> > Not exactly, please wait for dmraid synchronization - I'll initiate it now.
> 
> dmraid 1.0.0-0.rc16.18 is published at:
> https://abf.io/build_lists/2405330
> https://abf.io/build_lists/2405329
> 
> Please recheck with these updated versions.

I have tested update with two containers (iniscripts and dmraid).
All goes well for 32bit and 64bit.
No new errorr in dmesg and systemctl | grep failed commands.
Comment 7 Vladimir Potapov 2015-02-09 17:59:10 MSK
Created attachment 3738 [details]
ss

After update I see this....
Comment 8 Vladimir Potapov 2015-02-09 18:01:10 MSK
Created attachment 3739 [details]
ss

After update mc in konsole is black, keyboard don't work.
**********************************************************
QA Denied
Comment 9 a.lahin 2015-02-10 18:27:27 MSK
(In reply to comment #8)
> Created attachment 3739 [details]
> ss
> 
> After update mc in konsole is black, keyboard don't work.
> **********************************************************
> QA Denied

Please retest with the following build:
https://abf.io/build_lists/2423948
https://abf.io/build_lists/2423949
Comment 10 Alexander Petryakov 2015-02-13 03:32:31 MSK
# urpmi.addmedia --update 4993 http://abf-downloads.rosalinux.ru/rosa2014.1/container/2423949/x86_64/main/release/
источник «4993» уже обновлён
Следующие пакеты будут удалены для обновления остальных:
dmraid-1.0.0-0.rc16.8-rosa2014.1.x86_64
 (из-за конфликтов с initscripts-9.45-4-rosa2014.1.x86_64)
dmraid-events-1.0.0-0.rc16.8-rosa2014.1.x86_64
 (из-за неудовлетворённости dmraid == 1.0.0-0.rc16.8) (y/N)
Comment 11 Alexander Petryakov 2015-02-13 04:04:06 MSK
with dmraid 1.0.0-0.rc16.18 is OK
Comment 12 Alexander Petryakov 2015-02-15 00:54:11 MSK
After update mc/keyboard work properly.
Comment 13 Eugene Shatokhin 2015-02-16 16:26:54 MSK
Created attachment 3743 [details]
Screenshot - squares instead of the russian letters

After updating initcripts in ROSA R5 i586 (VirtualBox VM), there are squares instead of russian letters in the virtual console. There was no such problem before this update.
Comment 14 Vladimir Potapov 2015-02-16 19:02:33 MSK
(In reply to comment #13)
> Created attachment 3743 [details]
> Screenshot - squares instead of the russian letters
> 
> After updating initcripts in ROSA R5 i586 (VirtualBox VM), there are squares
> instead of russian letters in the virtual console. There was no such problem
> before this update.
I confirm the issue (after dracut -f on i586 system)
********************
QA Denied
Comment 15 Andrey Ponomarenko 2015-02-16 19:18:10 MSK
test-desktop x86_64 + initscripts 9.45-4: http://hw.rosalinux.ru/index.php?probe=671d3012f2

boot, suspend, hibernate, hybrid-sleep and resume - OK
Comment 16 a.lahin 2015-02-17 16:02:01 MSK
(In reply to comment #13)
> Created attachment 3743 [details]
> Screenshot - squares instead of the russian letters
> 
> After updating initcripts in ROSA R5 i586 (VirtualBox VM), there are squares
> instead of russian letters in the virtual console. There was no such problem
> before this update.

This problem is caused by new /etc/profile.d/10lang.sh (.csh).
New version does not execute unicode_start/setfont (it relies on correct font initialization in initrd).
But console font is not initialized in initrd due to incorrect font specification (FONT=latarcyrheb-sun16) in /etc/vconsole.conf.
So the possible solution is to revert /etc/profile.d/10lang.sh (.csh) or to upgrade systemd (and to fix incorrect font in /etc/vconsole.conf) before initscripts.
Comment 17 Denis Silakov 2015-05-19 18:12:13 MSD
Initscripts and accompanying packages were finally synced in bug #5430