Bug 4986 - Unable to download script (WGet : undefined symbol SSLv2_client_method)
: Unable to download script (WGet : undefined symbol SSLv2_client_method)
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-02 11:45 MSK by Gaël
Modified: 2015-02-28 18:49 MSK (History)
1 user (show)

See Also:
RPM Package: playonlinux-4.2.5-3.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gaël 2015-02-02 11:45:50 MSK
Description of problem:
Unable to download script for install components with playonlinux.


Version-Release number of selected component (if applicable):
playonlinux-4.2.5-3.src.rpm
wget-1.16.1-1.src.rpm


How reproducible:
Allways


Steps to Reproduce:
1. Start playonlinux
2. Select an installed software
3. Click "Configure"
4. Switch to tab "Install components"
5. Select a component (directx9, gdiplus, vcrun2013, ...)
6. Click on Install

wget: symbol lookup error: wget: undefined symbol: SSLv2_client_method

7. Warning !! The signature of the script you are trying to run is NOT valid... The script is empty...
Comment 1 Denis Silakov 2015-02-06 12:25:10 MSK
Can't reproduce at the moment. Which architecture do you have - 32bit or 64bit? 

Could you also provide output of "ldd -r /usr/bin/wget" command?
Comment 2 Gaël 2015-02-09 21:42:08 MSK
cat /etc/release :
ROSA Desktop Fresh R5 release 2014.1 for i586



ldd -r /usr/bin/wget :
        linux-gate.so.1 =>  (0xb7748000)
        libpcre.so.1 => /lib/libpcre.so.1 (0xb76ba000)
        libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0xb7646000)
        libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0xb743f000)
        libz.so.1 => /lib/libz.so.1 (0xb7422000)
        libidn.so.11 => /usr/lib/libidn.so.11 (0xb73ec000)
        libc.so.6 => /lib/i686/libc.so.6 (0xb721b000)
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0xb71ff000)
        libdl.so.2 => /lib/libdl.so.2 (0xb71fa000)
        /lib/ld-linux.so.2 (0xb7749000)





playonlinux :
Looking for python... 2.7.9 - selected
[main] Message: PlayOnLinux (4.2.5) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_System_CheckFS] Message: Checking filesystem for /home/fred/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Vérification de l'extension : Capture...
[install_plugins] Message: Vérification de l'extension : ScreenCap...
[install_plugins] Message: Vérification de l'extension : PlayOnLinux Vault...
[maj_check] Message: Web version : 1423501238
[maj_check] Message: Current local version : 1423221908
[maj_check] Message: Updating list
[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1423501238
[POL_SetupWindow_Init] Message: Creating new window for pid 6216
[POL_Call] Message: Calling POL_Install_corefonts
wget: symbol lookup error: wget: undefined symbol: SSLv2_client_method
Comment 3 Denis Silakov 2015-02-24 19:18:33 MSK
It looks like Playonlinux uses internal version of libssl.so.1.0.0 which doesn't provide necessary symbols.

Will it help to remove ~/.PlayOnLinux/wine/linux-x86/1.7.33/lib/libssl.so.1.0.0 file?

(note that path can be different if your PlayOnLinux downloaded another version of wine, just look for libssl.so.1.0.0 file in ~/.PlayOnLinux/ folder)
Comment 4 Gaël 2015-02-26 11:33:34 MSK
The problem seems to be resolved by removing the file ~/.PlayOnLinux/wine/linux-x86/1.*.**/lib/libssl.so.1.0.0

This must be done for each installed version of wine with PlayOnLinux.
Comment 5 Gaël 2015-02-28 09:22:10 MSK
This bug is now fixed with latest version of PlayOnLinux (4.2.6)

https://www.playonlinux.com/en/comments-1290.html
Comment 6 Denis Silakov 2015-02-28 18:49:41 MSK
Playonlinux has been updated and should appear on mirrors soon.

Optimistically marking the bug as fixed. Feel free to reopen if the issue doesn't disappear (can't test this by myself right now since the issue only affects 32bit systems and I don't have one near me).