Bug 4981 - Rosa R5 x64 - Nvidia driver does not update
: Rosa R5 x64 - Nvidia driver does not update
Status: RESOLVED NOTABUG
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-31 03:18 MSK by andrea_scopelliti
Modified: 2015-02-18 17:35 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrea_scopelliti 2015-01-31 03:18:36 MSK
Description of problem:
In Rosa R5 x64 repos currently is present version 343.22 of the Nvidia-current driver. However, rpmdrake does not recognise this new driver and does not propose it as an update from 340.65. If manually selected the new driver installs and runs flawlessly.

From my urpmi.cfg you can see that it's not a matter of a missing update option in my repos:
{
}

main http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/main/release {
  key-ids: 16a853e7
}

main\ updates http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/main/updates {
  update
}

main\ testing http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/main/testing {
  ignore
  update
}

Main32 http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/release {
}

Main32\ Updates http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/updates {
  update
}

main32\ testing http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/testing {
  ignore
  update
}

contrib http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/contrib/release {
}

contrib\ updates http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/contrib/updates {
  update
}

non-free http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/non-free/release {
  key-ids: 16a853e7
}

non-free\ updates http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/non-free/updates {
  key-ids: 16a853e7
  update
}

Non-free32 http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/non-free/release {
  key-ids: 16a853e7
}

Non-free32\ Updates http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/non-free/updates {
  key-ids: 16a853e7
  update
}

restricted http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/restricted/release {
  key-ids: 16a853e7
}

restricted\ updates http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/restricted/updates {
  key-ids: 16a853e7
  update
}

Restricted32 http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/restricted/release {
  key-ids: 16a853e7
}

Restricted32\ Updates http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/restricted/updates {
  key-ids: 16a853e7
  update
}

Kernel\ X64 http://abf-downloads.rosalinux.ru/kernels_3_17x_personal/repository/rosa2014.1/x86_64/main/release {
  update
}


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Eugene Shatokhin 2015-02-18 17:30:12 MSK
Generally, we recommend to use what XFdrake recommends.

Long story short:

Since ROSA R4, nvidia-current is not recommended for common usage, only for experiments & testing. XFdrake does not suggest it for this reason.

If your video card is not supported by the recommended driver or there are problems with graphics then, please file a separate bug for it.

Here is the longer story.

We recommend using the longterm branches of NVidia drivers: nvidia340 and nvidia304. This is safer, because NVidia is unlikely to drop support for any GPUs from these branches. Same - for the Xorg support. If a user sticks to these branches, it is less likely that some update results in a broken graphics after reboot.

NVidia seems to offer no such guarantees for their ordinary stable branches like 343.x, 346.x, etc. That is, they can (and did!) remove support for older GPUs from there. So, we only recommend such branches for experiments and testing, not for regular usage.

XFdrake was updated with that in mind.