Bug 4973 - Strange bug in libdirectfb
: Strange bug in libdirectfb
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-29 17:40 MSK by Zombie Ryushu
Modified: 2015-02-02 15:10 MSK (History)
2 users (show)

See Also:
RPM Package: libdirectfb1.6_0
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-01-29 17:40:14 MSK
While trying to play Quake 4 on Rosa 2014, I encountered the following extremely bizzare error: 

./quake4.x86: libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/libdirectfb-1.6.so.0)

 ldd /usr/lib/libdirectfb-1.6.so.0
        linux-gate.so.1 =>  (0xf776d000)
        libfusion-1.6.so.0 => /usr/lib/libfusion-1.6.so.0 (0xf761e000)
        libdirect-1.6.so.0 => /usr/lib/libdirect-1.6.so.0 (0xf75fa000)
        libz.so.1 => /lib/libz.so.1 (0xf75e2000)
        libdl.so.2 => /lib/libdl.so.2 (0xf75dd000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf75c0000)
        libstdc++.so.6 => /lib/libstdc++.so.6 (0xf74ce000)
        libc.so.6 => /lib/libc.so.6 (0xf72f0000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf72d2000)
        librt.so.1 => /lib/librt.so.1 (0xf72c9000)
        /lib/ld-linux.so.2 (0xf776e000)
        libm.so.6 => /lib/libm.so.6 (0xf727b000)
Comment 1 Denis Silakov 2015-02-02 14:32:20 MSK
Are you sure you have that latest libstdc++ installed? ("rpm -qi libstdc++6")?
Comment 2 Zombie Ryushu 2015-02-02 15:10:22 MSK
Was my fault, invalid LD_LIBRARY_PATH