Bug 4940 - Error while launching XDrakres
: Error while launching XDrakres
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-22 11:59 MSK by FirstLevel
Modified: 2015-01-27 14:23 MSK (History)
1 user (show)

See Also:
RPM Package: drakxtools-14.48-2-rosa2014.1.i586.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
Xdrakres-from-user.jpg (64.58 KB, image/jpeg)
2015-01-22 11:59 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2015-01-22 11:59:05 MSK
Created attachment 3673 [details]
Xdrakres-from-user.jpg

Description of problem:
For drakxtools-14.48-2-rosa2014.1.i586.rpm  I have such situations with launching XDrakres

If user launch 
/usr/bin/XDrakres 
/usr/sbin/XDrakres
an error occured Xdrakres-from-user.jpg

If root launch 
/usr/bin/XDrakres 
an error occured Xdrakres-from-user.jpg


If root launch 
/usr/sbin/XDrakres 
I see request for senfing bug
Программа "Xdrakres" аварийно завершила свою работу со следующей ошибкой:

  Can't call method "get_devices" on an undefined value at /usr/lib/libDrakX/Xconfig/card.pm line 49.
  Perl's trace:
  standalone::bug_handler() called from /usr/lib/libDrakX/Xconfig/card.pm:49
  Xconfig::card::from_raw_X() called from /usr/lib/libDrakX/Xconfig/main.pm:38
  Xconfig::main::configure_resolution() called from /usr/sbin/Xdrakres:46

Тема оформления: elementary

Для оправки отчёта об ошибке нажмите на кнопку «Отчёт».
В веб-браузере откроется адрес Bugzilla с формой для заполнения. Представленные выше сведения будут отправлены на указанный сервер.
Было бы неплохо приложить к вашему отчету вывод следующей команды: 'lspcidrake -v'.
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Konstantin Vlasov 2015-01-22 13:30:42 MSK
It seems, this problem occurs when xorg.conf is missing, that is, when no proprietary video drivers are installed. Actually, it's a problem of XFdrare since Xdrakres is just an alias for "XFdrake resolution".
Comment 2 Konstantin Vlasov 2015-01-26 13:16:42 MSK
Should be fixed in drakx-kbd-mouse-x11-0.115-2 (bug #4950). Now when xorg.conf is missing or invalid, an error message is printed in console and the program exits.