Bug 49 - Can not install Skype
: Can not install Skype
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal major
: 2012 Marathon Final
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-14 20:08 MSD by Denis Koryavov
Modified: 2012-06-08 23:45 MSD (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-04-14 20:08:17 MSD
Description of problem:

If I trying to install Skype a receive the next error:

A requested package cannot be installed:
get-skype-2.2.0.35-2-rosa.lts2012.0.noarch (due to unsatisfied libqtdbus4)
Comment 1 Postnikov Dmitry 2012-04-18 22:42:18 MSD
In 240th iso image Skype established excellent. The installation went without error.
-----------
[dima@mindlife ~]$ rpm -qa | grep skype
get-skype-2.2.0.35-2-rosa.lts2012.0.noarch
[dima@mindlife ~]$
-----------
Comment 2 Alexander Burmashev 2012-04-18 22:55:05 MSD
Did you test it on 64 or 32 bit image ?
Comment 3 Postnikov Dmitry 2012-04-18 22:59:50 MSD
I'm tested on 32bit (i586).
Comment 4 Alexander Burmashev 2012-04-18 23:08:25 MSD
That is the point, the problem, reported by Denis, is perfectly reproduced on 64 bit system, because skype on 64 bit requires 32bit libs.
Comment 5 Denis Koryavov 2012-04-19 00:18:17 MSD
Maybe we should add some 32bit repos by default for 64-bit systems?
Comment 6 Alexander Burmashev 2012-04-25 14:24:32 MSD
Adding 32bit repo by default may result in some weird results sometimes ( as it happened in mandriva before ).
I would really propose either to add it to Errata/Solutions or find other solution to provide 32bit libraries on 64 environment.
Comment 7 Andrew Lukoshko 2012-04-30 23:20:09 MSD
We still have a problem after adding 32bit repos.

---------------------------------------
[root@lukoshko andrew]# urpmi get-skype
Для удовлетворения зависимости «libGL.so.1» нужен один из следующих пакетов:
 1- x11-driver-video-nvidia-current-295.40-1-rosa.lts2012.0.x86_64: NVIDIA proprietary X.org driver and libraries for GeForce 6 and later cards (для установки)
 2- x11-driver-video-fglrx-8.951-2-mib.lts2012.0.x86_64: AMD proprietary X.org driver and libraries (для установки)
Ваш выбор? (1-2) 
---------------------------------------
(sorry for Russian)

Seems like I need to install NVIDIA or ATI drivers to use Skype. But I own Intel :)

It's a bit strange because libmesagl1-7.11.2-3-rosa.lts2012.0.i586.rpm also provides libGL.so.1. After manual install of this package Skype installs without any problem.

Looks like bug in repo metadata.
Comment 8 Alexander Burmashev 2012-04-30 23:28:18 MSD
I think skype requires should be fixed to be close to libmesagl1
Comment 9 Aleksandr Kazantcev 2012-04-30 23:33:46 MSD
NVIDIA and ATI replace this with own requires. And we need drop join skype 64 with 32 package anymore.
Comment 10 Dmitry Mikhirev 2012-05-02 15:11:59 MSD
(In reply to comment #7)

> It's a bit strange because libmesagl1-7.11.2-3-rosa.lts2012.0.i586.rpm also
> provides libGL.so.1. After manual install of this package Skype installs
> without any problem.

That's great...

Not nvidia nor fglrx should provide libGL.so.1. It is a bug that must be fixed.
Comment 11 Aleksandr Kazantcev 2012-05-02 15:18:24 MSD
NVIDIA and AMD blob need providing own package - see spec for drivers. We need use STATIC version, that not depended from external lib.
Comment 12 Dmitry Mikhirev 2012-05-02 15:40:00 MSD
(In reply to comment #11)
> NVIDIA and AMD blob need providing own package - see spec for drivers. We
> need use STATIC version, that not depended from external lib.

Sorry, I don't understand what do you mean. I know what should and what should not be provided by this packages because I maintain fglrx in Mandriva. In nvidia-current spec from Cooker I see:

# Other packages should not require any NVIDIA libraries, and this package
# should not be pulled in when libGL.so.1 is required
%define __noautoprov '\\.so'

NB: this does not work in ROSA 2012 LTS because it does not use rpm internal dependency generator by default.
Comment 13 Aleksandr Kazantcev 2012-05-02 15:43:42 MSD
It fixed in latest package for NVIDIA and AMD blob. Try install skype in updated machine.

But i'm think, that static version in opt more usable.
Comment 14 Dmitry Mikhirev 2012-05-02 15:55:29 MSD
(In reply to comment #13)
> It fixed in latest package for NVIDIA and AMD blob. Try install skype in
> updated machine.
> 
> But i'm think, that static version in opt more usable.

What are you speaking about? I repeat: nvidia and fglrx drivers should not provide libGL.so.1. How is it related to directory where it is placed?

BTW I dislike installing anything to /opt and I see no reasons for this.
Comment 15 Dmitry Mikhirev 2012-05-02 16:09:54 MSD
(In reply to comment #13)
> It fixed in latest package for NVIDIA and AMD blob. Try install skype in
> updated machine.
> 
> But i'm think, that static version in opt more usable.

Sorry, if this was about skype and not reply to my post.
Comment 16 Denis Koryavov 2012-06-08 23:45:22 MSD
It works for me now.