Bug 4831 - [UPDATE REQUEST] drakxtools-14.48-2
: [UPDATE REQUEST] drakxtools-14.48-2
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-30 02:20 MSK by Konstantin Vlasov
Modified: 2015-01-27 14:31 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
firstlevel: qa_verified+
konstantin.vlasov: published+


Attachments
01-release-notes.jpg (80.20 KB, image/jpeg)
2014-12-30 11:18 MSK, FirstLevel
Details
02-drakups.jpg (173.79 KB, image/jpeg)
2014-12-30 12:38 MSK, FirstLevel
Details
03-drakups.jpg (171.39 KB, image/jpeg)
2014-12-30 12:38 MSK, FirstLevel
Details
Xdrakres-from-user.jpg (64.58 KB, image/jpeg)
2015-01-19 17:02 MSK, FirstLevel
Details
Xdrakres-from-user-old.jpg (62.54 KB, image/jpeg)
2015-01-19 17:02 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2014-12-30 02:20:01 MSK
drakxtools updated.
Comment 1 Konstantin Vlasov 2014-12-30 02:22:25 MSK
https://abf.rosalinux.ru/build_lists/2384574
https://abf.rosalinux.ru/build_lists/2384575

Advisory: Various minor improvements (working with systemd, Russian translation fix, etc.)
Comment 2 FirstLevel 2014-12-30 11:17:31 MSK
Update for 32bit goes well.
Comment 3 FirstLevel 2014-12-30 11:18:06 MSK
Created attachment 3588 [details]
01-release-notes.jpg
Comment 4 FirstLevel 2014-12-30 11:19:36 MSK
Error message while launching display_release_notes.pl

01-release-notes.jpg
Comment 5 FirstLevel 2014-12-30 11:22:48 MSK
Same error with Xdrakes launching
Comment 6 FirstLevel 2014-12-30 11:23:29 MSK
And for clock.pl I see unknown error
Comment 7 FirstLevel 2014-12-30 11:24:43 MSK
It is for ordinary user. Not for root
Comment 8 FirstLevel 2014-12-30 11:25:44 MSK
Unknown error for /usr/sbin/logdrake
Comment 9 FirstLevel 2014-12-30 12:29:53 MSK
/usr/bin/display_release_notes.pl with result 01-release-notes.jpg - not regression
/usr/sbin/Xdrakres  with result 01-release-notes.jpg - not regression
/usr/sbin/clock.pl with result 01-release-notes.jpg - not regression
/usr/sbin/logdrake with result 01-release-notes.jpg - not regression
Comment 10 FirstLevel 2014-12-30 12:38:37 MSK
Created attachment 3589 [details]
02-drakups.jpg
Comment 11 FirstLevel 2014-12-30 12:38:51 MSK
Created attachment 3590 [details]
03-drakups.jpg
Comment 12 FirstLevel 2014-12-30 12:39:57 MSK
If I launch /usr/bin/drakups I have been asked for necessary package 02-drakups.jpg but this pacjage has not been found 03-drakups.jpg - It is not regression
Comment 13 FirstLevel 2014-12-30 12:42:38 MSK
Launching /usr/sbin/adduserdrake causes an  error 01-release-notes.jpg - not regression
Comment 14 FirstLevel 2014-12-30 12:43:59 MSK
launching /usr/sbin/drakdisk  causes an  error 01-release-notes.jpg - not regression
Comment 15 FirstLevel 2014-12-30 12:45:28 MSK
launching /usr/sbin/drakhardware  causes an  error 01-release-notes.jpg - not regression
Comment 16 FirstLevel 2014-12-30 12:48:51 MSK
Also an unknown error occured while launching
/usr/sbin/drakperm
/usr/sbin/draksound
/usr/sbin/drakx11
It is not regression
Comment 17 Konstantin Vlasov 2014-12-30 12:55:02 MSK
Confirm the problems with "unknown error", it happens at least since the R4 release. The error message appears when tools try to raise privileges: consolehelper fails to do it. Unfortunately, I'm not familiar with consolehelper...
Comment 18 Konstantin Vlasov 2014-12-30 13:09:31 MSK
Source of the problem: missing config files for some of the tools. When complete list is ready, I'll add them.
Comment 19 FirstLevel 2014-12-30 15:35:32 MSK
(In reply to comment #18)
> Source of the problem: missing config files for some of the tools. When
> complete list is ready, I'll add them.

display_release_notes.pl
Xdrakres
clock.pl
/usr/sbin/logdrake
/usr/bin/display_
/usr/sbin/Xdrakres
/usr/sbin/clock.pl
/usr/sbin/logdrake
/usr/sbin/adduserdrake
/usr/sbin/drakdisk
/usr/sbin/drakhardware
/usr/sbin/drakperm
/usr/sbin/draksound
/usr/sbin/drakx11
Comment 20 Konstantin Vlasov 2015-01-19 04:02:11 MSK
https://abf.rosalinux.ru/build_lists/2391468
https://abf.rosalinux.ru/build_lists/2391469

Advisory: Various minor improvements (working with systemd, Russian translation fix, fixed inability to run some tools from non-root, etc.)
Comment 21 FirstLevel 2015-01-19 17:02:14 MSK
(In reply to comment #20)
> https://abf.rosalinux.ru/build_lists/2391468
> https://abf.rosalinux.ru/build_lists/2391469
> 
> Advisory: Various minor improvements (working with systemd, Russian
> translation fix, fixed inability to run some tools from non-root, etc.)

For 32bit.
For container versions:
/usr/sbin/Xdrakres
/usr/bin/Xdrakres
have an error while launching  Xdrakres-from-user.jpg

For original version:
/usr/sbin/Xdrakres have an error while launching  Xdrakres-from-user-old.jpg
But other utility is absent at all
[sergei32@r5-32 ~]$ /usr/bin/Xdrakres
bash: /usr/bin/Xdrakres: Нет такого файла или каталога


For version from container:
[sergei32@r5-32 ~]$ /usr/sbin/prefdm
rm: невозможно удалить «/etc/systemd/system/display-manager.service»: Отказано в доступе
Failed to issue method call: Access denied
No regression
Comment 22 FirstLevel 2015-01-19 17:02:28 MSK
Created attachment 3651 [details]
Xdrakres-from-user.jpg
Comment 23 FirstLevel 2015-01-19 17:02:40 MSK
Created attachment 3652 [details]
Xdrakres-from-user-old.jpg
Comment 24 FirstLevel 2015-01-19 17:24:17 MSK
(In reply to comment #21)
> (In reply to comment #20)
> > https://abf.rosalinux.ru/build_lists/2391468
> > https://abf.rosalinux.ru/build_lists/2391469
> > 
> > Advisory: Various minor improvements (working with systemd, Russian
> > translation fix, fixed inability to run some tools from non-root, etc.)
> 
> For 32bit.
> For container versions:
> /usr/sbin/Xdrakres
> /usr/bin/Xdrakres
> have an error while launching  Xdrakres-from-user.jpg
> 
> For original version:
> /usr/sbin/Xdrakres have an error while launching  Xdrakres-from-user-old.jpg
> But other utility is absent at all
> [sergei32@r5-32 ~]$ /usr/bin/Xdrakres
> bash: /usr/bin/Xdrakres: Нет такого файла или каталога
> 
> 
> For version from container:
> [sergei32@r5-32 ~]$ /usr/sbin/prefdm
> rm: невозможно удалить «/etc/systemd/system/display-manager.service»:
> Отказано в доступе
> Failed to issue method call: Access denied
> No regression

All these are actual for 64bit too
Comment 25 FirstLevel 2015-01-22 11:59:50 MSK
I have created a bug http://bugs.rosalinux.ru/show_bug.cgi?id=4940
Comment 26 FirstLevel 2015-01-22 12:02:03 MSK
drakxtools-14.48-2
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2391468/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2391469/x86_64/main/release/
************************ Advisory **********************
Various minor improvements (working with systemd, Russian translation fix, etc.)
********************************************************
QA Verified
Comment 27 Konstantin Vlasov 2015-01-23 21:27:44 MSK
(In reply to comment #21)
> For version from container:
> [sergei32@r5-32 ~]$ /usr/sbin/prefdm
> rm: невозможно удалить «/etc/systemd/system/display-manager.service»:
> Отказано в доступе
> Failed to issue method call: Access denied
> No regression

It's not only "no regression", it's not a bug at all. prefdm is not a GUI application, so it's not designed for running from unprivileged user.