Bug 4828 - display brightness can not be adjusted from the keyboard
: display brightness can not be adjusted from the keyboard
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-29 10:13 MSK by Vladimir Potapov
Modified: 2015-06-09 15:04 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2014-12-29 10:13:05 MSK
For my notebook lenovo display brightness can not be adjusted from the keyboard
http://hw.rosalinux.ru/index.php?probe=c8d433cbaf
Comment 1 Eugene Shatokhin 2014-12-29 11:29:43 MSK
Please try pressing these brightness keys again and then collect and post the output of 'journalctl' here. If we are lucky, it may contain the codes of the keys to be handled. As well as the related errors.

By the way, which keys are used to increase/decrease brightness on that laptop model?
Comment 2 Vladimir Potapov 2014-12-29 12:58:41 MSK
ls -l /sys/class/backlight
итого 0
lrwxrwxrwx 1 root root 0 дек 30  2014 acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0/
lrwxrwxrwx 1 root root 0 дек 30  2014 acpi_video1 -> ../../devices/pci0000:00/0000:00:02.0/backlight/acpi_video1/
lrwxrwxrwx 1 root root 0 дек 30  2014 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card1/card1-LVDS-1/intel_backlight/
Comment 3 Vladimir Potapov 2014-12-29 13:01:17 MSK
KDE tray brightness support work correct
Comment 4 Vladimir Potapov 2014-12-29 14:27:28 MSK
with kernel 3.17.7 all worked!
Comment 5 Vladimir Potapov 2014-12-29 14:43:03 MSK
(In reply to comment #4)
> with kernel 3.17.7 all worked!
only after sleep|wake up
Comment 6 Vladimir Potapov 2015-01-27 21:37:51 MSK
I Check the issue for kernel 3.18.2. It's present.
Comment 7 Vladimir Potapov 2015-01-28 19:12:43 MSK
I check with 3.18.2 and "acpi_backlight=vendor"options 
http://hw.rosalinux.ru/index.php?probe=be4092507a
bad effect (after sleep not work)
Comment 8 Vladimir Potapov 2015-01-28 19:19:09 MSK
By applet display brightness from keyboard work always (without =vendor)
Comment 9 Vladimir Potapov 2015-01-28 19:32:53 MSK
acpi_listen пустой до ждущего режима
и работает после пробуждения
Comment 10 Eugene Shatokhin 2015-02-20 15:13:17 MSK
I have checked that the problem does affect mainline kernels 3.14.x, 3.18.x and 3.19 as well. The kernel from linux-pm tree (3.19+ at the moment) is also affected.

Sometimes, the problem disappears or shows up only from time to time. 

Reported upstream anyway as it may be a firmware (BIOS) or ACPI issue that we hit for some reason while some other systems did not:
https://bugzilla.kernel.org/show_bug.cgi?id=93551
Comment 11 Eugene Shatokhin 2015-03-03 20:20:18 MSK
Looks like, strangely enough, VirtualBox additions were the culprit. 

If anyone experiences such problems, please try to uninstall dkms-vboxadditions, reboot the system and see if the problem is still there.
Comment 12 Eugene Shatokhin 2015-03-03 21:14:53 MSK
*** Bug 4808 has been marked as a duplicate of this bug. ***
Comment 13 Eugene Shatokhin 2015-03-11 11:55:12 MSK
No more complaints so far, closing.
Comment 14 Andrey Bondrov 2015-06-01 11:33:16 MSD
Advisory: "Do not force loading of "vboxguest" kernel module"

https://abf.rosalinux.ru/build_lists/2506442
https://abf.rosalinux.ru/build_lists/2506443
Comment 15 Vladimir Potapov 2015-06-09 14:46:39 MSD
virtualbox-4.3.28-2
https://abf.rosalinux.ru/build_lists/2506442
https://abf.rosalinux.ru/build_lists/2506443
********************************* Advisory **************************
Do not force loading of "vboxguest" kernel module
*********************************************************************
QA Verified