Bug 4800 - ROMP plugin could not activate for firefox
: ROMP plugin could not activate for firefox
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Arkady L. Shane
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-17 09:52 MSK by FirstLevel
Modified: 2015-05-28 18:58 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
live-r5-could-not-activate-romp-plugin.jpg (87.59 KB, image/jpeg)
2014-12-17 09:52 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2014-12-17 09:52:56 MSK
Created attachment 3577 [details]
live-r5-could-not-activate-romp-plugin.jpg

Description of problem:
I have tested https://abf.rosalinux.ru/platforms/rosa2014.1/products/86/product_build_lists/8108
If I open http://techslides.com/sample-webm-ogg-and-mp4-video-files-for-html5 and try to open FLV file I see that ROMP plugin could not activate for firefox.
Firefox only try to save file but not to play with plugin

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-12-17 10:32:50 MSK
For installed system - bug is valid
Comment 2 FirstLevel 2014-12-23 16:59:40 MSK
Case is actual for 8280
Comment 3 Stanislav Fomin 2015-01-14 18:24:32 MSK
Похоже потеряли ROMP-плагины к FF.
Причем в системе rosa-media-player-plugin установлен (т.е. проблема не в образе).

Аркадий, подиагностируй
(может быть можно решить без правки самого плагина).
Comment 4 Arkady L. Shane 2015-01-20 19:11:08 MSK
Похоже там всё плохо. При самом первом запуске firefox выдаётся такое:

LoadPlugin: failed to initialize shared library
/usr/lib64/mozilla/plugins/librosa-media-player-plugin-smp.so
[/usr/lib64/mozilla/plugins/librosa-media-player-plugin-smp.so: undefined symbol: _ZN16MiniControlPanel18volumeWheelControlEi]
LoadPlugin: failed to initialize shared library
/usr/lib64/mozilla/plugins/librosa-media-player-plugin-qt.so
[/usr/lib64/mozilla/plugins/librosa-media-player-plugin-qt.so: undefined symbol: _ZN16MiniControlPanel18volumeWheelControlEi]
LoadPlugin: failed to initialize shared library
/usr/lib64/mozilla/plugins/librosa-media-player-plugin-rm.so
[/usr/lib64/mozilla/plugins/librosa-media-player-plugin-rm.so: undefined symbol: _ZN16MiniControlPanel18volumeWheelControlEi]
LoadPlugin: failed to initialize shared library
/usr/lib64/mozilla/plugins/librosa-media-player-plugin-dvx.so
[/usr/lib64/mozilla/plugins/librosa-media-player-plugin-dvx.so: undefined symbol: _ZN16MiniControlPanel18volumeWheelControlEi]
LoadPlugin: failed to initialize shared library
/usr/lib64/mozilla/plugins/librosa-media-player-plugin-wmp.so
[/usr/lib64/mozilla/plugins/librosa-media-player-plugin-wmp.so: undefined symbol: _ZN16MiniControlPanel18volumeWheelControlEi]

И пересборка плагинов не помогает.
Comment 5 Ural Mullabaev 2015-01-22 14:23:47 MSK
Такое впечатление, что проблема в сборке плагина под новую платформу rosa2014.1.
Если поставить плагин rosa-media-player-plugin версии 1.6.2 под rosa2012.1, то проблема уходит, ходя исходный код с версией 1.6.З одинаковый.
Comment 6 Denis Silakov 2015-05-28 18:58:23 MSD
Исправлено вот этим коммитом: https://abf.io/import/rosa-media-player-plugin/commit/5aeb8247a499a3f3cbf94b3bcd6337b07b6effa3

И сейчас romp-plugin вполне работает.