Bug 4787 - krfb incorrect localized
: krfb incorrect localized
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Localization
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: JDronova
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-12 18:58 MSK by Vladimir Potapov
Modified: 2015-03-30 21:15 MSD (History)
5 users (show)

See Also:
RPM Package: krfb
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
ss (48.25 KB, image/png)
2014-12-12 18:58 MSK, Vladimir Potapov
Details
krfb-help.png (199.07 KB, image/png)
2014-12-25 17:52 MSK, FirstLevel
Details
KRFB.png (208.40 KB, image/png)
2015-03-30 21:15 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2014-12-12 18:58:58 MSK
Created attachment 3570 [details]
ss

krfb incorrect localized (see screenshot)
Comment 1 FirstLevel 2014-12-23 16:17:30 MSK
Actual for 8280
Comment 2 JDronova 2014-12-23 17:05:17 MSK
Это входит в состав current?
Comment 3 FirstLevel 2014-12-23 17:22:42 MSK
(In reply to comment #2)
> Это входит в состав current?

Что такое current?
Comment 4 JDronova 2014-12-25 17:49:41 MSK
А если в меня «Справка» выбрать пункт «Сменить язык интерфейса приложения», то шо будет? У меня в R3 krfb весь на русском если чо, куда оно могло подеваться-то потом?
Comment 5 FirstLevel 2014-12-25 17:52:27 MSK
Created attachment 3587 [details]
krfb-help.png
Comment 6 FirstLevel 2014-12-25 17:52:42 MSK
(In reply to comment #4)
> А если в меня «Справка» выбрать пункт «Сменить язык интерфейса приложения»,
> то шо будет? У меня в R3 krfb весь на русском если чо, куда оно могло
> подеваться-то потом?

krfb-help.png

Вот так у меня
Comment 7 FirstLevel 2014-12-25 17:54:30 MSK
(In reply to comment #6)
> (In reply to comment #4)
> > А если в меня «Справка» выбрать пункт «Сменить язык интерфейса приложения»,
> > то шо будет? У меня в R3 krfb весь на русском если чо, куда оно могло
> > подеваться-то потом?
> 
> krfb-help.png
> 
> Вот так у меня

И смена на английский, затем на русский - ничего не меняет.
Comment 8 JDronova 2014-12-25 19:46:19 MSK
Штранно всё это, надо разобраться
Comment 9 FirstLevel 2015-01-14 13:31:46 MSK
Актуально с этими обновлениями http://bugs.rosalinux.ru/show_bug.cgi?id=4858
Comment 10 Denis Silakov 2015-03-20 14:24:11 MSK
Тут все просто.

Со времен KDE-4.12, в krfb поменяли немного строк и теперь в русском po-файле есть всякие "fuzzy", которые как-то никто не правит.
Comment 11 VictorR2007 2015-03-21 09:37:24 MSK
(In reply to comment #10)
> Тут все просто.
> 
> Со времен KDE-4.12, в krfb поменяли немного строк и теперь в русском
> po-файле есть всякие "fuzzy", которые как-то никто не правит.

В новом, собранном kde-l10n в патче kde-l10n-ru-4.14.3-krfb-ru.po.patch,
в строке 62 есть опечатка.
 
+"Если включен режим доступа бех подтверждения и удаленный пользователь вводит "

https://abf.rosalinux.ru/import/kde-l10n/diff/ea6a79ef731f15d65d3884843bdeb3e2dbdf5d4d...1d0e6e3ac53a6d582ceeaa11b4af194c4b331a49
Comment 12 Denis Silakov 2015-03-21 19:11:42 MSK
Спасибо, поправил. Думаю, можно отправить на QA.

Advisory:
Fixed Russian localization for Krfb.

Build lists:
https://abf.io/build_lists/2474399
https://abf.io/build_lists/2474400
Comment 13 FirstLevel 2015-03-23 10:30:23 MSK
(In reply to comment #12)
> Спасибо, поправил. Думаю, можно отправить на QA.
> 
> Advisory:
> Fixed Russian localization for Krfb.
> 
> Build lists:
> https://abf.io/build_lists/2474399
> https://abf.io/build_lists/2474400

Krfb localization is good for 32 and 64bit
Comment 14 Vladimir Potapov 2015-03-25 11:39:01 MSK
The update sent to expanded testing
***********************************
Comment 15 Vladimir Potapov 2015-03-30 08:45:55 MSD
kde-l10n-4.14.3-5
https://abf.io/build_lists/2474399
https://abf.io/build_lists/2474400
************************** Advisory **************************
Fixed Russian localization for Krfb.
**************************************************************
QA Verified
Comment 16 Andrey Bondrov 2015-03-30 09:30:41 MSD
This update should have been denied because we have kde-l10n-4.14.3-5 in another update request, that was approved today.
Comment 17 Andrey Bondrov 2015-03-30 09:34:15 MSD
I mean kde-l10n-4.14.3-7, not kde-l10n-4.14.3-5.
Comment 18 JDronova 2015-03-30 15:24:53 MSD
*** Bug 5229 has been marked as a duplicate of this bug. ***
Comment 19 FirstLevel 2015-03-30 21:15:40 MSD
New krfb is localized KRFB.png
Comment 20 FirstLevel 2015-03-30 21:15:54 MSD
Created attachment 3850 [details]
KRFB.png