Bug 4777 - [UPDATE REQUEST] fglrx 14.301.1001-3
: [UPDATE REQUEST] fglrx 14.301.1001-3
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-09 17:15 MSK by Eugene Shatokhin
Modified: 2014-12-12 15:11 MSK (History)
3 users (show)

See Also:
RPM Package: x11-driver-video-fglrx
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
eugene.shatokhin: published+


Attachments
updatelog (4.95 KB, text/x-log)
2014-12-10 21:30 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2014-12-09 17:15:23 MSK
Added a fix for bug #4740.
Comment 1 Eugene Shatokhin 2014-12-09 17:20:37 MSK
Advisory:
The packages with the proprietary graphics driver (fglrx) from AMD have been updated. A missing symlink needed to run Steam was added (bug 4740).

Build lists:
i586:
https://abf.rosalinux.ru/build_lists/2364088
x86_64:
https://abf.rosalinux.ru/build_lists/2364089
Comment 2 Eugene Shatokhin 2014-12-09 17:39:54 MSK
Hints for testing.

If possible, please test if Steam starts and there is no regressions there compared to the previous version of fglrx.

Apart from that, our test system has shown no regressions so far:
(x64) http://hw.rosalinux.ru/index.php?probe=a3542c0e68
(x32) http://hw.rosalinux.ru/index.php?probe=ffec1b5a19
Comment 3 FirstLevel 2014-12-10 09:41:42 MSK
No regressions for 
http://hw.rosalinux.ru/index.php?probe=cec5762e5d
Comment 4 Vladimir Potapov 2014-12-10 14:16:54 MSK
After update system don't boot
"reached target Graphical interface"
Comment 5 FirstLevel 2014-12-10 15:11:03 MSK
(In reply to comment #4)
> After update system don't boot
> "reached target Graphical interface"

Could You give the link HW probe?
Comment 6 Vladimir Potapov 2014-12-10 16:10:26 MSK
http://hw.rosalinux.ru/index.php?probe=8e6ab17c3b

I reproduce the issue twice :-(
1) Set up fglrx from repositories
2) reboot
3) update from containers
4) reboot 

If I run XFdrake in text mode after the issue, the system up.
hw-info after up the system
http://hw.rosalinux.ru/index.php?probe=a1c104e88e
Comment 7 Vladimir Potapov 2014-12-10 16:25:39 MSK
(In reply to comment #6)
> http://hw.rosalinux.ru/index.php?probe=8e6ab17c3b
> 
> I reproduce the issue twice :-(
> 1) Set up fglrx from repositories
> 2) reboot
> 3) update from containers
> 4) reboot 
> 
> If I run XFdrake in text mode after the issue, the system up.
> hw-info after up the system
> http://hw.rosalinux.ru/index.php?probe=a1c104e88e

***********************************
QA Denied
Comment 8 Eugene Shatokhin 2014-12-10 19:32:29 MSK
First of all, please re-check if this is a regression. 

The only change in this update is one added symlink (/usr/X11R6/lib/modules/dri/fglrx_dri.so to /usr/lib/dri/fglrx_dri.so). 

I doubt it is the cause of the problem.
Comment 9 Vladimir Potapov 2014-12-10 21:30:39 MSK
Created attachment 3568 [details]
updatelog
Comment 10 FirstLevel 2014-12-10 23:29:15 MSK
I have no any issues with clean R5 installation and upgrade to updated driver from container on my laptop HP6465b (http://hw.rosalinux.ru/index.php?probe=cec5762e5d)
Comment 11 Eugene Shatokhin 2014-12-11 11:26:22 MSK
No clue in the update log, everything looks normal.

Re-checked on my machines - no problems too. 

However, I do not have hybrid graphics (Intel+AMD) wnd it seems to have something to do with the problem, according to Xorg.log. Perhaps, the problem affects such hybrid systems only.

If it is possible to check the update on some other machine with Intel+AMD, please do so. Meanwhile, I'll try to figure out what went wrong. Looks like fglrx failed to probe Intel's (!) graphics card...
Comment 12 Eugene Shatokhin 2014-12-11 20:43:17 MSK
Well, looks like the root cause of the problem is that both fglrx packages and XFdrake try to set/remove 'nomodeset' boot option. This results in a mess. 

I will remove nomodeset-related logic from fglrx packages (XFdrake should be enough). The updated ones will be available soon.
Comment 13 Eugene Shatokhin 2014-12-11 21:36:03 MSK
Advisory:
The packages with the proprietary graphics driver (fglrx) from AMD have been updated. 
* A missing symlink needed to run Steam was added (bug 4740). 
* fglrx packages no longer set/remove 'nomodeset' boot option themselves (XFdrake already handles it).

Build lists:
i586:
https://abf.rosalinux.ru/build_lists/2365375 
x86_64:
https://abf.rosalinux.ru/build_lists/2365376
Comment 14 FirstLevel 2014-12-12 09:29:52 MSK
For my laptop HP6465b with AMD A4 (http://hw.rosalinux.ru/index.php?probe=cec5762e5d)
update - ok
glxgears - no regression
sleep and waiting mode - no regression
Comment 15 Sergey A. Sokolov 2014-12-12 11:13:54 MSK
$ fgl_glxgears 
Using GLX_SGIX_pbuffer
6229 frames in 5.0 seconds = 1245.800 FPS
6606 frames in 5.0 seconds = 1321.200 FPS
6613 frames in 5.0 seconds = 1322.600 FPS
6621 frames in 5.0 seconds = 1324.200 FPS
6624 frames in 5.0 seconds = 1324.800 FPS
^C
$ rpm -qa | grep fglrx
dkms-fglrx-14.301.1001-3-rosa2014.1.x86_64
fglrx-control-center-14.301.1001-3-rosa2014.1.x86_64
x11-driver-video-fglrx-14.301.1001-3-rosa2014.1.x86_64

http://hw.rosalinux.ru/index.php?probe=e2a6b707d5
Comment 16 Vladimir Potapov 2014-12-12 12:43:15 MSK
fglrx-14.301.1001-3
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2365375/i586/non-free/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2365376/x86_64/non-free/release/
***************************** Advisory *************************
The packages with the proprietary graphics driver (fglrx) from AMD have been updated. 
* A missing symlink needed to run Steam was added (bug 4740). 
* fglrx packages no longer set/remove 'nomodeset' boot option themselves (XFdrake already handles it).
****************************************************************
QA Verified