Bug 4768 - [UPDATE REQUEST] libbluedevil and bluedevil 2.0 rc1 -> 2.0
: [UPDATE REQUEST] libbluedevil and bluedevil 2.0 rc1 -> 2.0
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-04 10:00 MSK by Andrey Bondrov
Modified: 2014-12-09 15:14 MSK (History)
2 users (show)

See Also:
RPM Package: libbluedevil, bluedevil
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
blue-01.png (164.05 KB, image/png)
2014-12-04 11:57 MSK, FirstLevel
Details
blue-02.png (168.17 KB, image/png)
2014-12-04 11:57 MSK, FirstLevel
Details
Патч, исправляющий проблему. (384 bytes, application/gzip)
2014-12-08 16:05 MSK, VictorR2007
Details
bluetooth-is-enabled.png (89.71 KB, image/png)
2014-12-08 17:51 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-12-04 10:00:30 MSK
Version 2.0 final of libbluedevil and bluedevil was released.
Comment 2 FirstLevel 2014-12-04 10:56:51 MSK
Update goes well.
Bluetooth service is started after reboot successfully.
Comment 3 FirstLevel 2014-12-04 11:57:14 MSK
I have such strange situation for real hardware.
I have bluuetooth services in autostart befor update.
After update I have 
[sergei@r4 ~]$ systemctl --all | grep blue
sys-devices-pci0000:00-0000:00:12.0-usb1-1\x2d3-1\x2d3:1.0-bluetooth-hci0.device          loaded    active   plugged   /sys/devices/pci0000:00/0000:00:12.0/usb1/1-3/1-3:1.0/bluetooth/hci0
sys-subsystem-bluetooth-devices-hci0.device                                               loaded    active   plugged   /sys/subsystem/bluetooth/devices/hci0
bluetooth.service                                                                         loaded    active   running   Bluetooth service
bluetooth.target                                                                          loaded    active   active    Bluetooth
[sergei@r4 ~]$ 

But I see that bluetooth is not enabled by default blue-01.png blue-02.png
Is it important?
Comment 4 FirstLevel 2014-12-04 11:57:31 MSK
Created attachment 3555 [details]
blue-01.png
Comment 5 FirstLevel 2014-12-04 11:57:45 MSK
Created attachment 3556 [details]
blue-02.png
Comment 6 Andrey Bondrov 2014-12-04 12:07:42 MSK
(In reply to comment #3)
> But I see that bluetooth is not enabled by default blue-01.png blue-02.png
> Is it important?

Seems to be OK.
Comment 7 FirstLevel 2014-12-04 13:40:59 MSK
(In reply to comment #6)
> (In reply to comment #3)
> > But I see that bluetooth is not enabled by default blue-01.png blue-02.png
> > Is it important?
> 
> Seems to be OK.

But old version of bluedevil has another behavior...
Comment 8 Andrey Bondrov 2014-12-04 13:58:32 MSK
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #3)
> > > But I see that bluetooth is not enabled by default blue-01.png blue-02.png
> > > Is it important?
> > 
> > Seems to be OK.
> 
> But old version of bluedevil has another behavior...

Perhaps it was a bug, see:
https://projects.kde.org/projects/playground/libs/libbluedevil/repository/revisions/c76d6e50ba6466403457371ab8416b0600af4a77
Comment 9 Vladimir Potapov 2014-12-04 17:13:18 MSK
I have a bluetooth sound system. The system automatically enabled after reboot by old version.
With new version after reboot I must
1) Enable bluetooth in tray
2) Enable the sound system in tray menu
It's big regression (for bluetooth mouse too!)
******************************************
QA Denied
Comment 10 Andrey Bondrov 2014-12-04 17:30:44 MSK
Reported upstream: https://bugs.kde.org/show_bug.cgi?id=341546
Comment 11 VictorR2007 2014-12-08 16:05:17 MSK
Created attachment 3561 [details]
Патч, исправляющий проблему.

(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > (In reply to comment #3)
> > > > But I see that bluetooth is not enabled by default blue-01.png blue-02.png
> > > > Is it important?
> > > 
> > > Seems to be OK.
> > 
> > But old version of bluedevil has another behavior...
> 
> Perhaps it was a bug, see:
> https://projects.kde.org/projects/playground/libs/libbluedevil/repository/
> revisions/c76d6e50ba6466403457371ab8416b0600af4a77
Спасибо за подсказку.
Собрал себе с этим патчем и это исправило проблему.
После перезагрузки блютуз активен.
Comment 12 Andrey Bondrov 2014-12-08 17:20:24 MSK
Thanx :-) New build lists:

Advisory: "New version 2.0 final"

libbluedevil:
https://abf.rosalinux.ru/build_lists/2363769
https://abf.rosalinux.ru/build_lists/2363770

bluedevil:
https://abf.rosalinux.ru/build_lists/2363771
https://abf.rosalinux.ru/build_lists/2363772
Comment 13 FirstLevel 2014-12-08 17:40:30 MSK
(In reply to comment #12)
> Thanx :-) New build lists:
> 
> Advisory: "New version 2.0 final"
> 
> libbluedevil:
> https://abf.rosalinux.ru/build_lists/2363769
> https://abf.rosalinux.ru/build_lists/2363770
> 
> bluedevil:
> https://abf.rosalinux.ru/build_lists/2363771
> https://abf.rosalinux.ru/build_lists/2363772

Update goes well.
Comment 14 FirstLevel 2014-12-08 17:50:47 MSK
(In reply to comment #12)
> Thanx :-) New build lists:
> 
> Advisory: "New version 2.0 final"
> 
> libbluedevil:
> https://abf.rosalinux.ru/build_lists/2363769
> https://abf.rosalinux.ru/build_lists/2363770
> 
> bluedevil:
> https://abf.rosalinux.ru/build_lists/2363771
> https://abf.rosalinux.ru/build_lists/2363772

After update and reboot I see
[sergei32@r4-32 ~]$ systemctl --all | grep blue
sys-devices-pci0000:00-0000:00:12.0-usb4-4\x2d3-4\x2d3:1.0-bluetooth-hci0.device          loaded    active   plugged   /sys/devices/pci0000:00/0000:00:12.0/usb4/4-3/4-3:1.0/bluetooth/hci0
sys-subsystem-bluetooth-devices-hci0.device                                               loaded    active   plugged   /sys/subsystem/bluetooth/devices/hci0
bluetooth.service                                                                         loaded    active   running   Bluetooth service
bluetooth.target                                                                          loaded    active   active    Bluetooth
[sergei32@r4-32 ~]$

and bluetooth-is-enabled.png
Comment 15 FirstLevel 2014-12-08 17:51:04 MSK
Created attachment 3563 [details]
bluetooth-is-enabled.png
Comment 16 Andrey Bondrov 2014-12-08 18:01:36 MSK
So, everything is fine now?
Comment 17 Vladimir Potapov 2014-12-09 14:23:22 MSK
libbluedevil-2.0-2
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2363769/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2363770/x86_64/main/release/

bluedevil-2.0-1
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2363771/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2363772/x86_64/main/release/

**************************** Advisory ****************************
New version 2.0 final
******************************************************************
QA Verified