Bug 4758 - [UPDATE REQUEST] packagekit 0.8.11 -> 1.0.3
: [UPDATE REQUEST] packagekit 0.8.11 -> 1.0.3
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-02 16:45 MSK by Andrey Bondrov
Modified: 2015-03-30 11:43 MSD (History)
2 users (show)

See Also:
RPM Package: packagekit
ISO-related:
Bad POT generating:
Upstream:
firstlevel: qa_verified-


Attachments
kapper.jpg (88.24 KB, image/jpeg)
2014-12-08 09:00 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-12-02 16:45:42 MSK
New version of packagekit was released.

Please note that we should also update and check packagekit-qt, apper and gnome-packagekit before publishing packagekit update. But first we need to check packagekit itself, of course.
Comment 1 Andrey Bondrov 2014-12-02 16:49:55 MSK
Advisory: "New version 1.0.3"

https://abf.rosalinux.ru/build_lists/2347176
https://abf.rosalinux.ru/build_lists/2347177
Comment 2 FirstLevel 2014-12-02 17:37:47 MSK
For 32bit installation goes like this:
[root@r4 ~]# urpmi packagekit
GOT: gnome-packagekit-common-3.12.1-2-rosa2014.1.i586
GOT: apper-0.8.1-3-rosa2014.1.i586
Некоторые запрошенные пакеты не могут быть установлены:
gnome-packagekit-common-3.12.1-2-rosa2014.1.i586 (из-за неудовлетворённости libpackagekit-glib2.so.16)
libpackagekit-glib16-0.8.11-3-rosa2014.1.i586 (из-за конфликтов с libpackagekit-glib2_18-1.0.3-1-rosa2014.1.i586)
Продолжить установку? (Y/n) 




For 64bit update goes like this:
Следующий пакет будет удалён для обновления остальных:
gnome-packagekit-common-3.12.1-2-rosa2014.1.x86_64
 (из-за отсутствия libpackagekit-glib2.so.16()(64bit)) (y/N) y
Для удовлетворения зависимостей будут установлены следующие пакеты:
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа 
(источник «tst»)
 lib64packagekit-glib2_18       1.0.3        1             rosa  2014.1 x86_64 
 packagekit                     1.0.3        1             rosa  2014.1 x86_64 
 packagekit-gtk3-module         1.0.3        1             rosa  2014.1 x86_64 
Будет освобождено 11МБ дискового пространства.
Будет загружено 838КБ пакетов.
Установить 3 пакетов? (Y/n) y


    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2347177/x86_64/main/release/lib64packagekit-glib2_18-1.0.3-1-rosa2014.1.x86_64.rpm
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2347177/x86_64/main/release/packagekit-1.0.3-1-rosa2014.1.x86_64.rpm                      
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2347177/x86_64/main/release/packagekit-gtk3-module-1.0.3-1-rosa2014.1.x86_64.rpm          
устанавливается packagekit-gtk3-module-1.0.3-1-rosa2014.1.x86_64.rpm packagekit-1.0.3-1-rosa2014.1.x86_64.rpm lib64packagekit-glib2_18-1.0.3-1-rosa2014.1.x86_64.rpm из /var/cache/urpmi/rpms
warning: LOOP:
warning: removing packagekit-1.0.3-1.x86_64 "Requires(hint): packagekit-gtk3-module = 1.0.3-1:2014.1" from tsort relations.
warning: removing packagekit-gtk3-module-1.0.3-1.x86_64 "Requires: packagekit = 1.0.3-1:2014.1" from tsort relations.
warning: LOOP:
warning: removing packagekit-0.8.11-3.x86_64 "Requires: packagekit = 0.8.11-3" from tsort relations.
warning: removing packagekit-gtk3-module-0.8.11-3.x86_64 "Requires(hint): packagekit-gtk3-module = 0.8.11" from tsort relations.
Подготовка...                    ###################################################################################################################
      1/3: lib64packagekit-glib2_18
                                 ###################################################################################################################
      2/3: packagekit            ###################################################################################################################
      3/3: packagekit-gtk3-module
                                 ###################################################################################################################
      1/4: удаляется packagekit-0.8.11-3.x86_64
                                 ###################################################################################################################
      2/4: удаляется packagekit-gtk3-module-0.8.11-3.x86_64
                                 ###################################################################################################################
удаляется пакет gnome-packagekit-common-3.12.1-2.x86_64
      3/4: удаляется gnome-packagekit-common-3.12.1-2.x86_64
                                 ###################################################################################################################
удаляется пакет lib64packagekit-glib16-0.8.11-3.x86_64
      4/4: удаляется lib64packagekit-glib16-0.8.11-3.x86_64
                                 ###################################################################################################################
Хоть часть пакетов и могла быть установлена, произошли ошибки.
Следующий пакет будет удалён для обновления остальных:
gnome-packagekit-common-3.12.1-2-rosa2014.1.x86_64
 (из-за отсутствия libpackagekit-glib2.so.16()(64bit))
[root@r4-64 ~]#
Comment 3 Andrey Bondrov 2014-12-02 19:08:14 MSK
(In reply to comment #2)
> For 32bit installation goes like this:
> [root@r4 ~]# urpmi packagekit

Can you please try with "urpmi --no-suggests"? gnome-packagekit and apper are not ready yet.
Comment 4 FirstLevel 2014-12-03 10:07:29 MSK
(In reply to comment #3)
> (In reply to comment #2)
> > For 32bit installation goes like this:
> > [root@r4 ~]# urpmi packagekit
> 
> Can you please try with "urpmi --no-suggests"? gnome-packagekit and apper
> are not ready yet.

It's ok with this parameter[root@r4 ~]# urpmi --no-suggests packagekit
Для удовлетворения зависимостей будут установлены следующие пакеты:                                                                                   
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа                                                                     
(источник «tst»)                                                                                                                                      
 libpackagekit-glib2_18         1.0.3        1             rosa  2014.1 i586                                                                          
 packagekit                     1.0.3        1             rosa  2014.1 i586                                                                          
Будет использовано 4.4МБ дополнительного дискового пространства.                                                                                      
Будет загружено 834КБ пакетов.                                                                                                                        
Установить 2 пакетов? (Y/n) y                                                                                                                         
                                                                                                                                                      
                                                                                                                                                      
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2347176/i586/main/release/packagekit-1.0.3-1-rosa2014.1.i586.rpm                           
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2347176/i586/main/release/libpackagekit-glib2_18-1.0.3-1-rosa2014.1.i586.rpm               
устанавливается packagekit-1.0.3-1-rosa2014.1.i586.rpm libpackagekit-glib2_18-1.0.3-1-rosa2014.1.i586.rpm из /var/cache/urpmi/rpms                    
Подготовка...                    ###################################################################################################################  
      1/2: libpackagekit-glib2_18                                                                                                                     
                                 ###################################################################################################################  
      2/2: packagekit            ###################################################################################################################  
[root@r4 ~]#
Comment 5 Andrey Bondrov 2014-12-04 12:01:11 MSK
gnome-packagekit:

Advisory: "New version 3.14.0, build for PackageKit 1.0"
https://abf.rosalinux.ru/build_lists/2348395
https://abf.rosalinux.ru/build_lists/2348396
Comment 6 Andrey Bondrov 2014-12-04 13:40:39 MSK
packagekit-qt:

Advisory: "New version 0.9.5, build both Qt4 and Qt5 versions"

https://abf.rosalinux.ru/build_lists/2348413
https://abf.rosalinux.ru/build_lists/2348414

apper:

Advisory: "New version 0.9.1, build for PackageKit 1.0"

https://abf.rosalinux.ru/build_lists/2348416
https://abf.rosalinux.ru/build_lists/2348417

We don't really support PackageKit so we don't expect these packages to be perfect. They should install and somewhat work (don't segfault on start etc).
Comment 7 FirstLevel 2014-12-04 14:07:18 MSK
(In reply to comment #6)
> packagekit-qt:
> 
> Advisory: "New version 0.9.5, build both Qt4 and Qt5 versions"
> 
> https://abf.rosalinux.ru/build_lists/2348413
> https://abf.rosalinux.ru/build_lists/2348414
> 
> apper:
> 
> Advisory: "New version 0.9.1, build for PackageKit 1.0"
> 
> https://abf.rosalinux.ru/build_lists/2348416
> https://abf.rosalinux.ru/build_lists/2348417
> 
> We don't really support PackageKit so we don't expect these packages to be
> perfect. They should install and somewhat work (don't segfault on start etc).

I do not see "Путь до контейнера" for these 
https://abf.rosalinux.ru/build_lists/2348416
https://abf.rosalinux.ru/build_lists/2348417
Comment 8 Andrey Bondrov 2014-12-04 16:10:02 MSK
(In reply to comment #7)
> I do not see "Путь до контейнера" for these 
> https://abf.rosalinux.ru/build_lists/2348416
> https://abf.rosalinux.ru/build_lists/2348417

Should be fixed now. Please note that:

1. gnome-packagekit requires packagekit containers
2. packagekit-qt requires packagekit and gnome-packagekit containers
3. apper requires packagekit, gnome-packagekit and packagekit-qt containers
Comment 9 FirstLevel 2014-12-08 08:55:53 MSK
(In reply to comment #8)
> (In reply to comment #7)
> > I do not see "Путь до контейнера" for these 
> > https://abf.rosalinux.ru/build_lists/2348416
> > https://abf.rosalinux.ru/build_lists/2348417
> 
> Should be fixed now. Please note that:
> 
> 1. gnome-packagekit requires packagekit containers
> 2. packagekit-qt requires packagekit and gnome-packagekit containers
> 3. apper requires packagekit, gnome-packagekit and packagekit-qt containers

Install and update packages goes well.
Comment 10 FirstLevel 2014-12-08 09:00:18 MSK
I have such issue with apper.
If I try to install packages wirh apper and packages are installed but apper is ended by error kapper.jpg
Comment 11 FirstLevel 2014-12-08 09:00:36 MSK
Created attachment 3560 [details]
kapper.jpg
Comment 12 FirstLevel 2014-12-08 09:03:39 MSK
konsole output:

[root@r4 ~]# apper
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
[root@r4 ~]# void PackageModel::clear() 
void PackageModel::finished() PackageKit::Transaction(0x951d3c8) PackageKit::Transaction(0x951d3c8) 
void PackageModel::finished() QObject(0x0)  QObject(0x0)  
void PackageModel::clear() 

[root@r4 ~]#
Comment 13 Andrey Bondrov 2014-12-08 09:47:27 MSK
I see, thanx.
Comment 14 FirstLevel 2014-12-15 15:11:17 MSK
(In reply to comment #13)
> I see, thanx.

Is it final condition? Will work "As is"?
Comment 15 Andrey Bondrov 2014-12-15 15:33:58 MSK
Sorry, couldn't take a loot at this, let's ask Denis Silakov if he can fix the issue.
Comment 16 FirstLevel 2014-12-15 15:44:49 MSK
Waiting for final resolution of problems

QA Denied
Comment 17 Denis Silakov 2015-03-30 11:43:12 MSD
Packagekit has been updated to version 1.0.5 in bug #5219