Bug 4744 - [UPDATE REQUEST] kcm_touchpad 0.3.1 -> kcm-touchpad 1.1
: [UPDATE REQUEST] kcm_touchpad 0.3.1 -> kcm-touchpad 1.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-27 21:06 MSK by Andrey Bondrov
Modified: 2014-12-03 16:45 MSK (History)
3 users (show)

See Also:
RPM Package: kcm-touchpad
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
Not localized (122.17 KB, image/png)
2014-11-28 11:42 MSK, FirstLevel
Details
description (129.68 KB, image/png)
2014-11-28 12:00 MSK, FirstLevel
Details
old-kcm_touchpad.png (73.42 KB, image/png)
2014-11-28 12:07 MSK, FirstLevel
Details
not localized (248.03 KB, image/png)
2014-12-03 13:32 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-11-27 21:06:23 MSK
Old package kcm_touchpad 0.3.1 should be replaced with kcm-touchpad 1.1. Please test for regressions.
Comment 1 Andrey Bondrov 2014-11-27 21:12:08 MSK
Advisory: "New version 1.1. New package plasma-applet-touchpad was added."

https://abf.rosalinux.ru/build_lists/2345490
https://abf.rosalinux.ru/build_lists/2345491

P.S. kcm_touchpad should be removed from Main after publishing kcm-touchpad.
Comment 2 Andrey Bondrov 2014-11-28 06:14:31 MSK
Advisory: "New version 1.1. New package plasma-applet-touchpad and Russian translation were added."

https://abf.rosalinux.ru/build_lists/2345622
https://abf.rosalinux.ru/build_lists/2345623
Comment 3 FirstLevel 2014-11-28 11:34:12 MSK
Update goes well.
Install plasma-applet-touchpad goes well.
Comment 4 FirstLevel 2014-11-28 11:42:14 MSK
Created attachment 3535 [details]
Not localized
Comment 5 FirstLevel 2014-11-28 11:43:21 MSK
I see one not localized terms. See "50,00 scrolls/sec2" in "Замедление скорости" on the screenshot
Comment 6 FirstLevel 2014-11-28 12:00:48 MSK
Created attachment 3536 [details]
description
Comment 7 FirstLevel 2014-11-28 12:01:08 MSK
And appropriate description also not localized
Comment 8 FirstLevel 2014-11-28 12:07:57 MSK
Created attachment 3537 [details]
old-kcm_touchpad.png
Comment 9 FirstLevel 2014-11-28 12:08:43 MSK
Also in new kcm I could not find any information about model of touchpad.
Old kcm_touchpad has such information - old-kcm_touchpad.png
Comment 10 Andrey Bondrov 2014-11-28 14:05:54 MSK
(In reply to comment #9)
> Also in new kcm I could not find any information about model of touchpad.
> Old kcm_touchpad has such information - old-kcm_touchpad.png

I'll take a look if I can fix it.
Comment 11 Andrey Bondrov 2014-11-28 16:47:55 MSK
(In reply to comment #5)
> Also in new kcm I could not find any information about model of touchpad.

Looks like this feature was removed in upstream long time ago. It's too much effort to restore it with patch (because we'll have to take care of all translations).

I created upstream feature request to restore information panel:
https://bugs.kde.org/show_bug.cgi?id=341350

(In reply to comment #5)
> I see one not localized terms. See "50,00 scrolls/sec2" in "Замедление
> скорости" on the screenshot

Should be fixed now.

Advisory: "New version 1.1. New package plasma-applet-touchpad and Russian translation were added."

https://abf.rosalinux.ru/build_lists/2345739
https://abf.rosalinux.ru/build_lists/2345740
Comment 12 FirstLevel 2014-12-01 11:10:50 MSK
(In reply to comment #11)
> (In reply to comment #5)
> > Also in new kcm I could not find any information about model of touchpad.
> 
> Looks like this feature was removed in upstream long time ago. It's too much
> effort to restore it with patch (because we'll have to take care of all
> translations).
> 
> I created upstream feature request to restore information panel:
> https://bugs.kde.org/show_bug.cgi?id=341350
> 
> (In reply to comment #5)
> > I see one not localized terms. See "50,00 scrolls/sec2" in "Замедление
> > скорости" on the screenshot
> 
> Should be fixed now.
> 
> Advisory: "New version 1.1. New package plasma-applet-touchpad and Russian
> translation were added."
> 
> https://abf.rosalinux.ru/build_lists/2345739
> https://abf.rosalinux.ru/build_lists/2345740

Localization is OK
Comment 13 Vladimir Potapov 2014-12-03 13:32:46 MSK
Created attachment 3553 [details]
not localized

Не локализован апплет.
Comment 14 Andrey Bondrov 2014-12-03 15:08:44 MSK
(In reply to comment #13)
> Created attachment 3553 [details]
> not localized
> 
> Не локализован апплет.

Advisory: "New version 1.1. New package plasma-applet-touchpad and Russian translation were added."

https://abf.rosalinux.ru/build_lists/2347849
https://abf.rosalinux.ru/build_lists/2347850
Comment 15 Vladimir Potapov 2014-12-03 16:09:23 MSK
kcm-touchpad-1.1-3.20141125.4
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2347849/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2347850/x86_64/main/release/
**************************** Advisory *************************
New version 1.1. New package plasma-applet-touchpad and Russian translation were added.
***************************************************************
QA Verified