Bug 4716 - [UPDATE REQUEST] VirtualBox 4.3.18 -> 4.3.20
: [UPDATE REQUEST] VirtualBox 4.3.18 -> 4.3.20
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-22 17:38 MSK by Andrey Bondrov
Modified: 2014-11-27 12:10 MSK (History)
1 user (show)

See Also:
RPM Package: virtualbox
ISO-related:
Bad POT generating:
Upstream:
firstlevel: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-11-22 17:38:18 MSK
New version of VirtualBox was released.
Comment 1 Andrey Bondrov 2014-11-22 17:39:44 MSK
Advisory: "New bugfix version 4.3.20"

https://abf.rosalinux.ru/build_lists/2343364
https://abf.rosalinux.ru/build_lists/2343365

P.S. Changelog: https://www.virtualbox.org/wiki/Changelog
Comment 2 FirstLevel 2014-11-24 16:52:37 MSK
Install and update goes well.
Create new VM - also goes well
Comment 3 FirstLevel 2014-11-25 10:12:20 MSK
When I have uninstalled new virtualbox the package dkms-virtualbox was not deleted.
Because of this I could not install old virtualbox.
Maybe is it possible to create some dependencies that uninstalling virtualbox causes unistalling dkms-virtualbox?
Comment 4 Andrey Bondrov 2014-11-25 15:04:47 MSK
(In reply to comment #3)
> When I have uninstalled new virtualbox the package dkms-virtualbox was not
> deleted.
> Because of this I could not install old virtualbox.
> Maybe is it possible to create some dependencies that uninstalling
> virtualbox causes unistalling dkms-virtualbox?

I'm not sure if dkms-virtualbox itself makes any sense without virtualbox. It requires investigation.
Comment 5 Andrey Bondrov 2014-11-26 16:34:38 MSK
(In reply to comment #4)
> (In reply to comment #3)
> > When I have uninstalled new virtualbox the package dkms-virtualbox was not
> > deleted.
> > Because of this I could not install old virtualbox.
> > Maybe is it possible to create some dependencies that uninstalling
> > virtualbox causes unistalling dkms-virtualbox?
> 
> I'm not sure if dkms-virtualbox itself makes any sense without virtualbox.
> It requires investigation.

Advisory: "New bugfix version 4.3.20. Uninstall DKMS module when main VirtualBox package in uninstalled"

https://abf.rosalinux.ru/build_lists/2345136
https://abf.rosalinux.ru/build_lists/2345137
Comment 6 FirstLevel 2014-11-26 17:34:13 MSK
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > When I have uninstalled new virtualbox the package dkms-virtualbox was not
> > > deleted.
> > > Because of this I could not install old virtualbox.
> > > Maybe is it possible to create some dependencies that uninstalling
> > > virtualbox causes unistalling dkms-virtualbox?
> > 
> > I'm not sure if dkms-virtualbox itself makes any sense without virtualbox.
> > It requires investigation.
> 
> Advisory: "New bugfix version 4.3.20. Uninstall DKMS module when main
> VirtualBox package in uninstalled"
> 
> https://abf.rosalinux.ru/build_lists/2345136
> https://abf.rosalinux.ru/build_lists/2345137

Install and update goes well.
Create new VM - also goes well
Full Uninstallation goes well.
Comment 7 FirstLevel 2014-11-26 21:08:55 MSK
I could forward USB from host to guest in 64bit and could not in 32bit.
Comment 8 FirstLevel 2014-11-27 09:24:40 MSK
(In reply to comment #7)
> I could forward USB from host to guest in 64bit and could not in 32bit.

No regression because for old version of VirtualBox I see same situation
Comment 9 FirstLevel 2014-11-27 11:34:34 MSK
virtualbox-4.3.20-2
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2345136/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2345137/x86_64/main/release/
************************ Advisory **********************
"New bugfix version 4.3.20. Uninstall DKMS module when main VirtualBox package in uninstalled
********************************************************
QA Verified