Bug 4701 - Read-only root after installation of R4 on USB flash drive
: Read-only root after installation of R4 on USB flash drive
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-20 13:19 MSK by Andrey Ponomarenko
Modified: 2016-01-29 15:15 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2014-11-20 13:19:30 MSK
Description of problem:

The USB flash drive is mounted as read-only device after the installation of ROSA Fresh Desktop R4 on it. "/root" and "/home" are both read-only. So I can't use the system at all.

HP gt7725: http://hw.rosalinux.ru/index.php?probe=a41fd80751


Version-Release number of selected component (if applicable): R4


How reproducible: always


Steps to Reproduce:
1. Install ROSA R4 on the USB flash drive
2. Enter to the system
3. Try to install any package
Comment 1 Andrey Ponomarenko 2014-11-20 13:36:45 MSK
Fixed by remounting root and home before login to the system (in the second console, Ctrl+Alt+F2):

$> mount -o remount,rw /
$> mount -o remount,rw /home
Comment 2 Andrey Ponomarenko 2014-11-20 13:39:41 MSK
HP gt7725 + R4 on USB flash drive OK: http://hw.rosalinux.ru/index.php?probe=e7f513776c

All is OK after remounting.
Comment 3 Konstantin Vlasov 2014-11-20 19:03:24 MSK
Unfortunately, I cannot reproduce it on my computer. I tried both legacy BIOS and UEFI modes, but in all cases the root system was mounted read-write, and packages are installed without problems. (However, due to small USB flash disk I had to install ROSA without separate /home and without swap.)

Please, post the contents of: /etc/fstab, grub.cfg, journalctl -a.

Can you reproduce it on other computers by booting from the same flash disk?
Comment 4 Denis Silakov 2016-01-29 15:15:58 MSK
No reproducer for a long time - let's close. There are numerous reasons for root partition to become read-only, each case should be investigated separately.