Bug 4641 - [UPDATE REQUEST] gthumb 3.2.8 -> 3.3.2
: [UPDATE REQUEST] gthumb 3.2.8 -> 3.3.2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-10 18:30 MSK by Andrey Bondrov
Modified: 2016-01-14 19:28 MSK (History)
5 users (show)

See Also:
RPM Package: gthumb
ISO-related:
Bad POT generating:
Upstream:
firstlevel: qa_verified-
kuzma.kazygashev: secteam_verified+


Attachments
old.jpg (105.42 KB, image/jpeg)
2014-11-11 10:18 MSK, FirstLevel
Details
new.jpg (97.87 KB, image/jpeg)
2014-11-11 10:18 MSK, FirstLevel
Details
not-translated-01.jpg (127.70 KB, image/jpeg)
2014-11-11 10:32 MSK, FirstLevel
Details
not-translated-02.jpg (122.54 KB, image/jpeg)
2014-11-11 10:32 MSK, FirstLevel
Details
not-translated-03.jpg (123.64 KB, image/jpeg)
2014-11-11 10:32 MSK, FirstLevel
Details
not-translated-04.jpg (116.77 KB, image/jpeg)
2014-11-11 10:32 MSK, FirstLevel
Details
01-gthumb.jpg (70.99 KB, image/jpeg)
2014-11-24 10:47 MSK, FirstLevel
Details
02-no-hints.jpg (74.40 KB, image/jpeg)
2014-11-24 10:48 MSK, FirstLevel
Details
03-no-hints-bad-translation.jpg (73.12 KB, image/jpeg)
2014-11-24 10:52 MSK, FirstLevel
Details
04-invisible text.jpg (88.99 KB, image/jpeg)
2014-11-24 10:55 MSK, FirstLevel
Details
05-invisible text.jpg (92.52 KB, image/jpeg)
2014-11-24 10:56 MSK, FirstLevel
Details
06-exif-untranslated.jpg (87.93 KB, image/jpeg)
2014-11-24 11:00 MSK, FirstLevel
Details
07-themes.jpg (92.65 KB, image/jpeg)
2014-11-24 11:04 MSK, FirstLevel
Details
08-histogram.jpg (82.55 KB, image/jpeg)
2014-11-24 11:12 MSK, FirstLevel
Details
Непереводимый текст (113.30 KB, image/jpeg)
2014-11-24 18:19 MSK, VictorR2007
Details
Нет перевода в свойствах (137.71 KB, image/jpeg)
2014-11-24 18:25 MSK, VictorR2007
Details
Не переведены строки выбора сортировки для действия переименования. (110.58 KB, image/jpeg)
2014-11-24 18:33 MSK, VictorR2007
Details
new-gthumb-03.png (157.18 KB, image/png)
2014-11-30 18:02 MSK, FirstLevel
Details
new-gthumb-04.png (278.00 KB, image/png)
2014-11-30 18:02 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-11-10 18:30:15 MSK
New version of gthumb was released.
Comment 1 FirstLevel 2014-11-10 18:50:45 MSK
(In reply to comment #0)
> New version of gthumb was released.

Sorry, but where are the links to containers?
Comment 2 Andrey Bondrov 2014-11-10 18:53:54 MSK
Advisory: "New version 3.3.2"

https://abf.rosalinux.ru/build_lists/2331518
https://abf.rosalinux.ru/build_lists/2331519
Comment 3 Andrey Bondrov 2014-11-10 18:54:35 MSK
(In reply to comment #1)
> (In reply to comment #0)
> > New version of gthumb was released.
> 
> Sorry, but where are the links to containers?

Containers are posted when bug is marked as fixed :-)
Comment 4 FirstLevel 2014-11-11 10:18:37 MSK
Created attachment 3433 [details]
old.jpg
Comment 5 FirstLevel 2014-11-11 10:18:51 MSK
Created attachment 3434 [details]
new.jpg
Comment 6 FirstLevel 2014-11-11 10:20:54 MSK
Is it important that that old gthumb looks like old.jpg and new gthumb looks like new.jpg?
Comment 7 FirstLevel 2014-11-11 10:31:34 MSK
32
install - ok
update - 

64
install - ok
update - ok
Comment 8 FirstLevel 2014-11-11 10:32:01 MSK
Created attachment 3435 [details]
not-translated-01.jpg
Comment 9 FirstLevel 2014-11-11 10:32:16 MSK
Created attachment 3436 [details]
not-translated-02.jpg
Comment 10 FirstLevel 2014-11-11 10:32:38 MSK
Created attachment 3437 [details]
not-translated-03.jpg
Comment 11 FirstLevel 2014-11-11 10:32:52 MSK
Created attachment 3438 [details]
not-translated-04.jpg
Comment 12 FirstLevel 2014-11-11 10:35:05 MSK
New gthumb has very bad localization. It is regression because old version has full localization. See attachments.
Comment 13 Andrey Bondrov 2014-11-11 14:28:27 MSK
(In reply to comment #6)
> Is it important that that old gthumb looks like old.jpg and new gthumb looks
> like new.jpg?

Well, it's GNOME application and new GNOME applications look like that. But it seems that we need to add some icon there to Requires (I'll do it later with translation update).
Comment 14 FirstLevel 2014-11-20 12:39:26 MSK
************************ Advisory **********************
10 days without any answer. gthumb  has ugly design and have no some icons
********************************************************
QA Denied
Comment 15 Andrey Bondrov 2014-11-22 18:40:39 MSK
New build lists with updated Russian translation and fixed icons.

Advisory: "New version 3.3.2"

https://abf.rosalinux.ru/build_lists/2343375
https://abf.rosalinux.ru/build_lists/2343376
Comment 16 FirstLevel 2014-11-24 10:47:11 MSK
Created attachment 3506 [details]
01-gthumb.jpg
Comment 17 FirstLevel 2014-11-24 10:47:28 MSK
01-gthumb.jpg - translation regression
Comment 18 FirstLevel 2014-11-24 10:48:33 MSK
Created attachment 3507 [details]
02-no-hints.jpg
Comment 19 FirstLevel 2014-11-24 10:50:24 MSK
There are no hints for two icons in the top right corner (cross and cogwheel
)
Comment 20 FirstLevel 2014-11-24 10:52:50 MSK
Created attachment 3508 [details]
03-no-hints-bad-translation.jpg
Comment 21 FirstLevel 2014-11-24 10:53:45 MSK
03-no-hints-bad-translation.jpg Bad translation ("Details in the bottom left corner and no hints for icon in the borrom right corner (lamp)") - regression
Comment 22 FirstLevel 2014-11-24 10:55:47 MSK
Created attachment 3509 [details]
04-invisible text.jpg
Comment 23 FirstLevel 2014-11-24 10:56:02 MSK
Created attachment 3510 [details]
05-invisible text.jpg
Comment 24 FirstLevel 2014-11-24 10:57:46 MSK
If I press "Упорядочить" in the top right corner the window is appeared - 04-invisible text.jpg
But there is invisible text in this windows, I can see it only if I highlight the text - 05-invisible text.jpg
Comment 25 FirstLevel 2014-11-24 11:00:04 MSK
Created attachment 3511 [details]
06-exif-untranslated.jpg
Comment 26 FirstLevel 2014-11-24 11:02:24 MSK
06-exif-untranslated.jpg - I press "Экспорт - Контактный лист" and see some untranslated text, exif(In reply to comment #24)
> If I press "Упорядочить" in the top right corner the window is appeared -
> 04-invisible text.jpg
> But there is invisible text in this windows, I can see it only if I
> highlight the text - 05-invisible text.jpg

Is is regression
Comment 27 FirstLevel 2014-11-24 11:04:22 MSK
Created attachment 3512 [details]
07-themes.jpg
Comment 28 FirstLevel 2014-11-24 11:05:07 MSK
07-themes.jpg untranslated themes (I press "Экспорт - Веб-альбом"). No regression
Comment 29 FirstLevel 2014-11-24 11:12:01 MSK
Created attachment 3513 [details]
08-histogram.jpg
Comment 30 FirstLevel 2014-11-24 11:12:36 MSK
08-histogram.jpg - untranslated "Max" and "Selected". Regression
Comment 31 FirstLevel 2014-11-24 11:17:12 MSK
Install and update goes well
Comment 32 VictorR2007 2014-11-24 18:19:04 MSK
Created attachment 3516 [details]
Непереводимый текст

Тоже наблюдаю за этой программой.
В окне сохранения файла есть непереведённая строка.
Её перевести не получится.
Она не желает отображаться на русском.
Comment 33 VictorR2007 2014-11-24 18:25:34 MSK
Created attachment 3517 [details]
Нет перевода в свойствах

Эти строки тоже не будут отображаться на русском.
Не пойму, почему.
Как предположение, эти строки записаны в само изображение.
В исходном коде их нет.
Comment 34 VictorR2007 2014-11-24 18:33:32 MSK
Created attachment 3518 [details]
Не переведены строки выбора сортировки для действия переименования.

Эти строки тоже невозможно пока сделать на русском.
Comment 35 VictorR2007 2014-11-24 19:10:21 MSK
Все остальные замечания не сложно исправить.
Но я не хочу трогать строки, типа этих 
"Exif::Photo::SubSecTime"
Скорее всего их переведет Andrey Bondrov.
Но пока его нет и если вам несложно,
посмотрите пожалуйста эти пакеты.
Там добавлены строки локализации.
Но возможно я ещё что-то пропустил.
Для x84_64 http://abf-downloads.rosalinux.ru/victorr2007_personal/repository/rosa2014.1/x86_64/main/release/gthumb-3.3.2-6-rosa2014.1.x86_64.rpm
Для i586 http://abf-downloads.rosalinux.ru/victorr2007_personal/repository/rosa2014.1/i586/main/release/gthumb-3.3.2-6-rosa2014.1.i586.rpm
Comment 36 FirstLevel 2014-11-25 10:51:02 MSK
(In reply to comment #35)
> Все остальные замечания не сложно исправить.
> Но я не хочу трогать строки, типа этих 
> "Exif::Photo::SubSecTime"
> Скорее всего их переведет Andrey Bondrov.
> Но пока его нет и если вам несложно,
> посмотрите пожалуйста эти пакеты.
> Там добавлены строки локализации.
> Но возможно я ещё что-то пропустил.
> Для x84_64
> http://abf-downloads.rosalinux.ru/victorr2007_personal/repository/rosa2014.1/
> x86_64/main/release/gthumb-3.3.2-6-rosa2014.1.x86_64.rpm
> Для i586
> http://abf-downloads.rosalinux.ru/victorr2007_personal/repository/rosa2014.1/
> i586/main/release/gthumb-3.3.2-6-rosa2014.1.i586.rpm

Спасибо, но я подожду пакета от Andrey Bondrov
Comment 37 Andrey Bondrov 2014-11-28 17:07:01 MSK
Advisory: "New version 3.3.2"

https://abf.rosalinux.ru/build_lists/2345772
https://abf.rosalinux.ru/build_lists/2345773

Строки вида "Exif::" переводить не надо, я полагаю. Это стандартные тэги, вряд ли хоть в одной программе они переводятся.
Comment 38 FirstLevel 2014-11-30 18:01:26 MSK
(In reply to comment #37)
> Advisory: "New version 3.3.2"
> 
> https://abf.rosalinux.ru/build_lists/2345772
> https://abf.rosalinux.ru/build_lists/2345773
> 
> Строки вида "Exif::" переводить не надо, я полагаю. Это стандартные тэги,
> вряд ли хоть в одной программе они переводятся.

1. All not translated text - are translated.
2. Not corrected these mistakes
http://bugs.rosalinux.ru/attachment.cgi?id=3509
http://bugs.rosalinux.ru/attachment.cgi?id=3510
Comment 39 FirstLevel 2014-11-30 18:02:00 MSK
Created attachment 3545 [details]
new-gthumb-03.png
Comment 40 FirstLevel 2014-11-30 18:02:18 MSK
Created attachment 3546 [details]
new-gthumb-04.png
Comment 41 FirstLevel 2014-11-30 18:04:49 MSK
One main issue:
I could not import photo from my Canon Powershot
new-gthumb-03.png
new-gthumb-04.png
If I press "Источник" or "Носитель"  nothing happens.
I could work with photo bu Dolphin and coul import photo by Dikikam.
Comment 42 Andrey Bondrov 2014-11-30 19:53:15 MSK
Can you please test gthumb in Gnome? Gnome 3 applications may be too much Gnome-specific.
Comment 43 FirstLevel 2014-11-30 21:53:07 MSK
(In reply to comment #42)
> Can you please test gthumb in Gnome? Gnome 3 applications may be too much
> Gnome-specific.

Ok. What is the link to correct gnome iso?
Comment 45 Arkady L. Shane 2014-12-01 21:00:03 MSK
Look here: https://mail.gnome.org/archives/gthumb-list/2014-November/msg00001.html

3.3.x is unstable version, and it has regression:

https://bugzilla.redhat.com/show_bug.cgi?id=1161052
Comment 46 FirstLevel 2014-12-02 10:20:55 MSK
(In reply to comment #45)
> Look here:
> https://mail.gnome.org/archives/gthumb-list/2014-November/msg00001.html
> 
> 3.3.x is unstable version, and it has regression:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1161052

Sorry but what does it mean? Should I check this version or should I wait for new release?
Comment 47 Andrey Bondrov 2014-12-02 10:42:16 MSK
(In reply to comment #46)
> (In reply to comment #45)
> > Look here:
> > https://mail.gnome.org/archives/gthumb-list/2014-November/msg00001.html
> > 
> > 3.3.x is unstable version, and it has regression:
> > 
> > https://bugzilla.redhat.com/show_bug.cgi?id=1161052
> 
> Sorry but what does it mean? Should I check this version or should I wait
> for new release?

Looks like we should send our translations to upstream and revert the update, keep 3.2.8. Please do "QA denied".
Comment 48 FirstLevel 2014-12-02 14:26:34 MSK
************************ Advisory **********************
Looks like we should send our translations to upstream and revert the update, keep 3.2.8. Please do "QA denied".
********************************************************
QA Denied
Comment 49 Arkady L. Shane 2015-04-15 18:10:55 MSD
Gthumb 3.4.0 released today. It will be in next GNOME 3.16
Comment 50 Denis Silakov 2016-01-14 19:28:02 MSK
We are finally at gnome 3.16 and gthumb 3.4.0 now. If this new package has any issues, feel free to ooen new bugs.