Bug 4635 - Gnome applications don't see printer in KDE
: Gnome applications don't see printer in KDE
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-10 10:36 MSK by FirstLevel
Modified: 2015-06-22 17:28 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
not-printer.jpg (100.56 KB, image/jpeg)
2014-11-10 10:36 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2014-11-10 10:36:12 MSK
Created attachment 3424 [details]
not-printer.jpg

Description of problem:
I have installed printer in R4 and could use it for kwrite, for example.
But I coluld not see printer in shotwell print dialog - not-printer.jpg

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-11-10 10:36:43 MSK
Case is actual for updated version  0.20.2
Comment 2 Denis Silakov 2015-06-16 19:21:08 MSD
This is a common problem with applications that use GTK printing possibilities. To solve it, one should install lib[64]gtk-modules3.0 package. It would be better to add this dependency for the gtk+3 library itself to avoid problems with other applications.
Comment 3 Denis Silakov 2015-06-16 19:21:38 MSD
*** Bug 4112 has been marked as a duplicate of this bug. ***
Comment 4 Denis Silakov 2015-06-16 19:21:44 MSD
*** Bug 4004 has been marked as a duplicate of this bug. ***
Comment 5 Denis Silakov 2015-06-16 19:27:28 MSD
Advisory:
Added lib[64]gtk-modules3.0 to libgtk-3 requirements to force installation of GTK modules in case when gtk3 itself is installed to avoid problems with applications that try to print something using gtk capabilities.

Build lists:
https://abf.io/build_lists/2511192
https://abf.io/build_lists/2511191
Comment 6 FirstLevel 2015-06-17 10:51:06 MSD
32bit

install printer, install gedit. plug container, update - printer is visible
plug container, update, install, printer, install gedit - printer is visible

64bit

install printer, install gedit. plug container, update - printer is visible
plug container, update, install, printer, install gedit - printer is visible
Comment 7 FirstLevel 2015-06-17 18:09:14 MSD
32bit 

plug container, update, urpmi abiword brasero gthumb midori, launch abiword brasero gthumb midori  -  ok

64bit 

plug container, update, urpmi abiword brasero gthumb midori, launch abiword brasero gthumb midori  -  ok
Comment 8 Vladimir Potapov 2015-06-18 11:33:29 MSD
The update is sent to expanded testing
**************************************
Comment 9 Vladimir Potapov 2015-06-22 14:16:06 MSD
gtk+3.0-3.12.2-8
https://abf.io/build_lists/2511192
https://abf.io/build_lists/2511191
********************************** Advisory ***************************
Added lib[64]gtk-modules3.0 to libgtk-3 requirements to force installation of GTK modules in case when gtk3 itself is installed to avoid problems with applications that try to print something using gtk capabilities
***********************************************************************
QA Verified