Bug 4634 - Problems with gurpmi update
: Problems with gurpmi update
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: i586 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-09 07:34 MSK by Ruben Casillas
Modified: 2014-11-11 15:16 MSK (History)
2 users (show)

See Also:
RPM Package: gurpmi-7.32.3-23-rosa2014.1.noarch
ISO-related:
Bad POT generating:
Upstream:


Attachments
This is JPEG image of the error encounter when upgrading packages (114.97 KB, image/jpeg)
2014-11-09 07:34 MSK, Ruben Casillas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruben Casillas 2014-11-09 07:34:02 MSK
Created attachment 3423 [details]
This is JPEG image of the error encounter when upgrading packages

Description of problem:

When I tried to update packages from the Rosa Repository I get the following fatal error:

fatal error occurred  Usage:URPM ::Transaction::order (trans) at usr/lib/perl5/vendor_perl/5.18.2/urpm/install.pm line 360..

I am using Rosa Desktop Fresh R4. I upgrade from R3 to R4.
Comment 1 Vladimir Potapov 2014-11-10 11:35:37 MSK
The issue with perl-URPM-4.57.1 from main/testing
For fix this

# urpm-downloader perl-URPM
# rpm -U --oldpackage perl-URPM*rpm
Comment 2 Denis Silakov 2014-11-11 15:16:40 MSK
That's right, main/testing contained perl-URPM with higher version; that version was broken so we decided to remove it completely. Unfortunately, if you have already installed that version, you could get some troubles with gurpmi/urpmi.

Now we have rebuilt perl-URPM in such a way that a correct version will be installed in your system with updates in any case (even if you have broken perl-URPM from main/testing).