Bug 4621 - [UPDATE REQUEST] shotwell 0.18.0 -> 0.20.2
: [UPDATE REQUEST] shotwell 0.18.0 -> 0.20.2
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-06 09:17 MSK by Andrey Bondrov
Modified: 2014-11-12 16:59 MSK (History)
3 users (show)

See Also:
RPM Package: shotwell
ISO-related:
Bad POT generating:
Upstream:
firstlevel: qa_verified+
andrey.bondrov: published+


Attachments
non-translated-01 (97.62 KB, image/jpeg)
2014-11-07 10:53 MSK, FirstLevel
Details
non-translated-02 (76.12 KB, image/jpeg)
2014-11-07 10:53 MSK, FirstLevel
Details
send-01.jpg (93.17 KB, image/jpeg)
2014-11-07 11:14 MSK, FirstLevel
Details
send-02.jpg (91.27 KB, image/jpeg)
2014-11-07 11:14 MSK, FirstLevel
Details
send-03.jpg (79.92 KB, image/jpeg)
2014-11-07 11:15 MSK, FirstLevel
Details
make a background.jpg (119.83 KB, image/jpeg)
2014-11-07 11:19 MSK, FirstLevel
Details
not-printer.jpg (100.56 KB, image/jpeg)
2014-11-07 11:59 MSK, FirstLevel
Details
non translated clean recycle bin (84.95 KB, image/jpeg)
2014-11-07 12:07 MSK, FirstLevel
Details
shotwell (148.15 KB, image/jpeg)
2014-11-10 19:37 MSK, VictorR2007
Details
Корзина (142.95 KB, image/jpeg)
2014-11-12 08:19 MSK, VictorR2007
Details
panel (32.51 KB, image/png)
2014-11-12 10:52 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-11-06 09:17:28 MSK
New version of shotwell was released.
Comment 1 Andrey Bondrov 2014-11-06 09:22:43 MSK
Advisory: 
"New version 0.20.2. Some notable changes since 0.18.0:
  * Support for Rajce.net and Gallery 3 photo services added
  * Fix Flickr publishing errors due to Flickr moving to HTTPs-only
  * Set background image for lock screen
  * Corrects problems with navigating photos in full-screen mode
  * Fix crash when deleting a photo
  * Fix crash when updating photo data/time
  * Fix crash due to nested tag and changing sidebar selection
  * Better detection of corrupt files while importing
  * Updated translations"

https://abf.rosalinux.ru/build_lists/2329034
https://abf.rosalinux.ru/build_lists/2329035
Comment 2 FirstLevel 2014-11-07 10:53:13 MSK
Update and install is OK for 32 and 64 bit.
I see some non-translated text, but it is no regression.
Comment 3 FirstLevel 2014-11-07 10:53:40 MSK
Created attachment 3413 [details]
non-translated-01
Comment 4 FirstLevel 2014-11-07 10:53:53 MSK
Created attachment 3414 [details]
non-translated-02
Comment 5 FirstLevel 2014-11-07 11:13:49 MSK
I have some issues with this version (maybe no regression)
1. I could not use "Send" item of menu for photo.
- send-01.jpg
- send-02.jpg (I do not see the bottom edge of the buttons and could not maximize this window)
- send-03.jpg - ERROR
Comment 6 FirstLevel 2014-11-07 11:14:08 MSK
Created attachment 3415 [details]
send-01.jpg
Comment 7 FirstLevel 2014-11-07 11:14:23 MSK
Created attachment 3416 [details]
send-02.jpg
Comment 8 FirstLevel 2014-11-07 11:15:09 MSK
Created attachment 3417 [details]
send-03.jpg
Comment 9 FirstLevel 2014-11-07 11:19:25 MSK
Created attachment 3418 [details]
make a background.jpg
Comment 10 FirstLevel 2014-11-07 11:19:37 MSK
Also non-translated make a background.jpg
Comment 11 FirstLevel 2014-11-07 11:44:15 MSK
Don't work functionality "Set as Desktop Background - Use for Desktop "
Comment 12 FirstLevel 2014-11-07 11:49:07 MSK
Don't work functionality "Set as Desktop Background - Use for LockScreen "
Comment 13 FirstLevel 2014-11-07 11:59:25 MSK
Created attachment 3419 [details]
not-printer.jpg
Comment 14 FirstLevel 2014-11-07 11:59:45 MSK
Shotwell does not see installed printer - not-printer.jpg
Comment 15 FirstLevel 2014-11-07 12:05:09 MSK
I could not maximize any windows in shotwell. Close and minimize functionallity - works well
Comment 16 FirstLevel 2014-11-07 12:05:31 MSK
Publication to facebook - works well
Comment 17 FirstLevel 2014-11-07 12:07:41 MSK
Created attachment 3420 [details]
non translated clean recycle bin
Comment 18 FirstLevel 2014-11-07 12:38:59 MSK
1. Shotwell does not see printer - no regression.
2. I could not maximize any windows in shotwell. Close and minimize functionallity - works well - no regression
3. I could not use "Send" item of menu for photo - no regression
4. Menu Item "Make desktop background" does not work at all in old version. In new version new windowmake a background.jpg is appeared.
5. non translated clean recycle bin  - regression. In old version all is translated.
Comment 19 Andrey Bondrov 2014-11-10 15:53:05 MSK
Now Russian translation should be better.

Advisory: 
"New version 0.20.2. Some notable changes since 0.18.0:
  * Support for Rajce.net and Gallery 3 photo services added
  * Fix Flickr publishing errors due to Flickr moving to HTTPs-only
  * Set background image for lock screen
  * Corrects problems with navigating photos in full-screen mode
  * Fix crash when deleting a photo
  * Fix crash when updating photo data/time
  * Fix crash due to nested tag and changing sidebar selection
  * Better detection of corrupt files while importing
  * Updated translations"

https://abf.rosalinux.ru/build_lists/2331477
https://abf.rosalinux.ru/build_lists/2331478
Comment 20 FirstLevel 2014-11-10 16:20:53 MSK
I see that only http://bugs.rosalinux.ru/attachment.cgi?id=3413 is fixed. But other non-localizations are present.
It is final version?
Comment 21 VictorR2007 2014-11-10 19:37:34 MSK
Created attachment 3431 [details]
shotwell

Наверное стоит очистить ~/.cache/shotwell/
У меня по русски.
Comment 22 FirstLevel 2014-11-11 09:19:36 MSK
(In reply to comment #21)
> Created attachment 3431 [details]
> shotwell
> 
> Наверное стоит очистить ~/.cache/shotwell/
> У меня по русски.

Создал нового пользователя. Первый раз запустил под ним новый shotwell.
Непереведенность диалога очистки корзины и установки обоев присутствует.
Comment 23 FirstLevel 2014-11-11 11:00:15 MSK
(In reply to comment #21)
> Created attachment 3431 [details]
> shotwell
> 
> Наверное стоит очистить ~/.cache/shotwell/
> У меня по русски.

Добавка. Я и написал, что исправлено только это место. А остальные - нет.
Они будут исправлены или это финальная версия локализации?
Comment 24 VictorR2007 2014-11-12 08:19:23 MSK
Created attachment 3444 [details]
Корзина

Странно. У вас точно второй релиз пакета.
У меня с пакетом shotwell-0.20.2-2-rosa2014.1.x86_64.rpm
все по русски.
Comment 25 Vladimir Potapov 2014-11-12 10:43:36 MSK
Виктор, только что проверил
1) Удалите что-нибудь в корзину
2) Попробуйте ее очистить. См надписи на кнопках. 
http://bugs.rosalinux.ru/attachment.cgi?id=3420
Comment 26 Vladimir Potapov 2014-11-12 10:49:51 MSK
Ну и еще. 
Перевести Edit Event Comment
http://bugs.rosalinux.ru/attachment.cgi?id=3414
как "Редактировать событие комментарий" имхо, "за гранью добра и зла" :-)
Предлагаю заменить на "Изменить комментарий к событию" (там в открывающемся диалоге переведено именно так)
Comment 27 Vladimir Potapov 2014-11-12 10:52:36 MSK
Created attachment 3447 [details]
panel

Далее, там у меня БКовая панель :-)
Comment 28 Vladimir Potapov 2014-11-12 11:01:34 MSK
Далее, подтверждаю
Файл-сделать фоном рабочего стола.
Получим http://bugs.rosalinux.ru/attachment.cgi?id=3418
Comment 29 Andrey Bondrov 2014-11-12 16:10:03 MSK
More Russian translation fixes.

Advisory: 
"New version 0.20.2. Some notable changes since 0.18.0:
  * Support for Rajce.net and Gallery 3 photo services added
  * Fix Flickr publishing errors due to Flickr moving to HTTPs-only
  * Set background image for lock screen
  * Corrects problems with navigating photos in full-screen mode
  * Fix crash when deleting a photo
  * Fix crash when updating photo data/time
  * Fix crash due to nested tag and changing sidebar selection
  * Better detection of corrupt files while importing
  * Updated translations"

https://abf.rosalinux.ru/build_lists/2332590
https://abf.rosalinux.ru/build_lists/2332591
Comment 30 FirstLevel 2014-11-12 16:56:06 MSK
shotwell-0.20.2-4
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2332590/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2332591/x86_64/main/release/

************************ Advisory **********************
"New version 0.20.2. Some notable changes since 0.18.0:
  * Support for Rajce.net and Gallery 3 photo services added
  * Fix Flickr publishing errors due to Flickr moving to HTTPs-only
  * Set background image for lock screen
  * Corrects problems with navigating photos in full-screen mode
  * Fix crash when deleting a photo
  * Fix crash when updating photo data/time
  * Fix crash due to nested tag and changing sidebar selection
  * Better detection of corrupt files while importing
  * Updated translations"
********************************************************
QA Verified