Bug 4580 - We need python3-sip and python3-qt4
: We need python3-sip and python3-qt4
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-24 21:14 MSD by Andrey Bondrov
Modified: 2014-11-05 16:13 MSK (History)
2 users (show)

See Also:
RPM Package: python-sip, python-qt4, python3-qt4
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-10-24 21:14:26 MSD
We need to build both python-sip and python3-sip. And then both python-qt4 and python3-qt4.
Comment 1 Andrey Bondrov 2014-10-24 21:30:49 MSD
python-sip:
Advisory: "Build both python2 and python3 versions of sip"
https://abf.rosalinux.ru/build_lists/2320702
https://abf.rosalinux.ru/build_lists/2320703

python-qt4:
Advisory: "New version 4.11.2"
https://abf.rosalinux.ru/build_lists/2320704
https://abf.rosalinux.ru/build_lists/2320704

python3-qt4:
Advisory: "New package"
https://abf.rosalinux.ru/build_lists/2320709
https://abf.rosalinux.ru/build_lists/2320710

Both python-qt4 and python3-qt4 require python-sip containers. And python-qt4 is updated from 4.11 to 4.11.2 to sync version with python3-qt4.
Comment 2 Andrey Bondrov 2014-10-24 22:27:41 MSD
A package to test python3-qt4, ConvertAll:
https://abf.rosalinux.ru/build_lists/2320717
https://abf.rosalinux.ru/build_lists/2320718

Unfortunately, ABF tests failed for x86_64 build due to well known urpmi bug (too many repositories/containers).
Comment 3 Denis Silakov 2014-10-24 22:58:30 MSD
Hm, note that we already have a separate python3-sip project which is assigned to contrib (https://abf.io/import/python3-sip). We should remove it if we are going to build both python2 and python3 versions from python-sip.
Comment 4 Andrey Bondrov 2014-10-25 06:14:12 MSD
(In reply to comment #3)
> Hm, note that we already have a separate python3-sip project which is
> assigned to contrib (https://abf.io/import/python3-sip). We should remove it
> if we are going to build both python2 and python3 versions from python-sip.

Yes, that project is not really good (cannot be installed along with python-sip due to file conflicts, so we cannot have both python-qt4 and python3-qt4 etc installed), we need to drop it after this update gets approved.
Comment 5 Andrey Bondrov 2014-10-25 09:26:10 MSD
New build lists for python3-qt4 (devel package should conflist with python-qt4-devel, not python-qt4)
https://abf.rosalinux.ru/build_lists/2320839
https://abf.rosalinux.ru/build_lists/2320840
Comment 6 Andrey Bondrov 2014-10-25 10:12:05 MSD
I guess it also makes sense to build Qt5 bindings for python3.

So, the latest build lists:

python-sip:
Advisory: "Build both python2 and python3 versions of sip"
https://abf.rosalinux.ru/build_lists/2320702
https://abf.rosalinux.ru/build_lists/2320703

python-qt4:
Advisory: "New version 4.11.2"
https://abf.rosalinux.ru/build_lists/2320704
https://abf.rosalinux.ru/build_lists/2320705

python3-qt4:
Advisory: "New package"
https://abf.rosalinux.ru/build_lists/2320839
https://abf.rosalinux.ru/build_lists/2320840

python-qt5:
Advisory: "New version 5.3.2 with new modules: enginio, quickwidgets and websockets"
https://abf.rosalinux.ru/build_lists/2320841
https://abf.rosalinux.ru/build_lists/2320842

python3-qt5:
Advisory: "New package"
https://abf.rosalinux.ru/build_lists/2320843
https://abf.rosalinux.ru/build_lists/2320844