Bug 4565 - Graphics failed in UEFI mode on Sony SVE1713
: Graphics failed in UEFI mode on Sony SVE1713
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-22 15:30 MSD by Andrey Ponomarenko
Modified: 2015-06-05 00:41 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
boot hangs in UEFI mode (194.38 KB, image/jpeg)
2014-10-22 15:32 MSD, Andrey Ponomarenko
Details
kernel panic with nomodeset boot option (143.51 KB, image/jpeg)
2014-10-22 15:32 MSD, Andrey Ponomarenko
Details
boot hangs in UEFI mode (194.41 KB, image/jpeg)
2014-10-22 15:35 MSD, Andrey Ponomarenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2014-10-22 15:30:44 MSD
Description of problem:

Boot hangs at "Reached target Graphical Interface" in UEFI mode on Sony SVE1713 Notebook: http://hw.rosalinux.ru/index.php?probe=057f729e90

Kernel panic with nomodeset boot option.

Boot OK in Legacy mode: http://hw.rosalinux.ru/index.php?probe=431f2c9eec

Secure boot: off.


Version-Release number of selected component (if applicable): R4


How reproducible: always


Steps to Reproduce:
1. Insert installation media of ROSA Fresh R4 KDE 64-bit
2. Select "Start ROSA Desktop Fresh R4"
3.
Comment 1 Andrey Ponomarenko 2014-10-22 15:32:06 MSD
Created attachment 3368 [details]
boot hangs in UEFI mode
Comment 2 Andrey Ponomarenko 2014-10-22 15:32:39 MSD
Created attachment 3369 [details]
kernel panic with nomodeset boot option
Comment 3 Andrey Ponomarenko 2014-10-22 15:35:06 MSD
Created attachment 3370 [details]
boot hangs in UEFI mode
Comment 4 Andrey Ponomarenko 2014-11-18 12:15:02 MSK
Boot with VESA graphics in UEFI mode is OK: http://hw.rosalinux.ru/index.php?probe=d196f4bae2

What's wrong with free radeon driver in UEFI mode?
Comment 5 Konstantin Vlasov 2014-11-18 13:47:30 MSK
Did you try with official R4 images instead of latest builds? The build system sometimes produces strange results, it might be that e.g. initrd was generated incorrectly...
Comment 6 Andrey Ponomarenko 2014-11-18 17:09:49 MSK
The behaviour is exactly the same with official R4 image: ROSA.FRESH.KDE.R4.x86_64.iso
Comment 7 Andrey Ponomarenko 2014-12-02 00:19:56 MSK
Fixed in kernel 3.17.2: http://abf-downloads.rosalinux.ru/kernels_3_17x_personal/repository/rosa2014.1/x86_64/main/release/

Sony SVE1713 + R4 EFI + kernel 3.17.2 Ok: http://hw.rosalinux.ru/index.php?probe=1c68f596da
Comment 8 Eugene Shatokhin 2014-12-02 11:39:02 MSK
Let us keep the bug open until the problem is fixed in our officially supported kernels (or until version 3.17 or newer becomes our officially supported kernel version).
Comment 9 Andrey Ponomarenko 2015-05-22 13:25:52 MSD
For now the system should be installed in basic graphics mode. Boot it with nomodeset and xdriver=vesa kernel options (in VESA mode) and then update the kernel to 3.18: http://wiki.rosalinux.com/en/index.php/Update_kernel_to_3.18

or 4.0: http://wiki.rosalinux.com/en/index.php/Update_kernel_to_4.0