Bug 4562 - [UPDATE REQUEST] nvidia340-340.46
: [UPDATE REQUEST] nvidia340-340.46
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-21 13:30 MSD by Eugene Shatokhin
Modified: 2014-10-24 18:25 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
eugene.shatokhin: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2014-10-21 13:30:44 MSD
An update of the long-lived branch 340.x of the graphics drivers by NVidia.
Comment 1 Eugene Shatokhin 2014-10-21 13:35:23 MSD
Advisory:
The "long-lived" branch 340.x of the graphics drivers by NVidia was updated to version 340.46. 
Notable changes in this version:
* Added support for the following GPUs:
  - Quadro K420
  - Quadro K620
  - Quadro K2200
  - Quadro K4200
  - Quadro K5200
  - GeForce 830A
  - GeForce 810M
* Fixed a regression that prevented the internal stereo infrared emitter built into some 3D Vision monitors from working.
* Fixed a bug that could cause some Java-based OpenGL applications using JOGL to crash on startup on systems with Xinerama enabled.
* Fixed a bug that could prevent OpenGL Framebuffer Objects (FBOs) from being properly redrawn after a modeswitch.
* Fixed a memory leak that occurred when starting OpenGL applications.
* Fixed a bug that prevented the EDID-Like Data (ELD) of audio-capable displays from being updated when hotplugged/unplugged.
* Fixed a bug that caused Xid errors when using stereo mode 12 (HDMI 3D) on Quadro boards without an onboard stereo DIN connector.
* Fixed a video corruption issue for VDPAU decoding of VC-1 and WMV video streams utilizing range remapping on Maxwell GPUs.
* Fixed a "black window" bug in Ubuntu 14.04 when using the Xinerama and Composite extensions.
* Fixed a bug that caused the screen's contents to be shifted downward when a G-SYNC monitor is unplugged and replaced by a non-G-SYNC monitor.
* Fixed a bug that prevented G-SYNC from working when a G-SYNC monitor was unplugged and plugged back in without a modeset.
* Fixed a bug that could cause framelock status to be incorrectly reported in the nvidia-settings control panel on some multi-GPU framelock configurations.
* Improved the performance of OpenGL applications that request a large number of GPU mappings via the GL_NV_shader_buffer_load extension.
* Fixed a bug that could cause a system crash when killing applications that use NVIDIA GPUs on multiple-GPU systems with IOMMU functionality enabled.
* Fixed a bug that caused the NVIDIA kernel module to leak memory for DMA mappings on some configurations.
* Fixed an OpenGL issue that could cause glReadPixels() operations to be improperly clipped when resizing composited application windows, potentially leading to momentary X freezes.
* Fixed a bug that could prevent the GLSL compiler from correctly evaluating some expressions when compiling shaders.
* Fixed a bug that could cause nvidia-installer to crash while attempting to run nvidia-xconfig on systems where that utility is missing.
* Added option UseSysmemPixmapAccel to control the use of GPU acceleration for X drawing operations on pixmaps allocated in system memory.
* Fixed a bug that could prevent 32-bit GPU-based applications from running correctly on 64-bit systems when using GPUs with very large memory-mapped I/O regions.
* Fixed a bug that could cause poor system performance and hangs when running large compute workloads on IOMMU-enabled systems.
* Fixed a bug that could cause a system crash when two or more processes try to load the nvidia-uvm driver.

Besides that, nvidia-uvm driver is now actually built (it was not before).

Build lists:
i586:
https://abf.rosalinux.ru/build_lists/2316352
x86_64:
https://abf.rosalinux.ru/build_lists/2316353
Comment 2 Vladimir Potapov 2014-10-22 15:46:57 MSD
I see warning for installation (x64)
update-alternatives: warning: forcing reinstallation of alternative /etc/nvidia340/ld.so.conf because link group gl_conf is broken

Is it correct?
Comment 3 Eugene Shatokhin 2014-10-23 11:22:22 MSD
(In reply to comment #2)
> I see warning for installation (x64)
> update-alternatives: warning: forcing reinstallation of alternative
> /etc/nvidia340/ld.so.conf because link group gl_conf is broken
> 
> Is it correct?

Yes, it is. This might happen, for example, if the installation of the previous version finished with errors. There were problems with alternatives then, which are fixed in 340.46-1.
Comment 4 Andrey Ponomarenko 2014-10-24 15:41:17 MSD
ASUS EeePC 1015PN: OK (http://hw.rosalinux.ru/index.php?probe=34d13b8222)
Comment 5 Andrey Ponomarenko 2014-10-24 16:51:13 MSD
ASUS N53JF (Optimus): OK (http://hw.rosalinux.ru/index.php?probe=dbd7858cb1)
HP Pavilion dv8: OK (http://hw.rosalinux.ru/index.php?probe=0170ce52b7)
Comment 6 Vladimir Potapov 2014-10-24 17:54:33 MSD
nvidia340-340.46-1
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2316352/i586/non-free/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2316353/x86_64/non-free/release/
********************* Advisory *********************
The "long-lived" branch 340.x of the graphics drivers by NVidia was updated to version 340.46. 
********************** Changelog *******************
* Added support for the following GPUs:
  - Quadro K420
  - Quadro K620
  - Quadro K2200
  - Quadro K4200
  - Quadro K5200
  - GeForce 830A
  - GeForce 810M
* Fixed a regression that prevented the internal stereo infrared emitter built into some 3D Vision monitors from working.
* Fixed a bug that could cause some Java-based OpenGL applications using JOGL to crash on startup on systems with Xinerama enabled.
* Fixed a bug that could prevent OpenGL Framebuffer Objects (FBOs) from being properly redrawn after a modeswitch.
* Fixed a memory leak that occurred when starting OpenGL applications.
* Fixed a bug that prevented the EDID-Like Data (ELD) of audio-capable displays from being updated when hotplugged/unplugged.
* Fixed a bug that caused Xid errors when using stereo mode 12 (HDMI 3D) on Quadro boards without an onboard stereo DIN connector.
* Fixed a video corruption issue for VDPAU decoding of VC-1 and WMV video streams utilizing range remapping on Maxwell GPUs.
* Fixed a "black window" bug in Ubuntu 14.04 when using the Xinerama and Composite extensions.
* Fixed a bug that caused the screen's contents to be shifted downward when a G-SYNC monitor is unplugged and replaced by a non-G-SYNC monitor.
* Fixed a bug that prevented G-SYNC from working when a G-SYNC monitor was unplugged and plugged back in without a modeset.
* Fixed a bug that could cause framelock status to be incorrectly reported in the nvidia-settings control panel on some multi-GPU framelock configurations.
* Improved the performance of OpenGL applications that request a large number of GPU mappings via the GL_NV_shader_buffer_load extension.
* Fixed a bug that could cause a system crash when killing applications that use NVIDIA GPUs on multiple-GPU systems with IOMMU functionality enabled.
* Fixed a bug that caused the NVIDIA kernel module to leak memory for DMA mappings on some configurations.
* Fixed an OpenGL issue that could cause glReadPixels() operations to be improperly clipped when resizing composited application windows, potentially leading to momentary X freezes.
* Fixed a bug that could prevent the GLSL compiler from correctly evaluating some expressions when compiling shaders.
* Fixed a bug that could cause nvidia-installer to crash while attempting to run nvidia-xconfig on systems where that utility is missing.
* Added option UseSysmemPixmapAccel to control the use of GPU acceleration for X drawing operations on pixmaps allocated in system memory.
* Fixed a bug that could prevent 32-bit GPU-based applications from running correctly on 64-bit systems when using GPUs with very large memory-mapped I/O regions.
* Fixed a bug that could cause poor system performance and hangs when running large compute workloads on IOMMU-enabled systems.
* Fixed a bug that could cause a system crash when two or more processes try to load the nvidia-uvm driver.
*************************************************
QA Verified