Bug 455 - LMMS program does not respond
: LMMS program does not respond
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Marathon
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 10:35 MSD by Alexis
Modified: 2013-01-15 14:40 MSK (History)
1 user (show)

See Also:
RPM Package: lmms-0.4.12-2-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis 2012-07-01 10:35:53 MSD
Description of problem:

when I use the plugin ZynAddSubFX and pressed the button Show GUI, the program is frozen and unresponsive.

The terminal displays the following message:

[myuser@localhost ~]$ lmms
Notice: could not set realtime priority.
Couldn't create MIDI-client, neither with ALSA nor with OSS. Will use dummy-MIDI-client.
Connection established.

Stream successfully created

QtXmlWrapper::loadXMLfile(): empty data 
/usr/lib64/lmms//RemoteZynAddSubFx: error while loading shared libraries: libZynAddSubFxCore.so: cannot open shared object file: No such file or directory

I think that maybe the cause of the problem is that the path /usr/lib64/lmms//RemoteZynAddSubFx contains two bars.

I try to find the library from the terminal:

[myuser@localhost ~]$ ls /usr/lib64/lmms/
ladspa/                    liblb302.so*                 libspectrumanalyzer.so*
libaudiofileprocessor.so*  libmidiimport.so*            libstereoenhancer.so*
libbassbooster.so*         liborganic.so*               libstereomatrix.so*
libbitinvader.so*          libpapu.so*                  libtripleoscillator.so*
libflpimport.so*           libpatman.so*                libvibedstrings.so*
libkicker.so*              libpeakcontrollereffect.so*  libZynAddSubFxCore.so*
libladspabrowser.so*       libsf2player.so*             libzynaddsubfx.so*
libladspaeffect.so*        libsid.so*                   RemoteZynAddSubFx*

In the directory, find the libraries: libZynAddSubFxCore.so; libzynaddsubfx.so; RemoteZynAddSubFx.

Version-Release number of selected component (if applicable):
Name        : lmms                         Relocations: (not relocatable)
Version     : 0.4.12                            Vendor: ROSA
Release     : 2                             Build Date: dom 27 may 2012 22:15:56 CLT
Install Date: dom 01 jul 2012 01:26:33 CL   Build Host: build-client_x86_64-1.rosalab.ru
Group       : Sound                         Source RPM: lmms-0.4.12-2.src.rpm
Size        : 19727002                         License: GPLv2+
Signature   : DSA/SHA1, dom 27 may 2012 22:15:57 CLT, Key ID 862c6766aceed9fb
URL         : http://lmms.sourceforge.net/
Summary     : Linux MultiMedia Studio
Architecture: x86_64

Steps to Reproduce:
1. Open LMMS
2. Select ZynAddSubFX plugin
3. Press Show GUI button
Comment 1 Denis Silakov 2013-01-15 14:40:53 MSK
Finally fixed this one and updated lmms to 0.4.13. The updated package should be available on mirrors during the day.