Bug 454 - Broadcom wifi BCM 4312 doesn't work "out of the box"
: Broadcom wifi BCM 4312 doesn't work "out of the box"
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 17:36 MSD by stefninie
Modified: 2016-03-16 23:56 MSK (History)
8 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefninie 2012-06-29 17:36:40 MSD
Description of problem:
The wifi doesn't work after fresh installation ( wifi button doesn't light)

Wifi doesn't work with my card Broadcom BCM 4312 while F43-fwcutter-015 and dkms-broadcom-wl 5.100-82-112 be installed in "MCC".

I used the wiki http://wiki.mandriva.com/en/Installing_wireless_network_cards_using_the_b43_driver and after it worked.

Regards ( sorry for my english)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Postnikov Dmitry 2012-06-29 17:47:41 MSD
Dublicate bugs 217.
Comment 2 Dmitry Mikhirev 2012-06-29 18:07:56 MSD
(In reply to comment #1)
> Dublicate bugs 217.

Really? You understand what is #217 about? I don't...
Comment 3 Postnikov Dmitry 2012-06-29 18:31:27 MSD
We have already talked about the installation of this driver in mailing list.
You just need to install http://mirror.yandex.ru/mandriva/devel/2012/cooker/media/non-free/release/b43-firmware-install-0.1-1-mdv2012.0.noarch.rpm
Comment 4 stefninie 2012-06-29 18:43:11 MSD
(In reply to comment #3)
> We have already talked about the installation of this driver in mailing list.
> You just need to install
> http://mirror.yandex.ru/mandriva/devel/2012/cooker/media/non-free/release/
> b43-firmware-install-0.1-1-mdv2012.0.noarch.rpm

It should be in "main" not in "cooker" for working fine "out of the box" ,isnt'it ?
Comment 5 Dmitry Mikhirev 2012-07-02 11:44:09 MSD
(In reply to comment #4)
> (In reply to comment #3)
> > We have already talked about the installation of this driver in mailing list.
> > You just need to install
> > http://mirror.yandex.ru/mandriva/devel/2012/cooker/media/non-free/release/
> > b43-firmware-install-0.1-1-mdv2012.0.noarch.rpm
> 
> It should be in "main" not in "cooker" for working fine "out of the box"
> ,isnt'it ?

It should be in ROSA, not Mandriva, for working...

I don't know why was it removed. But it is safe to install Mandriva package, even from Cooker.
Comment 6 stefninie 2012-07-03 00:00:32 MSD
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > We have already talked about the installation of this driver in mailing list.
> > > You just need to install
> > > http://mirror.yandex.ru/mandriva/devel/2012/cooker/media/non-free/release/
> > > b43-firmware-install-0.1-1-mdv2012.0.noarch.rpm
> > 
> > It should be in "main" not in "cooker" for working fine "out of the box"
> > ,isnt'it ?
> 
> It should be in ROSA, not Mandriva, for working...
> 
> I don't know why was it removed. But it is safe to install Mandriva package,
> even from Cooker.

I hope it will be in Rosa 2012.1 or 2013 at least in main update.
Thanks
Comment 7 Denis Koryavov 2012-12-25 21:53:02 MSK
Unfortunately this bug still exist in ROSA Desktop.Fresh 2012. Many, many notebooks came with this WiFi adapter, and users can't use them. It is a pity.
Comment 8 Alexander Burmashev 2012-12-25 22:04:54 MSK
I recently pushed new broadcom driver, special for 3.6/3.7 kernel into the repo.
Could you please check it and tell if it works ?
Comment 9 Denis Koryavov 2012-12-25 22:36:03 MSK
Yes, what name of this driver?
Comment 10 Alexander Burmashev 2012-12-25 22:39:53 MSK
It's name is the same, but it was updated.
Checked the date - it happened yesterday )
Comment 11 Alexander Burmashev 2012-12-25 22:45:59 MSK
the same = dkms-broadcom-wl
Comment 12 Postnikov Dmitry 2012-12-25 23:49:58 MSK
Our testers checked in Marathon 2012 on two architectures. Set the system and updated. Then installed the driver from here:
http://abf.rosalinux.ru/downloads/rosa2012.1/container/broadcom-wl-857840/
http://abf.rosalinux.ru/downloads/rosa2012.1/container/broadcom-wl-857841/
Connection with Wi-Fi became more stable than the old driver, this is especially noticeable in x64 version.
Just tested on multiple switching between wifi networks. Within 24h. There are no problems. Test reports i sent yesterday.
Comment 13 Denis Koryavov 2012-12-26 00:42:03 MSK
Well, I've quickly tested this driver and it works for me fine. I write this message from Compag 615 with the ROSA Desktop.Fresh 2012 i586 installed and everything work fine now.
Comment 14 Dmitry Mikhirev 2012-12-26 12:34:49 MSK
In ROSA 2012.1 this chip should work without proprietary driver. Please test it by removing dkms-broadcom-wl and installing b43-firmware-install.
Comment 15 Aleksandr Kazantcev 2012-12-26 12:36:39 MSK
We has working driver with dkms becous inkernel realisation very bad...

I'm thin we may close this bug.
Comment 16 Dmitry Mikhirev 2012-12-26 13:35:54 MSK
(In reply to comment #15)
> We has working driver with dkms becous inkernel realisation very bad...

Why do you think so? I have seen some notebooks with Broadcom chips not working with wl module, but working with b43. Then, wl module does not allow chip to work in access point mode.

The only problem with b43 is that it requires proprietary firmware which can not be distributed and can only be extracted from proprietary driver.
Comment 17 Fedor Zevako 2014-05-04 02:03:37 MSD
So, WiFi for BCM does not work properly in ROSA Desktop.Fresh R3. Wireless tab was disabled. 

It works after the magic from mandriva:
wget http://mirror2.openwrt.org/sources/broadcom-wl-5.10.56.27.3_mipsel.tar.bz2
     tar xjf broadcom-wl-5.10.56.27.3_mipsel.tar.bz2
     su
     b43-fwcutter -w /lib/firmware/ broadcom-wl-5.10.56.27.3/driver/wl_apsta/wl_prebuilt.o
     modprobe b43
Comment 18 Eugene Shatokhin 2014-05-05 11:34:30 MSD
(In reply to comment #17)
> So, WiFi for BCM does not work properly in ROSA Desktop.Fresh R3. Wireless
> tab was disabled. 

Many things changed since the previous comments. Instead of extracting firmware from the proprietary driver directly, you can simply install b43-firmware or b43-firmware-install package and then reboot the system.

If there are any problems with WiFi after that, please let me know.

And by the way, Fedor, I am glad to hear you use our distro.
Comment 19 Postnikov Dmitry 2014-05-05 11:42:14 MSD
(In reply to comment #17)
> So, WiFi for BCM does not work properly in ROSA Desktop.Fresh R3. Wireless
> tab was disabled. 
> 
> It works after the magic from mandriva:
> wget
> http://mirror2.openwrt.org/sources/broadcom-wl-5.10.56.27.3_mipsel.tar.bz2
>      tar xjf broadcom-wl-5.10.56.27.3_mipsel.tar.bz2
>      su
>      b43-fwcutter -w /lib/firmware/
> broadcom-wl-5.10.56.27.3/driver/wl_apsta/wl_prebuilt.o
>      modprobe b43

1. This bug for Rosa Marathon. In Marathon you need install dkms-broadcom-wl.
2. If you use Fresh R3, then also install dkms-broadcom-wl and reboot