Bug 452 - [PACKAGE REQUEST] kfilebox
: [PACKAGE REQUEST] kfilebox
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
http://sourceforge.net/projects/kdrop...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 21:39 MSD by Sylvainsjc
Modified: 2012-09-14 13:55 MSD (History)
5 users (show)

See Also:
RPM Package: kfilebox
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
on tray link click (122.48 KB, image/png)
2012-08-30 18:31 MSD, Vladimir Potapov
Details
work for me (223.41 KB, image/png)
2012-08-30 19:32 MSD, symbianflo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2012-06-28 21:39:19 MSD
Description of problem: Dropbox package

Hi,

Most users use dropbox for example to synchronize folders between Windows PC at work and Linux PC or tablet or smartphone at home.

When I was on Mandriva 2011, I was able to find and install kfilebox package in the repositories.

Can you please make available kfilebox package in ROSA LTS Repos ?

Thanks
Comment 1 Alexander Burmashev 2012-06-28 22:14:59 MSD
Check this one:
x86_64
http://abf.rosalinux.ru/downloads/andrewlukoshko_personal/container/kfilebox-126780/RPMS/
i586
http://abf.rosalinux.ru/downloads/andrewlukoshko_personal/container/kfilebox-126779/RPMS/

If they are ok, i will rebuild it to the contrib or main repo.
Comment 2 Sylvainsjc 2012-06-29 08:46:06 MSD
Yes it works, great thanks

is there a way to make this package more official for Rosa users ?
Comment 3 Alexander Khryukin 2012-07-05 15:05:30 MSD
(In reply to comment #2)
> Yes it works, great thanks
> 
> is there a way to make this package more official for Rosa users ?
What you mean "more official"?
Comment 4 Alexander Burmashev 2012-07-05 15:07:26 MSD
I will rebuild it to the public repo.
Comment 5 Sylvainsjc 2012-07-05 15:34:18 MSD
(In reply to comment #3)
> > is there a way to make this package more official for Rosa users ?
> What you mean "more official"?

I meant a package that users can find directly in the software manager
Comment 6 Sylvainsjc 2012-07-05 15:34:45 MSD
(In reply to comment #4)
> I will rebuild it to the public repo.

Thanks
Comment 7 Sylvainsjc 2012-08-18 12:51:07 MSD
any chance to have this package in public repo ?

the link given above by Alex Burmashev does not work anymore
Comment 8 Denis Silakov 2012-08-22 12:34:56 MSD
The package has been pushed to non-free/updates, should be available on mirrors soon.
Comment 9 Denis Silakov 2012-08-22 12:55:49 MSD
Advisory:
New package with KDE front-end for Dropbox.

Buildlists:
https://abf.rosalinux.ru/build_lists/687810
https://abf.rosalinux.ru/build_lists/687811
Comment 10 Vladimir Potapov 2012-08-24 15:57:58 MSD
"Запустить GTK-версию установщика" - не работает (i586 Free RP1)
"Run GTK-installer" is not work
Comment 11 Vladimir Potapov 2012-08-24 16:12:01 MSD
The package is uninstalled incorrectly - service dropbox (.dropbox-dist folder) is not removed.
Comment 12 symbianflo 2012-08-25 11:17:18 MSD
I have service menu entry for dropbox:
https://abf.rosalinux.ru/symbianflo/dropbox-servicemenu.git

if it helps and you go for a import please let me know .

Thank you
Comment 13 Denis Silakov 2012-08-30 11:40:57 MSD
Advisory:
New package with KDE front-end for Dropbox.

Buildlists:
https://abf.rosalinux.ru/build_lists/699913
https://abf.rosalinux.ru/build_lists/699914
Comment 14 Denis Silakov 2012-08-30 11:45:38 MSD
The issue with installer came from dropbox daemon, should be fixed now. And .dropbox-dist should be removed, as well.

2 symbianflo: I've tried dropbox-servicemenu, but Dolphin says "Could not find the program '`kde4-config'". But I suggest to discuss dropbox-servicemenu in some other place (e.g., rosa-devel ML) not to pollute this bug.
Comment 15 Sylvainsjc 2012-08-30 12:12:53 MSD
(In reply to comment #14)
> 2 symbianflo: I've tried dropbox-servicemenu, but Dolphin says "Could not
> find the program '`kde4-config'". But I suggest to discuss
> dropbox-servicemenu in some other place (e.g., rosa-devel ML) not to pollute
> this bug.

To avoid this message about 'kde4-config', you must install sqlite3 package (or sqlite3-tools)
Comment 16 symbianflo 2012-08-30 14:37:45 MSD
(In reply to comment #15)
> (In reply to comment #14)
> > 2 symbianflo: I've tried dropbox-servicemenu, but Dolphin says "Could not
> > find the program '`kde4-config'". But I suggest to discuss
> > dropbox-servicemenu in some other place (e.g., rosa-devel ML) not to pollute
> > this bug.
> 
> To avoid this message about 'kde4-config', you must install sqlite3 package
> (or sqlite3-tools)

yeah , I don't use dropbox and looks like my testers miss it ... beside sqlite3 tools ,also klipper is needed.
but let's closed here  and stick with kfilebox 
thx folx
Comment 17 Vladimir Potapov 2012-08-30 18:31:07 MSD
Created attachment 522 [details]
on tray link click
Comment 18 symbianflo 2012-08-30 19:32:46 MSD
Created attachment 523 [details]
work for me
Comment 19 symbianflo 2012-08-30 19:39:22 MSD
Mabe you should ad a machine to your dropbox account , first.
Have you try to run :
~/.dropbox-dist/dropboxd
        
 to add the pc to your dropbox account?

More infos:
https://www.dropbox.com/install?os=lnx
Comment 20 Sylvainsjc 2012-08-30 21:29:42 MSD
(In reply to comment #13)
> Advisory:
> New package with KDE front-end for Dropbox.
> 
> Buildlists:
> https://abf.rosalinux.ru/build_lists/699913
> https://abf.rosalinux.ru/build_lists/699914

Great job. I just try it this evening, it works perfect.
Comment 21 Sylvainsjc 2012-08-30 22:38:47 MSD
2 things :

1) There is still a systray notification with a wrong link at the end of the automatic daemon download

2) There is a kfilebox-0.4.9 version 1 in software manager but it isn't the same package that the one given in those links ?

https://abf.rosalinux.ru/build_lists/699913
https://abf.rosalinux.ru/build_lists/699914

However the versions are identical
Comment 22 Denis Silakov 2012-08-30 22:49:23 MSD
(In reply to comment #21)
> 2 things :
> 
> 1) There is still a systray notification with a wrong link at the end of the
> automatic daemon download
> 
> 2) There is a kfilebox-0.4.9 version 1 in software manager but it isn't the
> same package that the one given in those links ?
> 
> https://abf.rosalinux.ru/build_lists/699913
> https://abf.rosalinux.ru/build_lists/699914
> 
> However the versions are identical

Hm, from which repo does that package come? What is the output of `urpmq --sources kfilebox` in console?
Comment 23 Sylvainsjc 2012-08-30 23:40:23 MSD
hum now I'm not sure but I've tried 2 times to use kfilebox installed from the repos and I wasn't able to see the Gui front-end after selecting "Run Gtk based installer" 

Whereas the use of kfilebox package from the link given above has not caused any problems?

here the result of `urpmq --sources kfilebox`
[root@rosa2012lts ~]# urpmq --sources kfilebox
http://mirrors.coreix.net/rosa/rosa2012lts/x86_64/media/non-free/updates/kfilebox-0.4.9-1-rosa.lts2012.0.x86_64.rpm
[root@rosa2012lts ~]# 

If you say that it is the same package, it's ok for me
Comment 24 Denis Silakov 2012-08-30 23:46:37 MSD
(In reply to comment #23)
> hum now I'm not sure but I've tried 2 times to use kfilebox installed from
> the repos and I wasn't able to see the Gui front-end after selecting "Run
> Gtk based installer" 
> 
> Whereas the use of kfilebox package from the link given above has not caused
> any problems?
> 
> here the result of `urpmq --sources kfilebox`
> [root@rosa2012lts ~]# urpmq --sources kfilebox
> http://mirrors.coreix.net/rosa/rosa2012lts/x86_64/media/non-free/updates/
> kfilebox-0.4.9-1-rosa.lts2012.0.x86_64.rpm
> [root@rosa2012lts ~]# 
> 
> If you say that it is the same package, it's ok for me

No, it's not the same package. Not sure why that package was published to the repos, probably due to build system issue - I remember we've had one that led to publishing of several unconfirmed packages.

The package in the buildlists from this bug is slightly different - I've added a patch that fixes Dropbox GUI launcher issue.

I'll increment the version and rebuild, but first I want to take a look at the issues reported by Vladimir...
Comment 25 symbianflo 2012-08-31 01:27:54 MSD
(In reply to comment #24)
> (In reply to comment #23)
> > hum now I'm not sure but I've tried 2 times to use kfilebox installed from
> > the repos and I wasn't able to see the Gui front-end after selecting "Run
> > Gtk based installer" 
> > 
> > Whereas the use of kfilebox package from the link given above has not caused
> > any problems?
> > 
> > here the result of `urpmq --sources kfilebox`
> > [root@rosa2012lts ~]# urpmq --sources kfilebox
> > http://mirrors.coreix.net/rosa/rosa2012lts/x86_64/media/non-free/updates/
> > kfilebox-0.4.9-1-rosa.lts2012.0.x86_64.rpm
> > [root@rosa2012lts ~]# 
> > 
I've install this:
┌─[ symbianflo @ symbianflo ] - [ Mandrivausers.ro ] 
└─[ MRB:aint_no_shit $]>urpmq --sources kfilebox
http://mirrors.coreix.net/rosa/rosa2012lts/x86_64/media/non-free/updates/kfilebox-0.4.9-1-rosa.lts2012.0.x86_64.rpm

and works as it should.

> > 
> > If you say that it is the same package, it's ok for me
> 
> No, it's not the same package. Not sure why that package was published to
> the repos, probably due to build system issue - I remember we've had one
> that led to publishing of several unconfirmed packages.
> 
> The package in the buildlists from this bug is slightly different - I've
> added a patch that fixes Dropbox GUI launcher issue.
> > If you say that it is the same package, it's ok for me
> 
> No, it's not the same package. Not sure why that package was published to
> the repos, probably due to build system issue - I remember we've had one
> that led to publishing of several unconfirmed packages.
> 
> The package in the buildlists from this bug is slightly different - I've
> added a patch that fixes Dropbox GUI launcher issue.
> 
> I'll increment the version and rebuild, but first I want to take a look at
> the issues reported by Vladimir...

about ~/.dropbox-dist, yes , uninstall package won't remove it...
because at the firs launch kfilebox download and unpack the daemon in $HOME ,
so the daemon will be installed for every single  user separately ...
it's a bit difficult  this task, if you try to delete the .dropbox-dist from all the $HOMEs , because the daemon won't install globally on the system...
Comment 26 Denis Silakov 2012-08-31 14:52:19 MSD
Well, it's nice that the package from coreix.net works for some of you. The rebuilt package should not introduce any changes - from functionality point of view it is exactly the same, just fixes one issue preventing GUI installer to be launch in ROSA (at least in some instances).

I've rebuilt the package with incremented version, here are the new build lists:

https://abf.rosalinux.ru/build_lists/700662
https://abf.rosalinux.ru/build_lists/700663

I should say that I can't reproduce error with URL mentioned by Vladimir... I have installed kfilebox, successfully created a new account using GUI installer and link machine to it. Then I installed kfilebox on another machine and successfully linked it to my account.
Comment 27 symbianflo 2012-08-31 15:24:08 MSD
(In reply to comment #26)
> Well, it's nice that the package from coreix.net works for some of you. The
> rebuilt package should not introduce any changes - from functionality point
> of view it is exactly the same, just fixes one issue preventing GUI
> installer to be launch in ROSA (at least in some instances).
I think this is irrelevant , I've install it from your _personal but since it had the same %name-%version-%rel, urpmq took the references from coreix,( in my case is the fastest mirror) :D

> I've rebuilt the package with incremented version, here are the new build
> lists:
> 
> https://abf.rosalinux.ru/build_lists/700662
> https://abf.rosalinux.ru/build_lists/700663
> 
> I should say that I can't reproduce error with URL mentioned by Vladimir...
> I have installed kfilebox, successfully created a new account using GUI
> installer and link machine to it. Then I installed kfilebox on another
> machine and successfully linked it to my account.

Just a beauty , this package, 
-urpme does remove ~/.dropbox-dist , 
-config all from the GUI , 
(no need to launch the daemon from shell), 
-perfect I would say

PS:
gotcha :D
+    sc.execute("rm -f "+QDir::homePath()+"/.dropbox-dist/libz.so.1");

Thx
Comment 28 Sylvainsjc 2012-08-31 15:42:19 MSD
For all tests I've made with package from coreix.net in a Virtual Machine, I've never seen the gui wizard installer after selecting "Run Gtk based installer". So, this package has issues

For the URL error mentioned by Vladimir, I've also notice this error every time I've clicked on the link given in the systray notification
Comment 29 Denis Silakov 2012-08-31 20:32:53 MSD
Advisory:
New package with KDE front-end for Dropbox.

Buildlists:
https://abf.rosalinux.ru/build_lists/700662
https://abf.rosalinux.ru/build_lists/700663
Comment 30 Denis Silakov 2012-08-31 20:33:17 MSD
I'd suggest to publish the package and file a separate bug for incorrect URL...
Comment 31 Vladimir Potapov 2012-09-01 15:01:54 MSD
I spent a great test of the package. For publication required minimal changes:
1) Add to requirements qt4-database-plugin-sqlite
2) Add to uninstall delete the folder ".dropbox"
Comment 32 Denis Silakov 2012-09-01 21:25:19 MSD
(In reply to comment #31)
> I spent a great test of the package. For publication required minimal
> changes:
> 1) Add to requirements qt4-database-plugin-sqlite

Indeed, this is an issue.

> 2) Add to uninstall delete the folder ".dropbox"

Well, I can add such behavior, but note that this is not typical. The common practice is to leave '.foo' folders in home directories when uninstalling 'foo' package. I agree that in most cases there is no sense in this and such folders only pollute the system, but I guess currently most ROSA packages (as well as packages in other distributions) do not delete such folders during uninstallation.
Comment 33 Vladimir Potapov 2012-09-02 15:24:00 MSD
(In reply to comment #32)

> > 2) Add to uninstall delete the folder ".dropbox"
> 
> Well, I can add such behavior, but note that this is not typical. The common
> practice is to leave '.foo' folders in home directories when uninstalling
> 'foo' package. I agree that in most cases there is no sense in this and such
> folders only pollute the system, but I guess currently most ROSA packages
> (as well as packages in other distributions) do not delete such folders
> during uninstallation.
OK, I checked again - the settings are saved when reinstalling correctly, the folder can not be deleted. Only need to add depending the plugin.
Comment 34 Denis Silakov 2012-09-03 09:51:37 MSD
Advisory:
New package with KDE front-end for Dropbox.

Buildlists:
https://abf.rosalinux.ru/build_lists/701188
https://abf.rosalinux.ru/build_lists/701189
Comment 35 Vladimir Potapov 2012-09-03 11:46:39 MSD
kfilebox-0.4.9-2-rosa.lts2012.0
**************** Advisory *****************
New package with KDE front-end for Dropbox.
******************************************
QA Verified