Bug 4507 - cheese стартует с ошибкой
: cheese стартует с ошибкой
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: 2014 Fresh R4
Assigned To: Arkady L. Shane
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-12 11:07 MSD by awl
Modified: 2014-10-15 11:51 MSD (History)
3 users (show)

See Also:
RPM Package: cheese-3.12.2-2-rosa2014.1.x86_64
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
ss (15.98 KB, image/png)
2014-10-12 17:13 MSD, Vladimir Potapov
Details
cheese-error.png (157.79 KB, image/png)
2014-10-14 13:26 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description awl 2014-10-12 11:07:19 MSD
Description of problem:
При попытке запуска в окне программы видео отсутствует, элементы управления не активны.

$ cheese
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(cheese:3682): GStreamer-CRITICAL **: gst_bin_add: assertion 'GST_IS_ELEMENT (element)' failed

(cheese:3682): GStreamer-CRITICAL **: gst_bin_add: assertion 'GST_IS_ELEMENT (element)' failed

(cheese:3682): GStreamer-CRITICAL **: gst_bin_add: assertion 'GST_IS_ELEMENT (element)' failed

(cheese:3682): GStreamer-CRITICAL **: gst_bin_add: assertion 'GST_IS_ELEMENT (element)' failed

(cheese:3682): GStreamer-CRITICAL **: gst_bin_add: assertion 'GST_IS_ELEMENT (element)' failed

(cheese:3682): GStreamer-CRITICAL **: gst_bin_add: assertion 'GST_IS_ELEMENT (element)' failed

(cheese:3682): GStreamer-CRITICAL **: gst_bin_add: assertion 'GST_IS_ELEMENT (element)' failed
** Message: cheese-application.vala:215: Error during camera setup: Один или более компонентов GStreamer отсутствуют:cluttervideosink.

После дополнительной установки пакета gstreamer1.0-gstclutter-2.0.12-2-rosa2014.1.x86_64 программа стартует без ошибок, всё работает нормально.
Пожалуйста исправьте.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Vladimir Potapov 2014-10-12 17:13:16 MSD
Created attachment 3313 [details]
ss
Comment 2 Andrey Bondrov 2014-10-13 11:18:43 MSD
Advisory: "Fix video output"

https://abf.rosalinux.ru/build_lists/2298335
https://abf.rosalinux.ru/build_lists/2298336
Comment 3 FirstLevel 2014-10-14 13:26:07 MSD
I have tested updated package of cheese. It realy requires neccessary packages.
But I can't see output of my camera in cheese, I see cheese-error.png instead.
I see my camera output by execution of 
ffplay -f video4linux2 /dev/video0
Is it another error of cheese?
Comment 4 FirstLevel 2014-10-14 13:26:34 MSD
Created attachment 3319 [details]
cheese-error.png
Comment 5 FirstLevel 2014-10-14 14:17:24 MSD
(In reply to comment #3)
> I have tested updated package of cheese. It realy requires neccessary
> packages.
> But I can't see output of my camera in cheese, I see cheese-error.png
> instead.
> I see my camera output by execution of 
> ffplay -f video4linux2 /dev/video0
> Is it another error of cheese?

I can use webcam in skype too. Only cheese generate an error
Comment 6 Andrey Bondrov 2014-10-14 17:36:51 MSD
Assigned to Arkady because Cheese is a Gnome package.
Comment 7 Vladimir Potapov 2014-10-15 11:19:51 MSD
(In reply to comment #3)
> I have tested updated package of cheese. It realy requires neccessary
> packages.
> But I can't see output of my camera in cheese, I see cheese-error.png
> instead.
> I see my camera output by execution of 
> ffplay -f video4linux2 /dev/video0
> Is it another error of cheese?

Yes, it is another error. Updated package work correct on my webcam
Comment 8 Vladimir Potapov 2014-10-15 11:21:47 MSD
cheese-3.12.2-3
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2298335/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2298336/x86_64/main/release/
******************* Advisory ***************
Fix video output, gstreamer1.0-gstclutter added
********************************************
QA Verified