Bug 4500 - Просмотр видео в KLook не работает
: Просмотр видео в KLook не работает
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: 2014 Fresh R4
Assigned To: Andrey Bondrov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-10 16:40 MSD by Vladimir Potapov
Modified: 2014-10-14 13:46 MSD (History)
2 users (show)

See Also:
RPM Package: KLook
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2014-10-10 16:40:52 MSD
Просмотр видео в KLook не работает - черный квадрат.
Comment 1 Vladimir Potapov 2014-10-10 16:45:33 MSD
http://forum.rosalab.ru/viewtopic.php?f=53&t=4490
Comment 2 Andrey Bondrov 2014-10-13 10:44:01 MSD
Хорошо бы мне вывод "rpm -qa" дать. Скорее всего не хватает какого-то плагина GStreamer.
Comment 3 Vladimir Potapov 2014-10-13 10:50:27 MSD
rpm -qa |gstreamer
bash: gstreamer: команда не найдена
[root@DNS-Fresh-x64-R4 parameters]# rpm -qa |grep gstreamer
lib64gstreamer0.10_0-0.10.36-6-rosa2014.1.x86_64
gstreamer0.10-tools-0.10.36-6-rosa2014.1.x86_64
lib64gstreamer-plugins-base0.10-0.10.36-7-rosa2014.1.x86_64
gstreamer0.10-vp8-0.10.23-5plf-plf2014.1.x86_64
gstreamer0.10-mpeg-0.10.19-4plf-plf2014.1.x86_64
gstreamer0.10-plugins-base-0.10.36-7-rosa2014.1.x86_64
lib64gstreamer1.0_0-1.2.4-2-rosa2014.1.x86_64
lib64gstreamer-plugins-base1.0_0-1.2.4-4-rosa2014.1.x86_64
gstreamer1.0-tools-1.2.4-2-rosa2014.1.x86_64
gstreamer1.0-plugins-base-1.2.4-4-rosa2014.1.x86_64
gstreamer1.0-pulse-1.2.4-5-rosa2014.1.x86_64
gstreamer1.0-plugins-good-1.2.4-5-rosa2014.1.x86_64
phonon-gstreamer-4.8.0-1-rosa2014.1.x86_64
gstreamer0.10-plugins-ugly-0.10.19-4plf-plf2014.1.x86_64
gstreamer0.10-flac-0.10.31-9-rosa2014.1.x86_64
gstreamer0.10-plugins-good-0.10.31-9-rosa2014.1.x86_64
gstreamer0.10-decoders-audio-1-9-rosa2014.1.noarch
gstreamer0.10-decoders-1-9-rosa2014.1.noarch
gstreamer0.10-cdparanoia-0.10.36-7-rosa2014.1.x86_64
gstreamer0.10-soup-0.10.31-9-rosa2014.1.x86_64
gstreamer0.10-python-0.10.22-6-rosa2014.1.x86_64
gstreamer0.10-ffmpeg-0.10.13-6-rosa2014.1.x86_64
gstreamer0.10-pulse-0.10.31-9-rosa2014.1.x86_64
lib64gstreamer1.0-devel-1.2.4-2-rosa2014.1.x86_64
gstreamer1.0-vp8-1.2.4-5-rosa2014.1.x86_64
gstreamer1.0-plugins-bad-1.2.4-1plf-plf2014.1.x86_64
gstreamer1.0-gstclutter-2.0.12-2-rosa2014.1.x86_64
qt-gstreamer-1.2.0-1-rosa2014.1.x86_64
Comment 4 Andrey Bondrov 2014-10-13 11:20:55 MSD
А если установить gstreamer1.0-plugins-ugly? Только для начала отключить репозиторий Restricted, чтобы сперва проверить версию из Main. Если не поможет, то поставить версию из Restricted. И хорошо бы поскорее это сделать, т.к. я сейчас немного переделываю пакет gstreamer1.0-plugins-ugly, хорошо бы успеть текущую версию затестить с klook.
Comment 5 Vladimir Potapov 2014-10-13 14:16:10 MSD
(In reply to comment #4)
> А если установить gstreamer1.0-plugins-ugly? Только для начала отключить
> репозиторий Restricted, чтобы сперва проверить версию из Main. Если не
> поможет, то поставить версию из Restricted. И хорошо бы поскорее это
> сделать, т.к. я сейчас немного переделываю пакет gstreamer1.0-plugins-ugly,
> хорошо бы успеть текущую версию затестить с klook.

Не работает.
Comment 6 Andrey Bondrov 2014-10-13 15:06:07 MSD
Тогда стоит по очереди ставить пакеты из списка:

gstreamer1.0-a52dec
gstreamer1.0-faac
gstreamer1.0-faad
gstreamer1.0-flac
gstreamer1.0-lame
gstreamer1.0-libass
gstreamer1.0-libav
gstreamer1.0-mpeg
gstreamer1.0-mpeg2enc
gstreamer1.0-plugins-ugly
gstreamer1.0-soundtouch
gstreamer1.0-soup
gstreamer1.0-speex
gstreamer1.0-twolame
gstreamer1.0-wavpack
gstreamer1.0-x264

И потом сказать, после какого заработало. Т.к. у меня стоят эти пакеты (кроме тех, которые были в приложенном списке), и klook всё показывает, на чём проверял.
Comment 7 Vladimir Potapov 2014-10-13 16:33:15 MSD
gstreamer1.0-libav 

Но после его установки видео в предпросмотре dolphin начинает двоиться (и по-прежнему не играет)
Comment 8 Andrey Bondrov 2014-10-13 17:08:22 MSD
А если дальше ставить пакеты по списку?
Comment 9 Vladimir Potapov 2014-10-13 17:10:10 MSD
Попробовал. Дальше уже ничего не меняется.
Comment 10 Andrey Bondrov 2014-10-13 17:24:17 MSD
Ну тогда я не знаю, в чём дело, может в каких-то конкретных видеофайлах, т.к. у меня klook проигрывает видео, а не проигрывать он что-то может из-за отсутствия нужных модулей gstreamer1.0...
Comment 11 Vladimir Potapov 2014-10-13 17:45:37 MSD
Андрей, я ж сказал что gstreamer1.0-libav 
решает проблему KLook но заглюкивает Dolphin
Comment 12 Andrey Bondrov 2014-10-13 18:46:52 MSD
(In reply to comment #11)
> Андрей, я ж сказал что gstreamer1.0-libav 
> решает проблему KLook но заглюкивает Dolphin

Тогда лучше другой баг завести, т.к. это разные проблемы.

Advisory: "Make sure Phonon-GStreamer requires more plugins to fix issues with klook not playing videos"

https://abf.rosalinux.ru/build_lists/2299672
https://abf.rosalinux.ru/build_lists/2299673
Comment 13 FirstLevel 2014-10-14 11:22:30 MSD
(In reply to comment #12)
> (In reply to comment #11)
> > Андрей, я ж сказал что gstreamer1.0-libav 
> > решает проблему KLook но заглюкивает Dolphin
> 
> Тогда лучше другой баг завести, т.к. это разные проблемы.
> 
> Advisory: "Make sure Phonon-GStreamer requires more plugins to fix issues
> with klook not playing videos"
> 
> https://abf.rosalinux.ru/build_lists/2299672
> https://abf.rosalinux.ru/build_lists/2299673

I have tested on i586.
All works fine. New package has correct dependencies

Для удовлетворения зависимостей будут установлены следующие пакеты:
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа 
(источник «main»)
 gstreamer1.0-libav             1.2.4        2             rosa  2014.1 i586 
 gstreamer1.0-soup              1.2.4        5             rosa  2014.1 i586 
 libsidplay1                    1.36.60      6             rosa  2014.1 i586 
(источник «restricted updates»)
 gstreamer1.0-a52dec            1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-amrnb             1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-amrwbdec          1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-cdio              1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-lame              1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-mpeg              1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-plugins-ugly      1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-sid               1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-twolame           1.2.4        5plf          plf   2014.1 i586 
 gstreamer1.0-x264              1.2.4        5plf          plf   2014.1 i586 
(источник «klooktest»)
 phonon-gstreamer               4.8.0        2             rosa  2014.1 i586 
Будет использовано 8.7МБ дополнительного дискового пространства.
Будет загружено 3.2МБ пакетов.
Установить 14 пакетов? (Y/n)
Comment 14 FirstLevel 2014-10-14 11:44:18 MSD
(In reply to comment #12)
> (In reply to comment #11)
> > Андрей, я ж сказал что gstreamer1.0-libav 
> > решает проблему KLook но заглюкивает Dolphin
> 
> Тогда лучше другой баг завести, т.к. это разные проблемы.
> 
> Advisory: "Make sure Phonon-GStreamer requires more plugins to fix issues
> with klook not playing videos"
> 
> https://abf.rosalinux.ru/build_lists/2299672
> https://abf.rosalinux.ru/build_lists/2299673

For 64bit all works fine too
Для удовлетворения зависимостей будут установлены следующие пакеты:
 Пакет                            Версия       Релиз         Dist  DEpoch Платформа 
(источник «main»)
 glib-gettextize                  2.40.0       4             rosa  2014.1 x86_64 
 gstreamer1.0-libav               1.2.4        2             rosa  2014.1 x86_64 
 gstreamer1.0-soup                1.2.4        5             rosa  2014.1 x86_64 
 lib64ffi-devel                   3.1          5             rosa  2014.1 x86_64 
 lib64glib2.0-devel               2.40.0       4             rosa  2014.1 x86_64 
 lib64gstreamer1.0-devel          1.2.4        2             rosa  2014.1 x86_64 
 lib64mimic0                      1.0.4        8             rosa  2014.1 x86_64 
 lib64pcre-devel                  8.35         2             rosa  2014.1 x86_64 
 lib64pcrecpp0                    8.35         2             rosa  2014.1 x86_64 
 lib64pcreposix0                  8.35         2             rosa  2014.1 x86_64 
 lib64sidplay1                    1.36.60      6             rosa  2014.1 x86_64 
 lib64stdc++-devel                4.9.2_2014.> 2             rosa  2014.1 x86_64 
 libgcc1                          4.9.2_2014.> 2             rosa  2014.1 x86_64 
 libstdc++6                       4.9.2_2014.> 2             rosa  2014.1 x86_64 
(источник «restricted»)
 gstreamer1.0-plugins-bad         1.2.4        1plf          plf   2014.1 x86_64 
 lib64gstbasevideo1.0_0           1.2.4        1plf          plf   2014.1 x86_64 
 lib64gstmpegts1.0_0-devel        1.2.4        1plf          plf   2014.1 x86_64 
 lib64gstphotography1.0_0         1.2.4        1plf          plf   2014.1 x86_64 
 lib64gsturidownloader1.0_0-devel 1.2.4        1plf          plf   2014.1 x86_64 
(источник «restricted updates»)
 gstreamer1.0-a52dec              1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-amrnb               1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-amrwbdec            1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-cdio                1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-lame                1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-mpeg                1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-plugins-ugly        1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-sid                 1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-twolame             1.2.4        5plf          plf   2014.1 x86_64 
 gstreamer1.0-x264                1.2.4        5plf          plf   2014.1 x86_64 
(источник «klooktes»)
 phonon-gstreamer                 4.8.0        2             rosa  2014.1 x86_64 
Будет использовано 69МБ дополнительного дискового пространства.
Будет загружено 10МБ пакетов.
Установить 30 пакетов? (Y/n)