Bug 4494 - Problem with accented characters with gtkfilechooser
: Problem with accented characters with gtkfilechooser
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: ---
Assigned To: Arkady L. Shane
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-09 21:16 MSD by Sylvainsjc
Modified: 2016-05-30 18:40 MSD (History)
3 users (show)

See Also:
RPM Package: simple-scan-3.17.4-3-rosa2014.1
ISO-related:
Bad POT generating:
Upstream:


Attachments
Screenshot Simple scan (96.03 KB, image/jpeg)
2014-10-09 21:16 MSD, Sylvainsjc
Details
ошибка при сохраненнии файла (9.09 KB, image/png)
2016-01-13 11:52 MSK, Sergey Zhemoitel
Details
список установленных пакетов (139.59 KB, text/plain)
2016-01-13 13:24 MSK, Sergey Zhemoitel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2014-10-09 21:16:25 MSD
Created attachment 3306 [details]
Screenshot Simple scan

Hello,

There is a problem in last R4 with "simple scan" that did not happen with the R3
When I scan a document and then ask to record it, there is an error due to the presence of accented characters in the automatic title.

See capture file in attachment

ROSA R3 with simple-scan-3.4.2-1-rosa2012.1 : No problem
ROSA R4 with simple-scan-3.12.0-2-rosa2014.1 : Problem !!!
Comment 1 Denis Silakov 2014-10-10 08:55:35 MSD
Do you see such an error in other Gnome-related programs (e.g., gedit)?

And on the other side, do non-Gnome programs like xsane work fine?
Comment 2 Sylvainsjc 2014-10-10 09:37:31 MSD
No problem with gedit : when I wants to record the default proposed name is "Document 1 non enregistré" and there is no warning
Comment 3 Sylvainsjc 2014-10-10 09:38:43 MSD
xsane also works fine
Comment 4 Stanislav Fomin 2015-01-14 20:00:16 MSK
Same problem with Cyrillic filenames.

Need research may be patches exists?
May be stable 3.14.0 OK, or 3.15.3
Comment 5 Stanislav Fomin 2015-01-14 20:00:49 MSK
*** Bug 4610 has been marked as a duplicate of this bug. ***
Comment 6 Sylvainsjc 2015-08-09 16:09:08 MSD
Hi,
Problem is still alive in ROSA R6
Is it possible to try latest release of simple-scan ?
In ROSA R6 : 3.12.0
Latest Release : 3.17.x
https://launchpad.net/simple-scan
Comment 7 Sylvainsjc 2015-08-10 13:28:16 MSD
Found and tested recent release 3.17 of SimpleScan ==> same problem 
The error message seems to come from Gtk File Chooser, not from SimpleScan himself.
Comment 8 Denis Silakov 2016-01-12 19:38:51 MSK
Could you try simple-scan-3.16 which is currently available in repos? It looks like it is free of this problem.
Comment 9 Sylvainsjc 2016-01-12 22:38:41 MSK
(In reply to comment #8)
> Could you try simple-scan-3.16 which is currently available in repos? It
> looks like it is free of this problem.

Hello,
Yes it's ok now with last release of simple-scan
Thanks a lot :)
Comment 10 Sergey Zhemoitel 2016-01-13 02:25:28 MSK
rpm -qa | grep simple-scan
simple-scan-3.16.2-1-rosa2014.1.x86_64

все по старому, не работает.
Comment 11 Sergey Zhemoitel 2016-01-13 11:51:57 MSK
Французские имена файлов пишутся в латинице, потому возможно при сохранении файлов нет проблем. Кириллица, все-таки не латиница, потому при вызове "сохранить" появляется сообщение об ошибке (см. картинку). При этом при внесении изменении в название файла, т.е. при удалении хотя бы одного символа в названии вылетает такая же ошибка.
Comment 12 Sergey Zhemoitel 2016-01-13 11:52:44 MSK
Created attachment 4346 [details]
ошибка при сохраненнии файла
Comment 13 Denis Silakov 2016-01-13 12:50:27 MSK
Проблема скорее всего была не в латинице/кирилие, а в ascii/non-ascci символах. 
Во французском языке тоже есть не-ascii символы типа "é", как в примере от Sylvainsjc.

Файл с названием "Отсканированный документ" у меня simple-scan в KDE успешно сохраняет. Приложите, пожалуйста, вывод "rpm -qa", посмотрим - может, пакетов не хватает.
Comment 14 Sergey Zhemoitel 2016-01-13 13:24:42 MSK
Created attachment 4347 [details]
список установленных пакетов
Comment 15 Sergey Zhemoitel 2016-02-23 15:18:18 MSK
simple-scan-3.17.4-3-rosa2014.1.x86_64 

проблема немного изменилась. Теперь по умолчанию название файла не в кириллице, и если так же в латинице файл сохранять проблем нет, однако, стоит только попробовать дать название файлу в кириллице как ошибка снова появляется, при этом при вводе каждого символа в названии файла
Comment 16 Sylvainsjc 2016-05-27 17:48:19 MSD
Please use english for good understanding of all of us
Problem seems to be solved by renaming (ou deleting) this file :
~/.config/gtk-2.0/gtkfilechooser.ini
Comment 17 Denis Silakov 2016-05-28 15:03:50 MSD
Thanks for the investigation. Indeed, config file in user's home can be a culprit. Unfortunately, there is no reliable way to fix files in /home by package updates, so it unlikely that we can do anything with this issue. Only hope that if somebody meets the same problem he will find this bug and proposed solution.
Comment 18 Denis Silakov 2016-05-30 18:40:23 MSD
So finally we would call this one as "fixed" but it is likely that in some cases you should remove ~/.config/gtk-2.0/gtkfilechooser.ini file.