Bug 4492 - [UPDATE REQUEST] systemd-208-37
: [UPDATE REQUEST] systemd-208-37
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-09 16:45 MSD by Eugene Shatokhin
Modified: 2014-10-16 09:07 MSD (History)
2 users (show)

See Also:
RPM Package: systemd-208-37
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2014-10-09 16:45:30 MSD
Systemd was updated for 2014.1: a patch was added that makes 'reboot' (as well as 'systemctl reboot') perform sync before rebooting. 

It is unclear, whether all file systems are properly unmounted or at least sync'ed when the system reboots. I suspect that, in some cases, they are not, and this is the root cause of the bugs like #4161.

Anyway, it won't hurt if 'reboot' calls sync explicitly.
Comment 1 Eugene Shatokhin 2014-10-09 16:58:45 MSD
Advisory:
Systemd was patched to make sure 'reboot' as well as 'systemctl reboot' perform sync before rebooting. This should prevent the situations when some important files (like the kernel, drivers, initrd, etc.) are updated but seem to disappear or are broken after reboot because they were not actually written to the drive by a file system.


Build lists:
i586:
https://abf.rosalinux.ru/build_lists/2278458
x86_64:
https://abf.rosalinux.ru/build_lists/2278459


Hints for testing:
Please try installing kernels, regenerating initrds and/or just copying some big file with 'dd', etc., then executing 'reboot' immediately. See if anything wrong happens in the system this way.
Comment 2 Vladimir Potapov 2014-10-16 07:26:49 MSD
systemd-208-37
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2278458/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2278459/x86_64/main/release/
************************ Advisory **********************
Systemd was patched to make sure 'reboot' as well as 'systemctl reboot' perform sync before rebooting. This should prevent the situations when some important files (like the kernel, drivers, initrd, etc.) are updated but seem to disappear or are broken after reboot because they were not actually written to the drive by a file system.
********************************************************
QA Verified