Bug 447 - Strange behaviour of Rosa-media-player while watching movie in fullscreen
: Strange behaviour of Rosa-media-player while watching movie in fullscreen
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Evgeniy Auzhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 08:33 MSD by FirstLevel
Modified: 2012-10-12 11:16 MSD (History)
2 users (show)

See Also:
RPM Package: rosa-media-player-1.0-0.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-06-27 08:33:33 MSD
Description of problem:
When I see the movie with rosa-media-player in fullscreen I expect that when I
move mouse cursor to bottom of the screen the progressbar and minimal
controlpanel is appeared. But in 90% of cases it is not appeared.
When I see this movie with VLC - progressbar with controls is appeared
everytime when I move mouse to the bottom of the screen

[root@localhost ~]# lspcidrake
sdhci_pci       : Ricoh Co Ltd|R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
[SYSTEM_SDHCI] (rev: 20)
firewire_ohci   : Ricoh Co Ltd|R5C832 IEEE 1394 Controller [SERIAL_FIREWIRE]
(rev: 03)
yenta_socket    : Ricoh Co Ltd|RL5c476 II [BRIDGE_CARDBUS] (rev: b9)
yenta_socket    : Ricoh Co Ltd|RL5c476 II [BRIDGE_CARDBUS] (rev: b9)
iwlagn          : Intel Corporation|PRO/Wireless 4965 AG or AGN [Kedron]
Network Connection [NETWORK_OTHER] (rev: 61)
ahci            : Intel Corporation|82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI
Controller [STORAGE_SATA] (rev: 03)
ata_piix        : Intel Corporation|82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller
[STORAGE_IDE] (rev: 03)
iTCO_wdt        : Intel Corporation|82801HBM (ICH8M-E) LPC Interface Controller
[BRIDGE_ISA] (rev: 03)
unknown         : Intel Corporation|82801 Mobile PCI Bridge [BRIDGE_PCI] (rev:
f3)
ehci_hcd        : Intel Corporation|82801H (ICH8 Family) USB2 EHCI Controller
#1 [SERIAL_USB] (rev: 03)
uhci_hcd        : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #3
[SERIAL_USB] (rev: 03)
uhci_hcd        : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #2
[SERIAL_USB] (rev: 03)
uhci_hcd        : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #1
[SERIAL_USB] (rev: 03)
shpchp          : Intel Corporation|82801H (ICH8 Family) PCI Express Port 5
[BRIDGE_PCI] (rev: 03)
shpchp          : Intel Corporation|82801H (ICH8 Family) PCI Express Port 2
[BRIDGE_PCI] (rev: 03)
shpchp          : Intel Corporation|82801H (ICH8 Family) PCI Express Port 1
[BRIDGE_PCI] (rev: 03)
snd_hda_intel   : Intel Corporation|82801H (ICH8 Family) HD Audio Controller
(rev: 03)
ehci_hcd        : Intel Corporation|82801H (ICH8 Family) USB2 EHCI Controller
#2 [SERIAL_USB] (rev: 03)
uhci_hcd        : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #5
[SERIAL_USB] (rev: 03)
uhci_hcd        : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #4
[SERIAL_USB] (rev: 03)
e1000e          : Intel Corporation|82566MM Gigabit Network Connection
[NETWORK_ETHERNET] (rev: 03)
unknown         : Intel Corporation|Mobile GM965/GL960 Integrated Graphics
Controller [DISPLAY_OTHER] (rev: 0c)
Card:Intel 810 and later: Intel Corporation|Mobile GM965/GL960 Integrated
Graphics Controller [DISPLAY_VGA] (rev: 0c)
unknown         : Intel Corporation|Mobile PM965/GM965/GL960 Memory Controller
Hub [BRIDGE_HOST] (rev: 0c)
[root@localhost ~]# 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Evgeniy Auzhin 2012-07-03 10:48:54 MSD
This bug was fixed in new release of ROSA-media-player. It will be published soon.
Btw you may test it now by getting new version of romp from my personal repository.

i586: urpmi.addmedia thesaint_personal http://abf.rosalinux.ru/downloads/thesaint_personal/repository/rosa2012lts/i586/main/release

x86_64: urpmi.addmedia thesaint_personal http://abf.rosalinux.ru/downloads/thesaint_personal/repository/rosa2012lts/x86_64/main/release
Comment 2 FirstLevel 2012-07-04 21:00:04 MSD
I have not found rosa-media-player in Your repo.
Comment 3 Evgeniy Auzhin 2012-07-06 14:44:03 MSD
(In reply to comment #2)
> I have not found rosa-media-player in Your repo.

Sorry, i built it in import_personal at first instead of thesaint_personal. It should be ok now.
Comment 4 FirstLevel 2012-07-06 19:05:09 MSD
(In reply to comment #3)
> (In reply to comment #2)
> > I have not found rosa-media-player in Your repo.
> 
> Sorry, i built it in import_personal at first instead of thesaint_personal.
> It should be ok now.

I have verified new package. It is OK, controlpanel is appeared every time.
But there is a slight nuance. Wneh controlpanel is appeared picture on the screen is blinking. And I have this situation every time. Is is normal behavior?
Comment 5 FirstLevel 2012-07-06 19:12:30 MSD
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > I have not found rosa-media-player in Your repo.
> > 
> > Sorry, i built it in import_personal at first instead of thesaint_personal.
> > It should be ok now.
> 
> I have verified new package. It is OK, controlpanel is appeared every time.
> But there is a slight nuance. Wneh controlpanel is appeared picture on the
> screen is blinking. And I have this situation every time. Is is normal
> behavior?

And also one important thing.
There is the position on the screen which is responsible for appearing the controlpanel. And when I move mouse to this position but don't cross it I have the situation that picture on the screen is blinking and not stop blinking until I move mouse to the top or to the bottom of this position.
It looks like repeating  "slight nuance".
This second problem is more significant in my opinion
Comment 6 Evgeniy Auzhin 2012-07-09 11:18:51 MSD
I know about "blinking" problem. It is also appear in other players such as VLC and Totem. If you want to remove this issue you can go to kde contol center -> desktop effects -> advanced and uncheck "Suspend desktop effects for fullscreen window" option.
Comment 7 FirstLevel 2012-07-09 12:00:28 MSD
Thanks for the explanation
Comment 8 FirstLevel 2012-07-13 08:53:55 MSD
Please build these packages for testing by QA (according to http://wiki.rosalab.ru/en/index.php/Requesting_an_Update#What_should_a_maintainer_do)
Comment 9 FirstLevel 2012-10-12 11:16:05 MSD
The problem is solved in actual packages