Bug 4410 - Random Banshee crashes
: Random Banshee crashes
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: GNOME edition
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Arkady L. Shane
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-19 17:56 MSD by Ben Aceler
Modified: 2015-05-18 17:33 MSD (History)
1 user (show)

See Also:
RPM Package: banshee-2.6.1-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Aceler 2014-09-19 17:56:34 MSD
Description of problem:
Banshee crashes at a random time.

Version-Release number of selected component (if applicable):
Banshee 2.6.1: [mandriva %{distro_release} (linux-gnu, x86_64) @ 2013-04-26 21:30:04 MSK]

How reproducible:
Crashes randomly, several times a day.


Stack trace:

Unhandled Exception: System.ObjectDisposedException: The object was used after being disposed.
  at System.Threading.WaitHandle.CheckDisposed () [0x00000] in <filename unknown>:0 
  at System.Threading.EventWaitHandle.Reset () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Threading.EventWaitHandle:Reset ()
  at Hyena.Data.Sqlite.HyenaSqliteCommand.Execute (Hyena.Data.Sqlite.HyenaSqliteConnection hconnection, Hyena.Data.Sqlite.Connection connection) [0x00000] in <filename unknown>:0 
  at Hyena.Data.Sqlite.HyenaSqliteConnection.ProcessQueue () [0x00000] in <filename unknown>:0 
  at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.ObjectDisposedException: The object was used after being disposed.
  at System.Threading.WaitHandle.CheckDisposed () [0x00000] in <filename unknown>:0 
  at System.Threading.EventWaitHandle.Reset () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Threading.EventWaitHandle:Reset ()
  at Hyena.Data.Sqlite.HyenaSqliteCommand.Execute (Hyena.Data.Sqlite.HyenaSqliteConnection hconnection, Hyena.Data.Sqlite.Connection connection) [0x00000] in <filename unknown>:0 
  at Hyena.Data.Sqlite.HyenaSqliteConnection.ProcessQueue () [0x00000] in <filename unknown>:0 
  at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
Comment 1 Denis Silakov 2015-03-29 16:00:11 MSD
Could you please try new banshee 2.9.1 which has bee recently published to repositories?
Comment 2 Denis Silakov 2015-05-18 17:33:30 MSD
Well, let's optimistically call this fixed, since we didn't receive any error reports concerning banshee. Feel free to reopen if you still experience any issues.