Bug 4394 - ibus does not work with Rosa 2012.1 Fresh
: ibus does not work with Rosa 2012.1 Fresh
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-18 09:27 MSD by Zombie Ryushu
Modified: 2014-10-22 17:29 MSD (History)
2 users (show)

See Also:
RPM Package: ibus
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2014-09-18 09:27:59 MSD
ibus does not work with Rosa 2012.1 Fresh, because at build  time pkgconfig(gconf-2.0) and python-gi are missing causing ibus to crash with a Python error.

To fix this I have modified Rosa ibus on the ABF Cluster upgrading to to 1.5.8, adding needed dependencies, and importing marisa, and ibus-kcc packages. These need to be considered bugfix updates. Additionally, This fixes Japanese support in ibus.
Comment 1 Denis Silakov 2014-10-22 17:29:07 MSD
Updates from zombie/ibus project have been merged, together with marisa and kcc* packages. All new packages should be available in Fresh R4 repositories.