Bug 4388 - /usr/bin/rst2man: /usr/bin/python3: bad interpreter
: /usr/bin/rst2man: /usr/bin/python3: bad interpreter
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: i586 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-15 21:20 MSD by symbianflo
Modified: 2014-10-08 21:00 MSD (History)
2 users (show)

See Also:
RPM Package: python-docutils/python3-docutils
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description symbianflo 2014-09-15 21:20:35 MSD
Description of problem:
rst2man is the binary provided by python-docutils, and have the same name as the binary provided by python3-docutils, also the emacs integration , produce same  filenames, and during the build  looks like the binary from python-docutils, was build on python3.3 api, so if used, the error is:
#
/usr/bin/rst2man: /usr/bin/python3: bad interpreter
#
Version-Release number of selected component (if applicable):
Name        : python-docutils
Version     : 0.11
Release     : 1
Group       : Development/Python
Size        : 3965912                      
Architecture: noarch
Source RPM  : python-docutils-0.11-1.src.rpm
URL         : http://docutils.sourceforge.net/
Summary     : Python Documentation Utilities                                                                                
How reproducible:
Steps to Reproduce:
1.rst2man -q README man.1
I've split python-docutils from pytho3-docutils and define as conflicted 
in 2014.1, and merge with 2012.1.
Since those builds python3-docutils, and python-docutils are two separate gits and conflicts one with another.
Comment 1 symbianflo 2014-09-15 21:24:06 MSD

Advisory: update and fix

[UPDATE AND FIX REQUEST] python-docutils

Rosa2012.1/main:
https://abf.rosalinux.ru/build_lists/2202499
https://abf.rosalinux.ru/build_lists/2202500
Comment 2 Alexander Petryakov 2014-09-20 03:20:54 MSD
Symbian, please clarify.
How did you  run rst2man from python-docutils with python3?
I see in Fresh R3 that rst2man use /usr/bin/python 
in default system we have
lrwxrwxrwx 1 root root    7 апр.  25 17:06 python -> python2*
lrwxrwxrwx 1 root root    9 апр.  25 17:06 python2 -> python2.7*
-rwxr-xr-x 1 root root 5508 дек.   4  2013 python2.7*

And rst2man from python3-docutils use /usr/bin/python3
lrwxrwxrwx 1 root root    9 сент. 20 02:46 python3 -> python3.3*
lrwxrwxrwx 1 root root    8 сент. 20 02:46 python3-2to3 -> 2to3-3.3*
lrwxrwxrwx 1 root root   10 сент. 20 02:46 python3.3 -> python3.3m*
-rwxr-xr-x 1 root root 5544 февр. 12  2014 python3.3m*

p.s. 
python-docutils-0.11-1-rosa2012.1.noarch
python3-docutils-0.12-8-rosa2012.1.noarch.rpm

Distributor ID: RosaDesktopFresh
Description:    ROSA Desktop Fresh R3
Release:        2012.1
Codename:       belka
Comment 3 symbianflo 2014-09-20 09:03:48 MSD
(In reply to comment #2)
> Symbian, please clarify.
> How did you  run rst2man from python-docutils with python3?
> I see in Fresh R3 that rst2man use /usr/bin/python 
> in default system we have
> lrwxrwxrwx 1 root root    7 апр.  25 17:06 python -> python2*
> lrwxrwxrwx 1 root root    9 апр.  25 17:06 python2 -> python2.7*
> -rwxr-xr-x 1 root root 5508 дек.   4  2013 python2.7*
> 
> And rst2man from python3-docutils use /usr/bin/python3
> lrwxrwxrwx 1 root root    9 сент. 20 02:46 python3 -> python3.3*
> lrwxrwxrwx 1 root root    8 сент. 20 02:46 python3-2to3 -> 2to3-3.3*
> lrwxrwxrwx 1 root root   10 сент. 20 02:46 python3.3 -> python3.3m*
> -rwxr-xr-x 1 root root 5544 февр. 12  2014 python3.3m*
> 
> p.s. 
> python-docutils-0.11-1-rosa2012.1.noarch
> python3-docutils-0.12-8-rosa2012.1.noarch.rpm
> 
> Distributor ID: RosaDesktopFresh
> Description:    ROSA Desktop Fresh R3
> Release:        2012.1
> Codename:       belka

I'm sorry I forgot to mention that looks like only 586 is affected :
http://file-store.rosalinux.ru/api/v1/file_stores/66553d8c181e0bb874d058057ae6d6c819800342.log?show=true
( corrected now, platform 586, sorry again)


I guess because it was build in the same buildroot both , python2 and python3 
modules and the executable provided  have the same name , I guess the python2 module provided rst2man was overwritten by python3 rst2man, I don't unerstand why only in 586/main ( even if noarch )
Anyway as I've wrote above , since this build python2-docutil and python3-docutils are 2 separate gits to avoid this situations, , so I gladly keep those two separate gits with separate builds conflicted each other.
And since we have python 2.7 support till 2020 we will keep python2.7 as default for a while , so I guess is more clean and safe 
to divide the builds in situation like this when the provided files have the same name.
I've already start this in contrib for this kind of python modules.
Thank you.
Comment 4 symbianflo 2014-09-20 09:07:54 MSD
Forgot to mention that 
python3-docutils-0.12-8-rosa2012.1.noarch.rpm
that you mention it above is alredy fixed and conflicts with pyhton-docutils, since is in contrib , I've already done the update and fix.
greetings
Comment 5 Denis Silakov 2014-10-08 16:45:39 MSD
Fixed in Desktop Fresh R4. All users of Fresh R3 are highly encouraged to
update to R4, since R3 will be no longer supported.
Comment 6 symbianflo 2014-10-08 21:00:59 MSD
(In reply to comment #5)
> Fixed in Desktop Fresh R4. All users of Fresh R3 are highly encouraged to
> update to R4, since R3 will be no longer supported.

Of course is no longer actual. 
Thanks .