Bug 4385 - Нет доступа к samba-сети
: Нет доступа к samba-сети
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High critical
: 2014 Fresh R4
Assigned To: Stanislav Fomin
: ROSA Linux Bugs
:
Depends on:
Blocks: 4358
  Show dependency treegraph
 
Reported: 2014-09-12 09:02 MSD by Vladimir Potapov
Modified: 2014-10-06 10:38 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
скриншот (63.57 KB, image/png)
2014-09-12 09:02 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2014-09-12 09:02:19 MSD
Created attachment 3200 [details]
скриншот

Образ 6027x64 (проверено также на 6009x86)
Просто не видит самба-шары и всю сеть заодно (см. скриншот)
В 5970 видело. 
В 6009 кроме этого лежал демон самбы, здесь же все нормально
systemctl status smb
smb.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smb.service; enabled)
   Active: inactive (dead) since Пт 2014-09-12 22:44:40 IRKT; 8h left
 Main PID: 4939 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/smb.service

сен 12 22:44:40 localhost systemd[1]: Started Samba SMB Daemon.

но все равно не работает.
Comment 1 Vladimir Potapov 2014-09-12 09:37:11 MSD
при попытке перезапустить самба-демон 
systemctl restart smb
Job for smb.service failed. See 'systemctl status smb.service' and 'journalctl -xn' for details

journalctl -xn показывает, что...

сен 12 14:30:15 localhost smbd[6906]: [2014/09/12 14:30:15.156877,  0] ../lib/util/util.c:216(directory_create_or_exist)
сен 12 14:30:15 localhost smbd[6906]: mkdir failed on directory /var/run/samba/ncalrpc: No such file or directory
сен 12 14:30:15 localhost smbd[6906]: [2014/09/12 14:30:15.157171,  0] ../source3/smbd/server.c:1467(main)
сен 12 14:30:15 localhost smbd[6906]: Failed to create pipe directory /var/run/samba/ncalrpc - No such file or directory
сен 12 14:30:15 localhost systemd[1]: smb.service: main process exited, code=exited, status=255/n/a
сен 12 14:30:15 localhost systemd[1]: Failed to start Samba SMB Daemon.
-- Subject: Unit smb.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit smb.service has failed.
Comment 2 Vladimir Potapov 2014-09-12 10:23:12 MSD
С похожими ошибками не стартует сервис winbind
Comment 3 Vladimir Potapov 2014-09-17 18:00:47 MSD
В последних образах работает, закрываю.
Comment 4 Vladimir Potapov 2014-09-18 12:52:09 MSD
в 6138 опять не работает. и сервис smb и сервис samba не стартуют.
На обеих архитектурах, в лайве и на установленной.
Comment 5 Vladimir Potapov 2014-09-19 13:58:21 MSD
в сегодняшнем обновлении сервисы самбы поднялись.
Но отсутствует просмотр сети.
показывается группа, которой нет в сети и на попытку в нее войти запрашивается пароль. Самба у меня свободная, без паролей и в r3 все работает.
Comment 6 Vladimir Potapov 2014-09-22 06:55:03 MSD
В 6189 всё заработало.
Comment 7 Vladimir Potapov 2014-10-01 14:39:01 MSD
В 6423x64 опять не работает. Пользователь не в группе sambashare, но даже добавление не помогает. Видится одна родная группа, зайти в нее не получается.
Comment 8 Vladimir Potapov 2014-10-04 19:36:58 MSD
(In reply to comment #7)
> В 6423x64 опять не работает. Пользователь не в группе sambashare, но даже
> добавление не помогает. Видится одна родная группа, зайти в нее не
> получается.

в 6520x64 с группой все нормально, но не работает. При этом на слабом нетбуке со старой сборкой рядом все прекрасно пашет. Правда, там 586... сейчас проверю новую.
Comment 9 Vladimir Potapov 2014-10-06 08:10:07 MSD
в 6526 все уже вполне прилично.
Правда, в лайве и после первой загрузки видится какой-то localhost, в который нельзя зайти без пароля, но потом он исчезает и все работает.
Единственное НО - видится только своя группа, от других даже названий нету. 
А т.к. она "mygroup" (что нестандартно для винды) будут вопросы.
Предлагаю сделать простейшее изменение - изменить "mygroup" на "workgroup"
Просто для совместимости (у меня даже в двух роутерах "workgroup" по-умолчанию).
Comment 10 Vladimir Potapov 2014-10-06 08:12:58 MSD
(In reply to comment #9)
> в 6526 все уже вполне прилично.
> Правда, в лайве и после первой загрузки видится какой-то localhost, в
> который нельзя зайти без пароля, но потом он исчезает и все работает.
поправка - после каждой загрузки, в том числе и в лайве.
Comment 11 Vladimir Potapov 2014-10-06 10:38:30 MSD
Этот баг закрываю тогда, открою новые.