Bug 4355 - Could not set up any printer in ROSA 2014 (system-config-printer)
: Could not set up any printer in ROSA 2014 (system-config-printer)
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High critical
: 2014 Fresh R4
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-04 15:18 MSD by FirstLevel
Modified: 2014-09-13 21:02 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
printer.png (185.19 KB, image/png)
2014-09-04 15:18 MSD, FirstLevel
Details
printer1.png (190.45 KB, image/png)
2014-09-04 15:18 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2014-09-04 15:18:27 MSD
Created attachment 3162 [details]
printer.png

Description of problem:
Image 5970.

I have installed ROSA 2014 and set up repository from http://abf-downloads.rosalinux.ru/rosa2014.1/repository/i586/
If I launch "Настройки принтера" I see window wih suggestions to install two packages- printer.png.
If I choose "Да" - nothing happens.
If I launch system-config-printer from konsole I see that after clicking "Да" an error occurs - printer1.png

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-09-04 15:18:39 MSD
Created attachment 3163 [details]
printer1.png
Comment 2 FirstLevel 2014-09-04 15:19:39 MSD
[root@r4 ~]# system-config-printer
/usr/share/system-config-printer/timedops.py:36: PyGIDeprecationWarning: Since version 3.11, calling threads_init is no longer needed. See: https://wiki.gnome.org/PyGObject/Threading
  GObject.threads_init ()
/usr/share/system-config-printer/system-config-printer.py:2099: PyGIDeprecationWarning: Since version 3.11, calling threads_init is no longer needed. See: https://wiki.gnome.org/PyGObject/Threading
  GObject.threads_init()
/usr/share/system-config-printer/system-config-printer.py:219: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "name" or use a class specific constructor. See: https://wiki.gnome.org/PyGObject/InitializerDeprecations
  Gtk.ActionGroup ("PrinterManagerActionGroup")
пакет task-printing-server не установлен
пакет task-printing-hp не установлен
Error: Can't locate object method "enable_exceptions2" via package "Glib" at /usr/bin/gurpmi line 23.

пакет task-printing-server не установлен
пакет task-printing-hp не установлен
[root@r4 ~]#
Comment 3 Denis Silakov 2014-09-04 15:26:29 MSD
Will it help to remove /usr/bin/gurpmi file and make it a symlink to /usr/bin/gurpmi2?
Comment 4 FirstLevel 2014-09-04 15:32:16 MSD
And gurpmi does not work
[root@r4 Загрузки]# gurpmi jre-7u67-linux-i586.rpm 
Error: Can't locate object method "enable_exceptions2" via package "Glib" at /usr/bin/gurpmi line 23.
Comment 5 FirstLevel 2014-09-04 15:35:22 MSD
(In reply to comment #3)
> Will it help to remove /usr/bin/gurpmi file and make it a symlink to
> /usr/bin/gurpmi2?

No. It does not help. I did it and launch
gurpmi jre-7u67-linux-i586.rpm and have an error "Unknown error"
Comment 6 FirstLevel 2014-09-04 15:38:31 MSD
(In reply to comment #4)
> And gurpmi does not work
> [root@r4 Загрузки]# gurpmi jre-7u67-linux-i586.rpm 
> Error: Can't locate object method "enable_exceptions2" via package "Glib" at
> /usr/bin/gurpmi line 23.

But gurpmi2 package.rpm - works well
Comment 7 Denis Silakov 2014-09-04 16:16:01 MSD
Ok.

Can you try urpmi and gurpmi from here:

(32bit):
https://abf.io/build_lists/2186297

(64bit):
https://abf.io/build_lists/2186298
Comment 8 FirstLevel 2014-09-04 16:34:20 MSD
(In reply to comment #7)
> Ok.
> 
> Can you try urpmi and gurpmi from here:
> 
> (32bit):
> https://abf.io/build_lists/2186297
> 
> (64bit):
> https://abf.io/build_lists/2186298

After updating packages with gurpmi are installed but some error occured after launching gurpmi: (I have tried to install alex package)

[root@r4 Загрузки]# gurpmi alex-3.0.5-3-rosa2014.1.i586.rpm 
Error: Can't locate object method "enable_exceptions2" via package "Glib" at /usr/sbin/gurpmi line 35.

getting exclusive lock on rpm
getting lock on urpmi
using mirror http://abf-downloads.rosalinux.ru/rosa2014.1/repository/i586/
изучается файл synthesis [/var/lib/urpmi/main/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/main updates/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/contrib/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/contrib updates/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/non-free/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/non-free updates/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/restricted/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/restricted updates/synthesis.hdlist.cz]
изучается файл synthesis [/var/lib/urpmi/testurpmi/synthesis.hdlist.cz]
будет произведена установка вместо обновления пакета kernel-nrj-desktop-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-netbook-devel-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-realtime-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-desktop-devel-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-desktop-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-doc-3.14.15-1-rosa2014.1.noarch
будет произведена установка вместо обновления пакета kernel-nrj-desktop-pae-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-desktop-pae-devel-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-source-3.14.15-1rosa-1-1-rosa2014.1.noarch
будет произведена установка вместо обновления пакета kernel-server-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-laptop-pae-devel-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-laptop-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-laptop-pae-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-laptop-devel-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-desktop-devel-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-server-devel-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-netbook-3.14.15-1rosa-1-1-rosa2014.1.i586
будет произведена установка вместо обновления пакета kernel-nrj-realtime-devel-3.14.15-1rosa-1-1-rosa2014.1.i586


устанавливается alex-3.0.5-3-rosa2014.1.i586.rpm
starting installing packages
создана транзакция для установки на / (remove=0, install=0, upgrade=1)
unlocking urpmi database
unlocking rpm database
[root@r4 Загрузки]#
Comment 9 Denis Silakov 2014-09-04 16:39:53 MSD
If the package was installed successfully, the this is not a problem.
Comment 10 Denis Silakov 2014-09-04 19:05:18 MSD
(In reply to comment #9)
> If the package was installed successfully, the this is not a problem.

... on the other hand, I think it's not hard to eliminate the error. I'll try to do this in the next image.
Comment 11 Denis Silakov 2014-09-04 20:05:20 MSD
(In reply to comment #10)
> (In reply to comment #9)
> > If the package was installed successfully, the this is not a problem.
> 
> ... on the other hand, I think it's not hard to eliminate the error. I'll
> try to do this in the next image.

New build lists, error concerning enable_exceptions2 should go away now:

(32bit)
https://abf.io/build_lists/2186321

(64bit)
https://abf.io/build_lists/2186322
Comment 12 FirstLevel 2014-09-05 08:34:20 MSD
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #9)
> > > If the package was installed successfully, the this is not a problem.
> > 
> > ... on the other hand, I think it's not hard to eliminate the error. I'll
> > try to do this in the next image.
> 
> New build lists, error concerning enable_exceptions2 should go away now:
> 
> (32bit)
> https://abf.io/build_lists/2186321
> 
> (64bit)
> https://abf.io/build_lists/2186322


Gurpmi from this updates works without any errors/
Comment 13 Denis Silakov 2014-09-05 10:14:26 MSD
*** Bug 4312 has been marked as a duplicate of this bug. ***
Comment 14 Denis Silakov 2014-09-06 22:24:55 MSD
I have recently published new cups-filters (1.0.54-3) with a fix suggested in bug #4374.

Could you try to update cups-filters and try to use system-config-printer again?
Comment 15 FirstLevel 2014-09-06 22:53:33 MSD
(In reply to comment #14)
> I have recently published new cups-filters (1.0.54-3) with a fix suggested
> in bug #4374.
> 
> Could you try to update cups-filters and try to use system-config-printer
> again?

Sorry, but I could check only next saturday. Does something else have HP printers for testing?
Comment 16 Vladimir Potapov 2014-09-08 09:33:25 MSD
У меня есть парочка HP. Но хотелось бы проверить уже в штатных условиях - с подключенными репами - автодоустановка пакетов ведь.
Comment 17 FirstLevel 2014-09-09 21:13:39 MSD
I have tested image 5994.
After manual adding repos by [root@r4 ~]# urpmi.addmedia  --distrib  http://abf-downloads.rosalinux.ru/rosa2014.1/repository/i586/
I have successfully installed all packages after clicking "Set up printer"  for 32bit system
Comment 18 FirstLevel 2014-09-13 21:02:40 MSD
Case is solved in 6058