Bug 4345 - Iso image does not contain all packages for printing
: Iso image does not contain all packages for printing
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: 2014 Fresh R4
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-04 12:29 MSD by FirstLevel
Modified: 2014-09-19 19:00 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
message (121.12 KB, image/png)
2014-09-04 12:29 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2014-09-04 12:29:37 MSD
Created attachment 3153 [details]
message

Description of problem:
Image 5970
I have started ROSA in live mode and launched "Настройки принтера".
After that I have got a message that I must to install two packages.
Is it an error? I expect that all packages for printer setup should be install always.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-09-04 13:02:47 MSD
case is actual for installed system too
Comment 2 Denis Silakov 2014-09-04 22:35:54 MSD
The main reason due to which task-printing was removed from iso half a year ago was hplip which couldn't detect correctly if it should be loaded or not.

So could somebody perform an experiment - install hplip package (or the whole task-printing) on machine without printer (e.g., inside VM) and check - if you see hp icon in the tray and hp processes in the process list?
Comment 3 FirstLevel 2014-09-05 09:21:46 MSD
(In reply to comment #2)
> The main reason due to which task-printing was removed from iso half a year
> ago was hplip which couldn't detect correctly if it should be loaded or not.
> 
> So could somebody perform an experiment - install hplip package (or the
> whole task-printing) on machine without printer (e.g., inside VM) and check
> - if you see hp icon in the tray and hp processes in the process list?

I have tested this situation.

Default system:
[root@r4 ~]# ps aux | grep hp
root     22505  0.0  0.0   6464   996 pts/1    S+   09:02   0:00 grep --color hp
[root@r4 ~]#

After I have installed  task-printing
[root@r4 ~]# ps aux | grep hp
sergei    5660  0.1  1.9 140124 39584 ?        Ss   09:09   0:00 /usr/bin/python /usr/bin/hp-systray -x
sergei    5747  0.0  0.4  30660  9184 ?        S    09:09   0:00 /usr/bin/python /usr/bin/hp-systray -x
sergei    5748  0.0  0.3  25828  7488 ?        S    09:09   0:00 /usr/bin/python /usr/bin/hp-systray -x
root      9917  0.0  0.0   6464   996 pts/1    S+   09:20   0:00 grep --color hp
[root@r4 ~]# 
and I see HP icon in the tray
Comment 4 FirstLevel 2014-09-13 20:51:22 MSD
(In reply to comment #2)
> The main reason due to which task-printing was removed from iso half a year
> ago was hplip which couldn't detect correctly if it should be loaded or not.
> 
> So could somebody perform an experiment - install hplip package (or the
> whole task-printing) on machine without printer (e.g., inside VM) and check
> - if you see hp icon in the tray and hp processes in the process list?

Please could You give final solution for original problem? Packages will be in system or will not?
Comment 5 Stanislav Fomin 2014-09-17 18:47:54 MSD
Сегодня на ТК решили, hplip-gui включаем. 
Наличие принтеров важнее, чем мешающая иконка.

Женя ШАтохин борется, не факт, что успеет к релизу.
Comment 6 Denis Silakov 2014-09-17 19:02:04 MSD
task-printing has been added to iso package list.
Comment 7 Eugene Shatokhin 2014-09-18 18:58:21 MSD
Пока пакеты с исправленным hplip опубликовать не удаётся, попробуйте, пожалуйста, вот что. В /etc/xdg/autostart/hplip-systray.desktop замените 
  'hp-systray -x'
на
  'hp-systray'

Перезагрузите систему. Теперь значок hp-systray не будет висеть в трее, если на момент загрузки в системе не было настроенных принтеров и факсов HP. 

Правда, если потом настроить такое устройство, hp-systray автоматически не запустится, только после перезагрузки. Либо можно запустить его вручную.
Comment 8 FirstLevel 2014-09-18 20:15:18 MSD
Для образа 6166 имею полный пакет дров и отсутствующий значок в трее.
[sergei-r4@r4 ~]$ rpm -qa | grep hplip
hplip-hpijs-3.14.6-1-rosa2014.1.i586
hplip-model-data-3.14.6-1-rosa2014.1.i586
hplip-hpijs-ppds-3.14.6-1-rosa2014.1.i586
hplip-3.14.6-1-rosa2014.1.i586
hplip-gui-3.14.6-1-rosa2014.1.i586
[sergei-r4@r4 ~]$ 



Решено?
Comment 9 FirstLevel 2014-09-18 20:16:31 MSD
 
> Правда, если потом настроить такое устройство, hp-systray автоматически не
> запустится, только после перезагрузки. Либо можно запустить его вручную.
А можно это в эррату?
Comment 10 Denis Silakov 2014-09-18 22:48:48 MSD
В эррату добавил

http://wiki.rosalab.ru/en/index.php/Errata_ROSA_Desktop_R4
http://wiki.rosalab.ru/ru/index.php/Errata_ROSA_Desktop_R4

С закрытием подождем, пока пакеты будут.
Comment 11 Eugene Shatokhin 2014-09-19 10:47:11 MSD
Для x64 пакеты с исправленным hplip можно взять отсюда:
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2204771/x86_64/main/release/

Когда ABF приведут в чувство, подготовлю для i586.
Comment 12 FirstLevel 2014-09-19 11:03:41 MSD
(In reply to comment #11)
> Для x64 пакеты с исправленным hplip можно взять отсюда:
> http://abf-downloads.rosalinux.ru/rosa2014.1/container/2204771/x86_64/main/
> release/
> 
> Когда ABF приведут в чувство, подготовлю для i586.

А 64битный образ уже починили? Он ставится?
Comment 13 Vladimir Potapov 2014-09-19 12:08:51 MSD
Принтеры уже есть, а вот xsane забыли. Теперь ведь принтеров мало, одни мфу...
Comment 14 Eugene Shatokhin 2014-09-19 12:16:58 MSD
Пакеты с исправлениями опубликованы в репозитории для i586 и x86_64.
Comment 15 Denis Silakov 2014-09-19 12:43:59 MSD
(In reply to comment #13)
> Принтеры уже есть, а вот xsane забыли. Теперь ведь принтеров мало, одни
> мфу...

Добавил task-printing-scanning, в следующих образах все будет.
Comment 16 FirstLevel 2014-09-19 19:00:46 MSD
Образ 6189

[sergei-r4@r4 ~]$ rpm -qa | grep task-printing-sc
task-printing-scanning-2014-1-rosa2014.1.i586
[sergei-r4@r4 ~]$ rpm -qa | grep xsane
xsane-0.999-2-rosa2014.1.i586
[sergei-r4@r4 ~]$