Bug 4341 - Could not work with database from LO Base
: Could not work with database from LO Base
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Low minor
: 2014 Fresh R4
Assigned To: Denis Silakov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-04 12:12 MSD by FirstLevel
Modified: 2014-09-29 13:39 MSD (History)
3 users (show)

See Also:
RPM Package: libreoffice-base-4.3.1-3-rosa2014.1.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
Error (82.33 KB, image/png)
2014-09-04 12:12 MSD, FirstLevel
Details
base.png (96.86 KB, image/png)
2014-09-17 20:32 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2014-09-04 12:12:42 MSD
Created attachment 3150 [details]
Error

Description of problem:
Image 5970.
I have started ROSA in Live mode and openned LO Base. If I try to create new database an error occured (jre is missing)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-09-04 13:00:05 MSD
case is actual for installed system too
Comment 2 FirstLevel 2014-09-16 21:32:16 MSD
Is this bug or feature?
Comment 3 Denis Silakov 2014-09-16 23:05:22 MSD
Initial error with abcent jre was a bug but should be fixed now (please check - openjdk should be included in latest images).

However, even with jre installed, you will get another error concerning hsqldb. This should be fixed by new LO builds; 32bit build has already finished, you can check it here:
https://abf.rosalinux.ru/build_lists/2202639
Comment 4 Stanislav Fomin 2014-09-17 18:16:55 MSD
Если протестировано и работает — переводите в VERIFIED
Если не починило — переоткрывайте.
Comment 5 FirstLevel 2014-09-17 20:32:30 MSD
При запуске LO Base в полностью  обновленной системе и попытке создания базы получаю теперь новую ошибку
base.png
Comment 6 FirstLevel 2014-09-17 20:32:49 MSD
Created attachment 3204 [details]
base.png
Comment 7 Denis Silakov 2014-09-18 15:12:40 MSD
Подтверждаю. В чисто установленной системе теперь такая ерунда. Интересно, как-то ведь я его однажды заставил работать...
Comment 8 FirstLevel 2014-09-18 20:12:40 MSD
В образе 6166 снова ошибка об отсутствующем jre.
Полагаю, если нужен openkdk, то его над в зависимости привязать
Comment 9 Denis Silakov 2014-09-18 20:30:21 MSD
Нужно, да

Только на последнем ТК мы решили убрать из образа и LO Base, и яву. Я так понимаю, LO Base не убрался? Возможно, он по зависимостям приехал, надо посмотреть.
Comment 10 FirstLevel 2014-09-18 21:16:48 MSD
(In reply to comment #9)
> Нужно, да
> 
> Только на последнем ТК мы решили убрать из образа и LO Base, и яву. Я так
> понимаю, LO Base не убрался? Возможно, он по зависимостям приехал, надо
> посмотреть.

В проинсталенном образе LO Base отсутствует. Я его установил дополнительно. И вот как раз для установки LO Base надо тогда openjdk в зависимости прописать.
Comment 11 Denis Silakov 2014-09-18 22:20:04 MSD
А, отлично.

Да, в зависимости добавим. Но чисто ради этого пока не буду LO пересобирать. Подождем, может еще каких изменений накидаем, а то и работу с hsqldb починим.
Comment 12 FirstLevel 2014-09-19 18:58:43 MSD
Образ 6189. Снова нет в зависимостях у LO Base пакет openjdk.
Появляется ошибка отб отсутсвии jre при открытии базы.
Comment 13 FirstLevel 2014-09-23 10:13:59 MSD
В 6261 ошибка вида base.png
Comment 14 FirstLevel 2014-09-24 08:41:37 MSD
В 6280 64бита ошибка про отсутствие jre
Comment 15 Stanislav Fomin 2014-09-24 16:49:40 MSD
Нужно
* добавить зависимость от jre

Но, все равно не работает с HSQLDb.

К релизу не фиксим — не успеем пересобрать.
Comment 16 Denis Silakov 2014-09-25 12:06:26 MSD
Похоже, решение простое - по умолчанию не ставится не только jre, но и libreoffice-java.

Если поставить libreoffice-java и openjdk, то вообще все должно работать - в том числе и создание БД с HSQLdb
Comment 17 FirstLevel 2014-09-25 13:03:56 MSD
(In reply to comment #16)
> Похоже, решение простое - по умолчанию не ставится не только jre, но и
> libreoffice-java.
> 
> Если поставить libreoffice-java и openjdk, то вообще все должно работать - в
> том числе и создание БД с HSQLdb

Только что попробовал на 64битном образе. Действительно, все работает корректно при наличии этих пакетов.
Comment 18 FirstLevel 2014-09-26 10:36:13 MSD
В 6353 64бита ошибка про отсутствие jre
Comment 19 Vladimir Potapov 2014-09-26 10:59:31 MSD
(In reply to comment #18)
> В 6353 64бита ошибка про отсутствие jre

дык, офис не пересобирали еще...
Comment 20 FirstLevel 2014-09-26 11:37:57 MSD
(In reply to comment #19)
> (In reply to comment #18)
> > В 6353 64бита ошибка про отсутствие jre
> 
> дык, офис не пересобирали еще...

Дык, тестирую образ просто :)
Comment 21 FirstLevel 2014-09-29 10:35:32 MSD
в 6420 ошибка про отсутствие jre
Comment 22 FirstLevel 2014-09-29 13:39:05 MSD
В последних обновлениях - все работает корректно