Bug 432 - [UPDATE REQUEST] json-glib 0.12.6 -> 0.14.2
: [UPDATE REQUEST] json-glib 0.12.6 -> 0.14.2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 430
  Show dependency treegraph
 
Reported: 2012-06-23 06:16 MSD by Andrey Bondrov
Modified: 2012-07-03 16:50 MSD (History)
2 users (show)

See Also:
RPM Package: json-glib
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2012-06-23 06:16:41 MSD
json-glib in Rosa 2012 LTS is too old. We need to update it to 0.14.2.

According to our Upstream Tracker, 0.14.2 is 100% backward compatile with 0.12.6:
http://upstream-tracker.org/versions/json-glib.html

So it's safe to update.
Comment 1 Andrey Bondrov 2012-06-23 06:17:41 MSD
Advisory: "json-glib in Rosa 2012 LTS is too old. We need to update it to 0.14.2."

https://abf.rosalinux.ru/build_lists/619517
https://abf.rosalinux.ru/build_lists/619518
Comment 2 Vladimir Potapov 2012-06-28 14:16:29 MSD
What is the application uses a json-glib? (need to check its performance)
Comment 3 Alexander Burmashev 2012-06-28 16:26:02 MSD
Vladimir, actually i am not sure that it can be properly tested by launching some external application and checking it's perfomance. This version is backwards compatible with previous one. ( Check the link, given by Andrey Bondrov ).
And as far as i can see package was built in a sane environment, on a proper package base, package internal tests were not disabled ( so all package tests passed fine ). If you can check that it installs ok and there is no easily noticed MAJOR regressions i would call this update valid.
Comment 4 Vladimir Potapov 2012-06-29 14:38:49 MSD
libjson-glib1.0_0-0.12.6-2-rosa.lts2012.0
********** Advisory ************
json-glib in Rosa 2012 LTS is too old. We need to update it to 0.14.2.
*******************************
QA Verified