Bug 4315 - Broadcom BCM4322 WiFi doesn't work
: Broadcom BCM4322 WiFi doesn't work
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: -Enter Bugs Here-
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Desktop Triage Team
: Desktop Triage Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-14 15:40 MSD by Andrey Ponomarenko
Modified: 2014-08-15 13:17 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2014-08-14 15:40:12 MSD
Description of problem:

The PC can't locate any WiFi networks using BCM4322 with b43-firmware installed. If I install b43-firmware-install package (upstream firmware), then all works fine.

Device ID="pci:14e4-432b-1028-000d"


Version-Release number of selected component (if applicable):
ROSA Fresh R2
x86_64
Intel powered classmate PC

How reproducible:
always
Comment 1 Eugene Shatokhin 2014-08-15 13:17:19 MSD
An interesting fact is, b43-firmware provides *newer* firmware (corresponding to the version 6.30.163.46 of the proprietary driver) than b43-firmware-install installs (the latter corresponds to version 5.100.138 of the driver).

Anyway, due to licensing issues, we cannot distribute the firmware files directly.

The users have the following options if b43-firmware does not help:

1. Install b43-firmware-install instead.

2. Install the proprietary driver (dkms-broadcom-wl). This currently works for BCM4313 and newer WiFi adapters and does not work for BCM4311 and BCM4312 due to the issues in the driver, seemingly ignored by Broadcom.