Bug 4314 - Fresh R2 LXDE: can't start any apps after hostname change
: Fresh R2 LXDE: can't start any apps after hostname change
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: -Enter Bugs Here-
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Desktop Triage Team
: Desktop Triage Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-14 12:29 MSD by Andrey Ponomarenko
Modified: 2015-12-28 18:06 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2014-08-14 12:29:45 MSD
Description of problem:
Can't start any applications after hostname change

Version-Release number of selected component (if applicable):
ROSA R2 LXDE
x86_64
Intel powered classmate PC notebook

How reproducible:
always

Steps to Reproduce:
1. open terminal
2. type `sudo hostname intel-classmate`
3. close terminal
4. click on the terminal or any other icon on the desktop (it doesn't start)
Comment 1 Denis Silakov 2015-05-25 17:50:47 MSD
This iscaused by the fact that X11 use hostname as a part of authorization (just take a look at your ~/.Xauthority file - it is likely that you will see your hostname there). After you change the hostname, this autorization becomes invalid and applications can't connect to X server.

We are not alone with this problem (https://bugs.mageia.org/show_bug.cgi?id=5230, https://forums.pcbsd.org/thread-12140.html, ...).
Comment 2 Denis Silakov 2015-12-28 18:06:45 MSK
I remember we tried to address this issue and likely solved the problem. At least there is no such an issue in recent LXQt images.