Bug 424 - Installation is finished with dracut#
: Installation is finished with dracut#
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 14:00 MSD by FirstLevel
Modified: 2014-06-09 09:41 MSD (History)
6 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
error message (401.30 KB, image/jpeg)
2012-06-20 14:00 MSD, FirstLevel
Details
the menu I get if I press F1, Esc if ISO is being booted (20.33 KB, image/png)
2012-07-23 17:05 MSD, Pavel Shved
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-06-20 14:00:21 MSD
Created attachment 295 [details]
error message

Description of problem:
I have tried to install ROSA 2012 LTS EE x64 on my system (MB - P5Q SE2;
Proc -  intel(r) Core(TM) Duo CPU E7500 @ 2.93GHz; video - nVidia  G92 (GeForce GTS 250); CD/DVD - PIONEER DVD-RW  DVR-216D, HDD - Seagate Technology 500418AS) with partitions Primary: ‎2 (sda1, sda2),  Extended: ‎7 (sda5, sda6, sda7, sda8, sda9, sda10, sda11). But installation is finished with error (screenshot is attached).
I have checked md5summ of iso-image, it is correct.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-07-12 08:32:01 MSD
Is there any comments from developers?
Comment 2 Denis Silakov 2012-07-13 23:38:17 MSD
Are you able to install any other Linux distribution on that machine? 

If yes, could you try to install ROSA from iso image using that distribution bootloader, as described here:

http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file
Comment 3 Postnikov Dmitry 2012-07-14 00:12:44 MSD
(In reply to comment #2)
> If yes, could you try to install ROSA from iso image using that distribution
> bootloader, as described here:
> 
> http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file

This is the official method? Or the script in development and an experimental?

PS: Why is a page not linked anywhere in the wiki? I have all the pages in the wiki bind them, but I'm all for people not to follow. :)
Comment 4 Denis Silakov 2012-07-14 09:04:30 MSD
(In reply to comment #3)
> (In reply to comment #2)
> > If yes, could you try to install ROSA from iso image using that distribution
> > bootloader, as described here:
> > 
> > http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file
> 
> This is the official method? Or the script in development and an
> experimental?

I would consider this as experimental, since up to now I am probably the only man who have tried it:) However, this method shouldn't damage your system; in the worst case, ROSA installer will fail to load, but the main system will remain unchanged. So feel free to experiment.
 
> PS: Why is a page not linked anywhere in the wiki? I have all the pages in
> the wiki bind them, but I'm all for people not to follow. :)

I have created it only a couple of days ago. Not sure where to link it. Maybe we should create a separate subsection devoted to different ways of ROSA installation (and there is one more page from this series created not long ago and not linked anywhere - http://wiki.rosalab.ru/ru/index.php/Установка_Parallels_Tools). But I think it's better to discuss this in forum devoted to our wiki.
Comment 5 FirstLevel 2012-07-16 09:49:27 MSD
(In reply to comment #2)
> Are you able to install any other Linux distribution on that machine? 
> 
> If yes, could you try to install ROSA from iso image using that distribution
> bootloader, as described here:
> 
> http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file

Do I understand it correctly, that user need to install some other linux distribution and from it install ROSA? What distribution do You recomend?
Comment 6 Denis Silakov 2012-07-16 10:30:36 MSD
(In reply to comment #5)
> (In reply to comment #2)
> > Are you able to install any other Linux distribution on that machine? 
> > 
> > If yes, could you try to install ROSA from iso image using that distribution
> > bootloader, as described here:
> > 
> > http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file
> 
> Do I understand it correctly, that user need to install some other linux
> distribution and from it install ROSA? What distribution do You recomend?

It would be nice to try Fedora, since we have similar boot procedure. But actually any distribution should work (if it installs to your hardware successfully).

You can even try to install grub4dos in windows and configure it to use the iso file, but I haven't tried this way.
Comment 7 FirstLevel 2012-07-16 10:53:21 MSD
Ok, I'll inform user about this method.
Is there russian translation of this article http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file ?
Comment 9 FirstLevel 2012-07-20 14:11:03 MSD
(In reply to comment #2)
> Are you able to install any other Linux distribution on that machine? 
> 
> If yes, could you try to install ROSA from iso image using that distribution
> bootloader, as described here:
> 
> http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file

Аuthor of problem do not want to install other system for installation ROSA.
Is there other solultion?
Comment 10 Pavel Shved 2012-07-20 15:11:30 MSD
Technically, we could attach the patched initrd file the script linked at that wiki page would extract, and try to use the bootloader that already presents on a user's flash drive (if he or she successfully got to dracut, that menas that their bootloader is OK).

However, I didn't manage to edit the boot menu the livecd contains.  I could only edit kernel parameters, but not the other lines of Grub config.  Maybe, it's somehow possible?
Comment 11 Denis Silakov 2012-07-20 16:11:57 MSD
(In reply to comment #10)
> 
> However, I didn't manage to edit the boot menu the livecd contains.  I could
> only edit kernel parameters, but not the other lines of Grub config.  Maybe,
> it's somehow possible?

You can try to enter the grub console and type all necessary commands there, i.e.:
$ root=/dev/sda1
$ kernel=/path/to/kernel
$ initrd=/path/to/initrd
$ boot

I guess it should work, but haven't tried by myself, maybe something more should be added.
Comment 12 Pavel Shved 2012-07-22 12:07:26 MSD
(In reply to comment #11)
> You can try to enter the grub console 

How exactly do I enter there?  What should I press, and at what stage?  I tried like all the possible key combinations as if I was pixel-hunting in a badly designed quest game X-)
Comment 13 Denis Silakov 2012-07-22 12:44:47 MSD
Indeed, this is a little tricky.

1) When you see grub menu (where you choose OS to boot), press F1 and then Esc. This will bring you to the text-mode grub menu.
2) Now press 'c'.

Not sure if there is a more straightforward way, 'c' by itself doesn't work in our graphical menu.
Comment 14 Pavel Shved 2012-07-23 17:05:20 MSD
Created attachment 423 [details]
the menu I get if I press F1, Esc if ISO is being booted

(In reply to comment #13)
> Indeed, this is a little tricky.
> 
> 1) When you see grub menu (where you choose OS to boot), press F1 and then
> Esc. This will bring you to the text-mode grub menu.
> 2) Now press 'c'.
> 
> Not sure if there is a more straightforward way, 'c' by itself doesn't work
> in our graphical menu.

When I press "Esc", or any f-key and then Esc, it only gets me to a line where I can select a kernel to boot, not to a Grub menu (see screenshot: that's all the menu I can get).  It seems to allow to enter the portion of Grub config line that comes after "kernel ".  It can boot the default "vmlinuz0" from there, but I can't specify kernel using (hd*,*) notation in this line.

Is there a way to get to the _real_ grub menu from the usb flash?
Comment 15 Denis Silakov 2012-07-25 15:14:46 MSD
Uh-oh, in the iso omage we use isolinux, not grub. I'm afraid it is impossible to force isolinux to boot some image from hard drive partition...
Comment 16 FirstLevel 2012-07-25 15:25:13 MSD
(In reply to comment #2)
> Are you able to install any other Linux distribution on that machine? 
> 
> If yes, could you try to install ROSA from iso image using that distribution
> bootloader, as described here:
> 
> http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file

Denis, another user who try to install ROSA folllowing Your instruction have responded:
"Стоит дополнить что инструкция на сайте неполная. 

Dowload rosa-fromiso script, make it executable and launch to create a special initrd file to allow booting from iso image:

\"wget https://abf.rosalinux.ru/dsilakov/rosa-fromiso/raw/master/rosa-fromiso
chmod a+x rosa-fromiso
./rosa-fromiso ./rosa.iso ./initrd-fromiso

If you use a system with grub-legacy (grub version 0.9x), you should additionally extract vmlinuz0 file from the iso:

mkdir /mnt/iso
mount -o loop rosa.iso /mnt/iso
cp /mnt/iso/isolinux/vmlinuz0 /rosa

Now you should add necessary menu entries to your bootloader configuration.

For grub legacy, add the following lines to the menu.lst:
 title ROSA Live
 root (hd0,0)
 kernel /rosa/vmlinuz0 root=live:/rosa/rosa.iso rootfstype=auto ro liveimg vga=788 desktop nopat rd_NO_LUKS rd_NO_MD noiswmd splash=silent logo.nologo nomodeset
 initrd /rosa/rosa_initrd\"

ошибка в том что сообщается о том что на выходе будет ./initrd-fromiso в то время как в конфигурациях GRUB нет об этом ни слова..."

Is instruction correct?
Comment 17 Denis Silakov 2012-07-25 15:29:02 MSD
Indeed, this was a mistake, the initrd image should be named 'rosa_initrd', not 'initrd-fromiso'.

I have updated wiki pages.
Comment 18 Denis Silakov 2012-07-25 15:36:46 MSD
As for the bug itself - these symptoms can have different reasons - for example, UEFI (though it seems that P5Q SE2 is an old MB without EFI). Currently we are working on improving UEFI support, probably this will allow us to fix this issue, as well.
Comment 19 Alexander Burmashev 2012-08-03 13:16:47 MSD
I may need additional info: when the system does not boot and you sit at dracut# can you try
 ls -l /dev/disk/by-uuid/

?
Comment 20 Alexander Petryakov 2012-10-24 00:52:33 MSD
The same error on acer V5-171 (CPU i5-3317U) for ROSA.2012.RP1.MARATHON.EE.x86_64.iso

I try install from UsbFlash and Usb-DVDROM.

p.s. In /dev/ (and in /dev/disk/by-uuid) present only sda (system HDD) and his uuids
Comment 21 Denis Silakov 2012-12-25 15:30:21 MSK
It's interesting if ROSA Desktop.Fresh 2012 can be installed on the machines discussed in this bug?
Comment 22 FirstLevel 2014-06-09 09:41:49 MSD
I have not found original case in GLPI.
I'll close bug because we could not take feedback from initiator.