Bug 4237 - [UPDATE REQUEST] midnight-commander mc-4.8.11 to 4.8.12
: [UPDATE REQUEST] midnight-commander mc-4.8.11 to 4.8.12
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-16 20:52 MSD by symbianflo
Modified: 2014-07-31 14:41 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
kuzma.kazygashev: secteam_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description symbianflo 2014-07-16 20:52:40 MSD
Changelog:
Version 4.8.12- Core 
* Speed up of file find (#2290) 
* If cwd is a symlink it is kept at startup (#3093)
* Improve support of Zsh (#3121, #3124, #3125, #3177)
* Launch external editor/viewer without passing line number (#3117)
* Exit without confirmation by default (#3132)
* Simple user-friendly skin selector (#2165, #3178)
* Use Joliet and RockRidge in ISO9660 image view action (#3187)
- VFS
* Use .zip extension as preferred way to recognize ZIP archives (#2857)
- Editor
* Configurable selection reset on CK_Store (#3111)
- Misc
* Code cleanup (#3113, #3151)
* Adjust script permissions to installed ones (#2274)
* Fix name of FSF in add source files (#3167)
* Skin cleanups (#3180, #3184)
* Do not consider 'String not found' message as error (#3179)
- Fixes
* Broken build with NCurses (#3114)
* Incorrect tilde expansion in copy/rename/move dialog (#3131)
* Advanced chown: Escape on user list accepts value (#3150)
* Toggling hidden files using mouse doesn't update the other panel (#3156)
* Question mark in delete confirmation is on its own line (#3123)
* Popup dialogs wander upwards upon resize (#3173)
* Keypad '*' doesn't work with numlock off (#3133)
* Some inconsistencies in 'Learn keys' UI (#3134)
* Unconventional behavior of 'Display bits' dialog (#3152)
* Shift-Fn keys don't work in 256-color mode of tmux (#2978)
* mcedit: format paragraph produces inconsistent wrapping (#3119)
* mcedit: file out-of-date check on saving is botched (#3142)
* mcedit: 1st line is shifted after paragraph format (#1666)
* mcedit: trailing newline check applied too early when exiting (#3140)
* Inconsistency of the arrow's direction in the panel header line across skins (#3157)
* Possible segfault while passing messages to widgets (#3116)
* Possible segfault when freeing a VFS (#3116)
* Segfault in cpio VFS while reading corrupted RPM (#3116)
* Segfault in sftpfs VFS when trying to view a file (#3176)
* Incorrect handling of filenames with unrar v5 (#3073)
* FISH VFS: remote panel confused by filenames with '%' (#2983)
* iso9660: xorriso shows only one depth (#3122)
* Nicedark skin looks bad on black-on-white terminals (#3154)
* Incorrect definition of -topmiddle- and -bottommiddle- characters (#3183)

Version-Release number of selected component (if applicable):
4.8.12
Comment 1 symbianflo 2014-07-16 21:24:42 MSD
Advisory: New bugfix release

[UPDATE REQUEST] mc-4.8.11 to 4.8.12 

QA team can you ,kindly, keep an eye out for the *new* features as fallows:
*-Core-*
-All network protocols, smb, sftp, ftp,ssh,fish.
-unrar5 support
-switch to zip as default compression extension.
-all vfs enabled by default cpio,sftpfs, %rpmbuildroot,fish
-gmp mouse support
-localizations (build with aspell )
-Shift-Function keys work in 256-color mode of tmux.

*-Mcedit-*
-paragraph format errors ware  fixed

*-Look-and-feel-*
-Nicedark skin fixed


***Note***
Ths is pushed from MRB we use it from april without any regressions observed,
but it was tested and used since then mostly in TTY, I guess a proper 
testing is needed in X, also.

Thank you for your attention.
Comment 3 symbianflo 2014-07-16 22:00:41 MSD
Advisory: New bugfix release

[UPDATE REQUEST] mc-4.8.11 to 4.8.12 

https://abf.rosalinux.ru/build_lists/2034829
https://abf.rosalinux.ru/build_lists/2034830
Comment 4 Alexander Petryakov 2014-07-18 01:40:12 MSD
mc-4.8.12-1
https://abf.rosalinux.ru/build_lists/2034829
https://abf.rosalinux.ru/build_lists/2034830

************** Advisory **************
New bugfix release
[UPDATE REQUEST] mc-4.8.11 to 4.8.12 
**************************************
QA Verified