Bug 42 - Can't disable klipper
: Can't disable klipper
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 16:35 MSD by FirstLevel
Modified: 2012-04-16 15:49 MSD (History)
5 users (show)

See Also:
RPM Package: kdebase4-workspace-4.8.2-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-04-12 16:35:41 MSD
Description of problem:
When I've used ROSA2011 I can to disable klipper by clicking mouse on its icon and choosing menu item "Exit"
Klipper in LTS release does not have such menu item. I don't know how to disable klipper.

By the way, I've tried OpenSuse with KDE 4.8.2 and this menu item exists.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Koryavov 2012-04-12 22:17:51 MSD
Yes, we disabled possibility to close Klipper. If you don't use it, just remove it.
Comment 2 FirstLevel 2012-04-13 08:58:41 MSD
Denis, how do I delete klipper if it is a part of kdebase4-workspace?
Comment 3 Denis Koryavov 2012-04-13 12:27:46 MSD
Please, submit bug to pick out Klipper to a single package.
Comment 4 Aleksandr Kazantcev 2012-04-13 12:29:05 MSD
Why delete package?

chmod -x /usr/bin/klipper not worked?
Comment 5 FirstLevel 2012-04-13 12:31:24 MSD
(In reply to comment #4)
> Why delete package?
> 
> chmod -x /usr/bin/klipper not worked?

It's ugly hack for comon users.
Comment 6 Pavel Shved 2012-04-13 12:43:03 MSD
(In reply to comment #4)
> Why delete package?
> 
> chmod -x /usr/bin/klipper not worked?

I do not have this file, neither I have the klipper package installed, but klipper scissors icon is shown in the tray, and I don't know how to disable it.
Comment 7 Pavel Shved 2012-04-13 13:24:40 MSD
Please, correct me if I wrong, but here's what I learned today.

The issue with clipper had been discussed in Mandriva mailing lists prior to its removal.  The thing is that the removal of klipper leads to unexpected and damaged copy-pasting behavior, and even more user complaints than keeping it.  A user may occasionally remove klipper, and his or her copy-pasting may stop working properly (or stop working at all) after that.

Thus, the feature to hide klipper has been removed because it made users shoot themselves in the foot without realizing the consequences.

A friendly way to do this, is to "hide" the icon via System Tray settings.  And an entry in errata and/or in this Bugzilla with a "command-line" solution will probably be provided to those brave ones, Who Know What They're Doing.
Comment 8 Denis Koryavov 2012-04-13 14:45:16 MSD
Yes, everything is correct.
Comment 9 Alexander Burmashev 2012-04-16 15:39:56 MSD
closing the bug as it seems to be discussed and it does not seem to be a bug actually.
Comment 10 Pavel Shved 2012-04-16 15:46:16 MSD
There is a specific resolution for this, "WONTFIX."
Comment 11 Alexander Burmashev 2012-04-16 15:49:33 MSD
Ok, i will note it and use "wontfix" in future.