Bug 4179 - Could not launch ExEf
: Could not launch ExEf
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-30 09:59 MSD by FirstLevel
Modified: 2015-02-07 23:24 MSK (History)
1 user (show)

See Also:
RPM Package: ExEf-1.70-7-rosa2012.1.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
exef.error.txt (4.90 KB, text/plain)
2014-06-30 09:59 MSD, FirstLevel
Details
exef.png (135.76 KB, image/png)
2014-06-30 10:00 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2014-06-30 09:59:53 MSD
Created attachment 3017 [details]
exef.error.txt

Description of problem:
I have installed ROSA Fresh R3 and ExEf package.
If I start ExEf from GUI - nothing happens.
If I start ExEf from konsole - an error occured - exef.error.txt
I have tested on VirtualBox VM with audiocard  - exef.png


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-06-30 10:00:06 MSD
Created attachment 3018 [details]
exef.png
Comment 2 Denis Silakov 2014-06-30 20:48:12 MSD
Try to run "padsp ExEf".
Comment 3 FirstLevel 2014-06-30 21:17:41 MSD
(In reply to comment #2)
> Try to run "padsp ExEf".

Ok. It works. But If i launch ExEf from SimpleWelcome - nothing happens.
Comment 4 Denis Silakov 2014-06-30 21:41:58 MSD
Ok. I've updated ExEf package, now it should be launched through padsp automatically. New package has been recently published to contrib/updates.
Comment 5 FirstLevel 2014-07-01 08:40:43 MSD
ooops
New package has another error

[sergei@freshkdex32 ~]$ ExEf
bash: /usr/bin/ExEf: Отказано в доступе
[sergei@freshkdex32 ~]$ ls -al  /usr/bin/ExEf
-rw-r--r-- 1 root root 37 июня  30 21:23 /usr/bin/ExEf
Comment 6 Denis Silakov 2014-07-01 11:04:04 MSD
Indeed. Pushed one more fix, updated packages have been published.
Comment 7 FirstLevel 2014-07-02 08:15:40 MSD
For ExEf-1.70-9-rosa2012.1.i586.rpm
I could not launch ExEf again.


[test@testnm ~]$ ExEf

ExEf - the ultimate effect engine
ExEf GUI - Copyright (C) 2001 Tom Olexa
Waiting 100 ms for /var/tmp/.ExEf

ExEf - the ultimate effect engine
Copyright (C) 2001 Tom Olexa

Changing directory to /home/test/.ExEf
Can't change: No such file or directory
Copying config files from /usr/share/ExEf
«/usr/share/ExEf» -> «/home/test/ExEf»
«/usr/share/ExEf/configs» -> «/home/test/ExEf/configs»
«/usr/share/ExEf/configs/robots» -> «/home/test/ExEf/configs/robots»
Waiting 200 ms for /var/tmp/.ExEf
«/usr/share/ExEf/configs/metal-modulators» -> «/home/test/ExEf/configs/metal-modulators»
«/usr/share/ExEf/configs/metal-reverbs» -> «/home/test/ExEf/configs/metal-reverbs»
«/usr/share/ExEf/configs/nuclearmetal» -> «/home/test/ExEf/configs/nuclearmetal»
«/usr/share/ExEf/configs/death» -> «/home/test/ExEf/configs/death»
«/usr/share/ExEf/configs/channels» -> «/home/test/ExEf/configs/channels»
«/usr/share/ExEf/configs/channels/metal» -> «/home/test/ExEf/configs/channels/metal»
«/usr/share/ExEf/configs/channels/wah-wah» -> «/home/test/ExEf/configs/channels/wah-wah»
«/usr/share/ExEf/configs/channels/death» -> «/home/test/ExEf/configs/channels/death»
«/usr/share/ExEf/configs/channels/rock» -> «/home/test/ExEf/configs/channels/rock»
«/usr/share/ExEf/configs/channels/telephone» -> «/home/test/ExEf/configs/channels/telephone»
«/usr/share/ExEf/configs/channels/clean» -> «/home/test/ExEf/configs/channels/clean»
«/usr/share/ExEf/configs/channels/tremolo» -> «/home/test/ExEf/configs/channels/tremolo»
«/usr/share/ExEf/configs/channels/phaser» -> «/home/test/ExEf/configs/channels/phaser»
«/usr/share/ExEf/configs/distort-voice» -> «/home/test/ExEf/configs/distort-voice»
«/usr/share/ExEf/configs/telephone» -> «/home/test/ExEf/configs/telephone»
«/usr/share/ExEf/configs/robots-weird» -> «/home/test/ExEf/configs/robots-weird»
«/usr/share/ExEf/configs/aliens» -> «/home/test/ExEf/configs/aliens»
«/usr/share/ExEf/.ExEfrc» -> «/home/test/ExEf/.ExEfrc»
«/usr/share/ExEf/ExEflogo.gif» -> «/home/test/ExEf/ExEflogo.gif»
«/home/test/ExEf» -> «/home/test/.ExEf»
удалён «/home/test/.ExEf/ExEflogo.gif»
Opening .ExEfrc config file
By Tom Olexa
Audio 44100 8
Switch 0 2 5
VUMeters 20 20 1
SaveWave 0 3 start.wav
Loading Column 0: Death
x=0   y=0
Effect type S, Threshold -75 dB, Noise estimation time 99 ms, Estimation end -1 ms
x=0   y=1
Effect type c, No params
x=0   y=2
Effect type g, Gain 65 dB
x=0   y=3
Effect type m, Modulator type p, Wave form s, Modulation depth 50%, Period 512 ms, ParaDir -10 dB
x=0   y=4
Effect type b, Pass type h, Frequency 330 Hz, Q factor -6 dB, Stopband gain -80 dB
a1 = -1.908304e+00, a2 = 9.104148e-01, b0 = 9.551286e-01, b1 = -1.909359e+00, b2 = 9.542307e-01
x=0   y=5
Effect type d, Left distortion S, Right distortion S, ParaDir -100 dB
x=0   y=6
Effect type b, Pass type l, Frequency 4977 Hz, Q factor -6 dB, Stopband gain -80 dB
a1 = -9.201165e-01, a2 = 2.123598e-01, b0 = 7.706130e-02, b1 = 1.460150e-01, b2 = 6.916698e-02
x=0   y=7
Effect type b, Pass type l, Frequency 98 Hz, Q factor 0 dB, Stopband gain -18 dB
a1 = -1.984209e+00, a2 = 9.844027e-01, b0 = 1.298684e-01, b1 = -2.497126e-01, b2 = 1.200377e-01
x=0   y=8
Effect type g, Gain -6 dB
x=0   y=9
Effect type D, Predelay 16 m, X1 26 m, X2 15 m, R1 -5 dB, R2 -7 dB, Output -6 dB
Loading Column 1: Clean
x=1   y=0
Effect type c, No params
x=1   y=1
Effect type g, Gain 13 dB
x=1   y=2
Effect type d, Left distortion a, Right distortion a, ParaDir -120 dB
x=1   y=3
Effect type D, Predelay 14 m, X1 16 m, X2 12 m, R1 -15 dB, R2 -6 dB, Output -10 dB
x=1   y=4
Effect type g, Gain -3 dB
Loading Column 2: Kocour
x=2   y=0
Effect type g, Gain 44 dB
x=2   y=1
Effect type b, Pass type h, Frequency 233 Hz, Q factor -3 dB, Stopband gain -12 dB
a1 = -1.941941e+00, a2 = 9.430117e-01, b0 = 9.874663e-01, b1 = -1.942342e+00, b2 = 9.551446e-01
x=2   y=2
Effect type d, Left distortion a, Right distortion a, ParaDir -20 dB
x=2   y=3
Effect type b, Pass type l, Frequency 3135 Hz, Q factor -3 dB, Stopband gain -80 dB
a1 = -1.382098e+00, a2 = 5.324397e-01, b0 = 4.096795e-02, b1 = 7.502497e-02, b2 = 3.434847e-02
x=2   y=4
Effect type m, Modulator type p, Wave form t, Modulation depth 14%, Period 256 ms, ParaDir -10 dB
x=2   y=5
Effect type g, Gain -12 dB
x=2   y=6
Effect type D, Predelay 0 m, X1 90 m, X2 45 m, R1 -12 dB, R2 -16 dB, Output 0 dB
Loading Column 3: Tuner
x=3   y=0
Effect type s, Frequency 440 Hz, ParaDir 10 dB
Warning: can't lock memory: Cannot allocate memory
Warning: not exclusive realtime mode: Operation not permitted
Opening /dev/dsp...
Soundcard successfully init'd at 44100 Hz
fragments 4
fragstotal 4
fragsize 256 B
bytes 1024
Waiting 400 ms for /var/tmp/.ExEf
Waiting 800 ms for /var/tmp/.ExEf
Waiting 1600 ms for /var/tmp/.ExEf
Waiting 3200 ms for /var/tmp/.ExEf
Waiting 6400 ms for /var/tmp/.ExEf
Waiting 12800 ms for /var/tmp/.ExEf
Waiting 25600 ms for /var/tmp/.ExEf
Waiting 51200 ms for /var/tmp/.ExEf
^C
Comment 8 Denis Silakov 2014-07-07 14:55:47 MSD
Interesting, can't reproduce this issue.

Which permissions do you have for /var/tmp?
Comment 9 FirstLevel 2014-07-08 10:37:28 MSD
(In reply to comment #8)
> Interesting, can't reproduce this issue.
> 
> Which permissions do you have for /var/tmp?

[test@testnm proc]$ ls -al /var/tmp
итого 24
drwxrwxrwt  6 root root 4096 июля   8 10:36 ./
drwxr-xr-x 17 root root 4096 мая   27 12:15 ../
drwx------  2 root root 4096 июля   7 11:12 kdecache-root/
drwx------  6 test test 4096 июля   8 10:36 kdecache-test/
drwx------  3 root root 4096 июля   7 11:12 systemd-cups.service-X6gstu0/
drwx------  3 root root 4096 мая   27 12:15 systemd-cups.service-XeBdcfo/
[test@testnm proc]$
Comment 10 FirstLevel 2014-10-08 22:33:48 MSD
Case is actual for 2014.1
Comment 11 Denis Silakov 2015-02-07 23:24:40 MSK
I have investigated this program deeper and now I don't think that we can make this ancient guitar processor (no updates for more than 10 years) work with modern sound systems.

As far as I can see, all distributions already dropped exef from their repositories. So we have dropped it now, as well. If you need guitar processor, feel free to try gnuitar, guiatrix, rackarrack or other modern software.